Bug 197803 - lockdep: cpufreq vs hotplug lock dependancy.
lockdep: cpufreq vs hotplug lock dependancy.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: Reopened
: 197838 198105 198204 198989 199026 199664 199811 200121 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 10:47 EDT by Tom London
Modified: 2015-01-04 17:27 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-29 13:35:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Excerpt attached in case error message differs (1.38 KB, text/plain)
2006-07-15 21:27 EDT, Jim Cornette
no flags Details

  None (edit)
Description Tom London 2006-07-06 10:47:06 EDT
Description of problem:
After installing .2356, lock dependency detected each time I boot:

=======================================================
[ INFO: possible circular locking dependency detected ]
-------------------------------------------------------
S06cpuspeed/1620 is trying to acquire lock:
 (dbs_mutex){--..}, at: [<c060d6bb>] mutex_lock+0x21/0x24

but task is already holding lock:
 (cpucontrol){--..}, at: [<c060d6bb>] mutex_lock+0x21/0x24

which lock already depends on the new lock.


the existing dependency chain (in reverse order) is:

-> #1 (cpucontrol){--..}:
       [<c043c546>] lock_acquire+0x4b/0x6d
       [<c060d51e>] __mutex_lock_slowpath+0xbf/0x23b
       [<c060d6bb>] mutex_lock+0x21/0x24
       [<c0440009>] __lock_cpu_hotplug+0x36/0x56
       [<c0440042>] lock_cpu_hotplug+0xa/0xc
       [<c04337de>] __create_workqueue+0x52/0x168
       [<f8e6b32e>] cpufreq_governor_dbs+0x9e/0x2cb [cpufreq_ondemand]
       [<c05a724b>] __cpufreq_governor+0x57/0xd8
       [<c05a7409>] __cpufreq_set_policy+0x13d/0x1a9
       [<c05a760c>] store_scaling_governor+0x128/0x151
       [<c05a6c67>] store+0x37/0x48
       [<c04ab4cc>] sysfs_write_file+0xab/0xd1
       [<c047248b>] vfs_write+0xab/0x157
       [<c0472ace>] sys_write+0x3b/0x60
       [<c0403f2f>] syscall_call+0x7/0xb

-> #0 (dbs_mutex){--..}:
       [<c043c546>] lock_acquire+0x4b/0x6d
       [<c060d51e>] __mutex_lock_slowpath+0xbf/0x23b
       [<c060d6bb>] mutex_lock+0x21/0x24
       [<f8e6b503>] cpufreq_governor_dbs+0x273/0x2cb [cpufreq_ondemand]
       [<c05a724b>] __cpufreq_governor+0x57/0xd8
       [<c05a7463>] __cpufreq_set_policy+0x197/0x1a9
       [<c05a760c>] store_scaling_governor+0x128/0x151
       [<c05a6c67>] store+0x37/0x48
       [<c04ab4cc>] sysfs_write_file+0xab/0xd1
       [<c047248b>] vfs_write+0xab/0x157
       [<c0472ace>] sys_write+0x3b/0x60
       [<c0403f2f>] syscall_call+0x7/0xb

other info that might help us debug this:

2 locks held by S06cpuspeed/1620:
 #0:  (&policy->lock){--..}, at: [<c060d6bb>] mutex_lock+0x21/0x24
 #1:  (cpucontrol){--..}, at: [<c060d6bb>] mutex_lock+0x21/0x24

stack backtrace:
 [<c0405167>] show_trace_log_lvl+0x54/0xfd
 [<c040571e>] show_trace+0xd/0x10
 [<c040583d>] dump_stack+0x19/0x1b
 [<c043b63d>] print_circular_bug_tail+0x59/0x64
 [<c043be35>] __lock_acquire+0x7ed/0x98d
 [<c043c546>] lock_acquire+0x4b/0x6d
 [<c060d51e>] __mutex_lock_slowpath+0xbf/0x23b
 [<c060d6bb>] mutex_lock+0x21/0x24
 [<f8e6b503>] cpufreq_governor_dbs+0x273/0x2cb [cpufreq_ondemand]
 [<c05a724b>] __cpufreq_governor+0x57/0xd8
 [<c05a7463>] __cpufreq_set_policy+0x197/0x1a9
 [<c05a760c>] store_scaling_governor+0x128/0x151
 [<c05a6c67>] store+0x37/0x48
 [<c04ab4cc>] sysfs_write_file+0xab/0xd1
 [<c047248b>] vfs_write+0xab/0x157
 [<c0472ace>] sys_write+0x3b/0x60
 [<c0403f2f>] syscall_call+0x7/0xb


Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2356.fc6

How reproducible:
every time


Steps to Reproduce:
1. install .2356
2. boot
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Ball 2006-07-06 13:29:53 EDT
I'm seeing the same message, same offsets.  System's otherwise working fine.
Comment 2 Ronald Warsow 2006-07-06 14:07:31 EDT
I'm seeing a similar message. System's otherwise working fine.

=============================================
Jul  6 13:49:05 FC6 kernel: [ INFO: possible recursive locking detected ]
Jul  6 13:49:05 FC6 kernel: ---------------------------------------------
Jul  6 13:49:05 FC6 kernel: lvm.static/1467 is trying to acquire lock:
Jul  6 13:49:05 FC6 kernel:  (&md->io_lock){----}, at: [<e08ce508>]
dm_request+0x18/0xea [dm_mod]
Jul  6 13:49:05 FC6 kernel: 
Jul  6 13:49:05 FC6 kernel: but task is already holding lock:
Jul  6 13:49:05 FC6 kernel:  (&md->io_lock){----}, at: [<e08ce508>]
dm_request+0x18/0xea [dm_mod]
Jul  6 13:49:05 FC6 kernel: 
Jul  6 13:49:05 FC6 kernel: other info that might help us debug this:
Jul  6 13:49:05 FC6 kernel: 1 lock held by lvm.static/1467:
Jul  6 13:49:05 FC6 kernel:  #0:  (&md->io_lock){----}, at: [<e08ce508>]
dm_request+0x18/0xea [dm_mod]
Jul  6 13:49:05 FC6 kernel: 
Jul  6 13:49:05 FC6 kernel: stack backtrace:
...
Jul  6 13:49:06 FC6 kernel:  [<c0405167>] show_trace_log_lvl+0x54/0xfd
Jul  6 13:49:06 FC6 kernel:  [<c040571e>] show_trace+0xd/0x10
Jul  6 13:49:06 FC6 kernel:  [<c040583d>] dump_stack+0x19/0x1b
Jul  6 13:49:06 FC6 kernel:  [<c043bdb2>] __lock_acquire+0x76a/0x98d
Jul  6 13:49:06 FC6 kernel:  [<c043c546>] lock_acquire+0x4b/0x6d
Jul  6 13:49:06 FC6 kernel:  [<c0439510>] down_read+0x2d/0x40
Jul  6 13:49:06 FC6 kernel:  [<e08ce508>] dm_request+0x18/0xea [dm_mod]
Jul  6 13:49:06 FC6 kernel:  [<c04d820f>] generic_make_request+0x290/0x2a0
Jul  6 13:49:06 FC6 kernel:  [<e08cd447>] __map_bio+0xc3/0xf1 [dm_mod]
Jul  6 13:49:06 FC6 kernel:  [<e08cdda3>] __split_bio+0x159/0x39f [dm_mod]
Jul  6 13:49:06 FC6 kernel:  [<e08ce5cc>] dm_request+0xdc/0xea [dm_mod]
Jul  6 13:49:06 FC6 kernel:  [<c04d820f>] generic_make_request+0x290/0x2a0
Jul  6 13:49:06 FC6 kernel:  [<c04da0d8>] submit_bio+0xa9/0xae
Jul  6 13:49:06 FC6 kernel:  [<c0493856>] dio_bio_submit+0x4f/0x61
Jul  6 13:49:06 FC6 kernel:  [<c04946f5>] __blockdev_direct_IO+0x995/0xcf4
Jul  6 13:49:06 FC6 kernel:  [<c0479bd9>] blkdev_direct_IO+0x30/0x35
Jul  6 13:49:06 FC6 kernel:  [<c04550e2>] generic_file_direct_IO+0x86/0xe0
Jul  6 13:49:06 FC6 kernel:  [<c0455368>] __generic_file_aio_read+0xf2/0x1d8
Jul  6 13:49:06 FC6 kernel:  [<c045631d>] generic_file_read+0x87/0x9b
Jul  6 13:49:06 FC6 kernel:  [<c04725e0>] vfs_read+0xa9/0x155
Jul  6 13:49:06 FC6 kernel:  [<c0472a6e>] sys_read+0x3b/0x60
Jul  6 13:49:06 FC6 kernel:  [<c0403f2f>] syscall_call+0x7/0xb
....
Comment 3 Dave Jones 2006-07-06 14:57:00 EDT
*** Bug 197838 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2006-07-06 15:00:37 EDT
I'm working on this, but it may take a while to get fixed completely.
Comment 5 Ronald Warsow 2006-07-06 15:25:58 EDT
okay !
Comment 6 Dave Jones 2006-07-11 01:19:13 EDT
*** Bug 198204 has been marked as a duplicate of this bug. ***
Comment 7 Dave Jones 2006-07-11 01:25:13 EDT
*** Bug 198105 has been marked as a duplicate of this bug. ***
Comment 8 Tom London 2006-07-11 09:59:09 EDT
Bootup of kernel-2.6.17-1.2364.fc6 no longer complains about cpufreq/hotplug
lock dependency.  Fix in 'Big bunch o' lockdep patches from Arjan'?
Comment 9 Ronald Warsow 2006-07-11 13:20:19 EDT
i got the same like in Comment #2 .
more info/time (Comment #4) necessary ?
Comment 10 Dave Jones 2006-07-12 00:08:28 EDT
should be fixed in tomorrows rawhide push (kernel-2.6.17-1.2375.fc6 or higher).
Comment 11 Jim Cornette 2006-07-15 21:24:49 EDT
I,m still seeing this with kernel-2.6.17-1.2401.fc6
Comment 12 Jim Cornette 2006-07-15 21:27:58 EDT
Created attachment 132515 [details]
Excerpt attached in case error message differs
Comment 13 Dave Jones 2006-07-15 23:27:04 EDT
*** Bug 198989 has been marked as a duplicate of this bug. ***
Comment 14 Dave Jones 2006-07-15 23:29:07 EDT
*** Bug 199026 has been marked as a duplicate of this bug. ***
Comment 15 Ronald Warsow 2006-07-18 08:36:52 EDT
see Comment #9 
with kernel-...2405
Comment 16 Dave Jones 2006-07-26 00:12:20 EDT
*** Bug 199664 has been marked as a duplicate of this bug. ***
Comment 17 Dave Jones 2006-07-26 00:21:43 EDT
*** Bug 200121 has been marked as a duplicate of this bug. ***
Comment 18 Dave Jones 2006-07-28 13:36:07 EDT
*** Bug 199811 has been marked as a duplicate of this bug. ***
Comment 19 Dave Jones 2006-07-29 13:35:57 EDT
This bug is fixed, but it has mutated into a new form (bug 200638).
Comment 20 Jim Cornette 2006-07-29 22:36:37 EDT
bug 200638 mutation?

Note You need to log in before you can comment on or make changes to this bug.