Bug 201937 - kernel BUG at lib/list_debug.c:65! involving squashfs
kernel BUG at lib/list_debug.c:65! involving squashfs
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: 201854 201878 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-08-09 16:58 EDT by Chris Lumens
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-17 11:01:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
kernel debug output (5.94 KB, text/plain)
2006-08-09 16:58 EDT, Chris Lumens
no flags Details

  None (edit)
Description Chris Lumens 2006-08-09 16:58:13 EDT
While attempting an installation of today's Rawhide tree, the attached bug
happens in anaconda when it goes to fetch the squashfs images.  Some small
amount of anaconda text is mixed in with the rest of the kernel output.

kernel version:  2.6.17-1.2532.fc6
Comment 1 Chris Lumens 2006-08-09 16:58:13 EDT
Created attachment 133885 [details]
kernel debug output
Comment 2 Dave Jones 2006-08-11 01:46:38 EDT
*** Bug 201854 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2006-08-11 01:46:53 EDT
*** Bug 201878 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2006-08-11 10:07:15 EDT
This works for me today.
Comment 5 Joachim Frieben 2006-08-11 10:12:04 EDT
I have tried to do a net install from "boot.iso" as of 2008-08-11, and
it hangs exactly as yesterday after (during(?)) downloading "stage2.img".
Closing Bug 201854 as "duplicate" was hence maybe a bit premature ...
Comment 6 Jason 2006-08-11 17:25:01 EDT
I also tried a ftp install from the aug 11 boot.iso and it still crashes.
Comment 7 Joachim Frieben 2006-08-13 12:35:31 EDT
Tried again for "rawhide" as of 2006-08-13, and it -works- again!
Comment 8 Jason 2006-08-13 15:12:16 EDT
The august 13 boot.iso works fine for me.  Now back to the regularlly scheduled
video problem.
Comment 9 Dave Jones 2006-08-14 14:31:31 EDT
I'm puzzled that it's been working the last few days, as nothing changed which
could explain how it got fixed.

Todays kernel however does have squashfs changes which should fix the bug.
If it's still working tomorrow, we can close this out I guess :)
Comment 10 Jason 2006-08-15 14:49:59 EDT
I tried the august 15th boot.iso and my system locks up when stage2 finishs
downloading.  No text, no kernel panic, nothing but a hard lock.  I have to
press the reset button.
Comment 11 Chris Lumens 2006-08-16 10:48:07 EDT
This looks like it could be a mksquashfs bug.  Feel free to reassign or dupe to
bug 202663.

Note You need to log in before you can comment on or make changes to this bug.