Bug 203652 - Update notification bubble attached to wrong panel icon
Update notification bubble attached to wrong panel icon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 205805 206254 207379 207707 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-22 16:37 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 18:43:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of falsely attached update notification bubble (34.35 KB, image/png)
2006-08-22 16:39 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2006-08-22 16:37:51 EDT
Description of problem:
As the attached screenshot demonstrates, the notification bubble of
the "pup" update manager is slightly displaced. It seems to originate
from the power manager icon whereas it should be attached to the "pup"
icon (actually associated with "yum-updatesd-2.9.4-4").

Version-Release number of selected component (if applicable):
pirut-1.1.9-1

How reproducible:
Always.

Steps to Reproduce:
1. Wait until new updates are available.
2. Log in to "GNOME" session.
  
Actual results:
Notification bubble is "attached" to "g-p-m" notification panel icon.

Expected results:
Notification bubble is "attached" to "pup/yum-updatesd" notification
panel icon.

Additional info:
None.
Comment 1 Joachim Frieben 2006-08-22 16:39:12 EDT
Created attachment 134671 [details]
Screenshot of falsely attached update notification bubble
Comment 2 Luke Macken 2006-08-22 22:26:35 EDT
Known issue.  The notification is displayed in a gobject.add_idle() callback, so
I'm not sure why this is still happening.

Jeremy, any ideas?
Comment 3 Jeremy Katz 2006-09-11 17:19:48 EDT
*** Bug 205805 has been marked as a duplicate of this bug. ***
Comment 4 John (J5) Palmieri 2006-09-11 17:41:11 EDT
I would say timeout a second or so.  Actually if you are loading up a whole
session it might take a while for the window to be mapped.  This is only an
issue when you first start puplet.  Waiting a few seconds before assaulting the
user witha popup is actually a good idea anyway.  The real fix is to detect when
the window is fully realized.  Perhaps attaching to a mapped signal or something
similar?
Comment 5 Jeremy Katz 2006-09-11 18:43:55 EDT
Hacked around in CVS, although I expect that a full fix really requires the
notification daemon to dtrt
Comment 6 Jeremy Katz 2006-09-13 10:18:43 EDT
*** Bug 206254 has been marked as a duplicate of this bug. ***
Comment 7 Mayank Jain 2006-09-13 10:28:17 EDT
Hi, which library is used to create such popups?
Thanks,
Mayank
Comment 8 Matthias Clasen 2006-09-13 10:34:03 EDT
Jeremy, don't tell them !!! :-)
Comment 9 Matthias Clasen 2006-09-21 22:38:37 EDT
*** Bug 207379 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2006-09-22 13:28:21 EDT
*** Bug 207707 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.