Bug 207128 - windows disappear and only background and panel get's shown
windows disappear and only background and panel get's shown
Status: CLOSED DUPLICATE of bug 207263
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 12:14 EDT by Thorsten Leemhuis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-26 07:59:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2006-09-19 12:14:51 EDT
Description of problem:
compiz is playing games with me on both of my two rawhide machines (one i386 and
one x86_64) since the first bunch of rawhide update after test3.

I have 7 workspaces and I'm switching between them a lot with
CTRL-ALT-{LEFT,RIGHT}. irssi fullscreen on ws#1, thunderbird fullscreen on ws#2,
firefox, a terminal and gaim on ws#3 and openoffice on ws#4. Sometimes windows
simpy are now shown after switching to a specific workspaces -- just the
background is shown.

They suddenly are visable again after switchin back an forth between workspaces
multiple times. Only firefox is always visable. 

Another way to make the apps visable again: click on the app in the "Window
Selector Applet"; compitz switches to the proper workspace. Klick on the app
again in the applet. Now it shows up again sometimes. In other times only the
bootom ~40 pixels of the widow show up the top of the screen and not at the
place where i left it. Moving it down with the mouse while holding ALT and it's
there again completely.

Windows sometimes even disappear *while* moving windows from one ws to abother
with CTRL-ALT-SHIFT-{LEFT,RIGHT}

Version-Release number of selected component (if applicable):
compiz-0.0.13-0.25.20060817git.fc6
otherwise up2date rawhide system as of today with gnome
Comment 1 Thorsten Leemhuis 2006-09-20 01:22:46 EDT
The problem does not show up today for me on my x86_64 machine -- but now Bug
201634 is back (tiny desktops is gnome's workspace switcher).

Why? Well, i did something different today. I started with metacity and enabled
compiz afterwards because starting directly with compitz enabled lock up my
machine quite often (see Bug 206850)
Comment 2 Søren Sandmann Pedersen 2006-09-20 11:48:42 EDT
Could you try upgrading to the latest rawhide, ie., at least compiz 0.0.13-0.27
and gnome-panel-2.16.0-2?
Comment 3 Thorsten Leemhuis 2006-09-20 14:31:25 EDT
(In reply to comment #2)
> at least compiz 0.0.13-0.27  and gnome-panel-2.16.0-2?

Those two did not help yet; I'll update to the full rawhide tree later and check
it on another machine tomorrow
Comment 4 Thorsten Leemhuis 2006-09-21 01:30:35 EDT
Also still happens with my x86_64 machine after updating to latest rawhide and a
fresh boot; compiz was enabled with desktop-effects after gnome was started with
metacity due to problems described in Bug 206850
Comment 5 Ola Thoresen 2006-09-21 10:23:06 EDT
I have not had this problem before, and I have been running compiz for a few
weeks.  But after todays updates this started happening on my x86_64 (my i386 is
not yet updated).

The windows are disappearing and appearing seemingly at random.
Comment 6 Ola Thoresen 2006-09-21 10:29:08 EDT
After a bit more investiagtion it seems to only happen to maximized windows.

compiz-0.0.13-0.27.20060817git.fc6
Comment 7 Thorsten Leemhuis 2006-09-21 10:42:04 EDT
(In reply to comment #6)
> After a bit more investiagtion it seems to only happen to maximized windows.

Happens for me with maximimized windows often, but sometimes also with a
terminal and gaim that I've running together with firefox on ws#3.

I got the impression that maximaized windows and/or windows that hit a corner of
the screen seem to be effected by the problem most. And I'm sill wondering why
the problem never happened with firefox.
Comment 8 Ola Thoresen 2006-09-21 10:48:40 EDT
For me it happened with firefox as well - but onl when maximized.
I now make sure that no windows are touching the edges og the viewport, and I
have not had it happen since I did that.
Comment 9 Thorsten Leemhuis 2006-09-26 07:59:51 EDT

*** This bug has been marked as a duplicate of 207263 ***

Note You need to log in before you can comment on or make changes to this bug.