This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 207462 - Unable to mount root fs after installation
Unable to mount root fs after installation
Status: CLOSED DUPLICATE of bug 206453
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 04:24 EDT by Yao Qi
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-24 23:09:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yao Qi 2006-09-21 04:24:13 EDT
Description of problem:
Install FC6 Test3 on a ppc64 box, and fail to boot after installation.

Welcome
Welcome to yaboot version 1.3.13 (Red Hat 1.3.13-2.fc6)
Enter "help" to get some basic usage information
boot: linux
Please wait, loading kernel...
   Elf64 kernel loaded...
OF stdout device is: /pci@400000000110/isa@3/serial@i3f8
command line: root=/dev/sda3 ro console=ttyS0 rhgb quiet 
memory layout at init:
  alloc_bottom : 0000000004100000
  alloc_top    : 0000000030000000
  alloc_top_hi : 0000000200000000
  rmo_top      : 0000000030000000
  ram_top      : 0000000200000000
Looking for displays
opening PHB /pci@400000000110... done
opening PHB /pci@400000000112... done
instantiating rtas at 0x000000002fd00000 ... done
0000000000000000 : boot cpu     0000000000000000
0000000000000001 : starting cpu hw idx 0000000000000001... done
0000000000000002 : starting cpu hw idx 0000000000000002... done
0000000000000003 : starting cpu hw idx 0000000000000003... done
copying OF device tree ...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000004210000 -> 0x000000000421132d
Device tree struct  0x0000000004220000 -> 0x0000000004230000
Calling quiesce ...
returning from prom_init
Starting Linux PPC64 #1 SMP Wed Sep 6 17:17:26 EDT 2006
-----------------------------------------------------
ppc64_pft_size                = 0x0
physicalMemorySize            = 0x200000000
ppc64_caches.dcache_line_size = 0x80
ppc64_caches.icache_line_size = 0x80
htab_address                  = 0xc0000001f0000000
htab_hash_mask                = 0xfffff
-----------------------------------------------------
Linux version 2.6.17-1.2630.fc6 (brewbuilder@js20-bc2-9.build.redhat.com) (gcc
version 4.1.1 20060828 (Red Hat 4.1.1-20)) #1 SMP Wed Sep 6 17:17:26 EDT 2006
[boot]0012 Setup Arch
No ramdisk, default root is /dev/sda2
EEH: PCI Enhanced I/O Error Handling Enabled
PPC64 nvram contains 81920 bytes
[boot]0015 Setup Done
Built 2 zonelists.  Total pages: 131072
Kernel command line: root=/dev/sda3 ro console=ttyS0 rhgb quiet 
[boot]0020 XICS Init
xics: PCI 8259 intack at 0x000003fffdf091f0
i8259 legacy interrupt controller initialized
[boot]0021 XICS Done
PID hash table entries: 4096 (order: 12, 32768 bytes)
time_init: decrementer frequency = 125.288300 MHz
time_init: processor frequency   = 1002.000000 MHz
Using pSeries machine description
Page orders: linear mapping = 24, virtual = 12, io = 12
Found legacy serial port 0 for /pci@400000000110/isa@3/serial@i3f8
  port=3f8, taddr=3fd300003f8, irq=0, clk=1843200, speed=0
Found legacy serial port 1 for /pci@400000000110/isa@3/serial@i2f8
  port=2f8, taddr=3fd300002f8, irq=0, clk=1843200, speed=0
Found legacy serial port 2 for /pci@400000000110/isa@3/serial@i898
  port=898, taddr=3fd30000898, irq=0, clk=1843200, speed=0
Starting Linux PPC64 #1 SMP Wed Sep 6 17:17:26 EDT 2006
-----------------------------------------------------
ppc64_pft_size                = 0x0
physicalMemorySize            = 0x200000000
ppc64_caches.dcache_line_size = 0x80
ppc64_caches.icache_line_size = 0x80
htab_address                  = 0xc0000001f0000000
htab_hash_mask                = 0xfffff
-----------------------------------------------------
Linux version 2.6.17-1.2630.fc6 (brewbuilder@js20-bc2-9.build.redhat.com) (gcc
version 4.1.1 20060828 (Red Hat 4.1.1-20)) #1 SMP Wed Sep 6 17:17:26 EDT 2006
[boot]0012 Setup Arch
Node 0 Memory: 0x0-0x100000000
Node 1 Memory: 0x100000000-0x200000000
No ramdisk, default root is /dev/sda2
EEH: PCI Enhanced I/O Error Handling Enabled
PPC64 nvram contains 81920 bytes
Using default idle loop
On node 0 totalpages: 65536
  DMA zone: 65536 pages, LIFO batch:1
On node 1 totalpages: 65536
  DMA zone: 65536 pages, LIFO batch:1
[boot]0015 Setup Done
Built 2 zonelists.  Total pages: 131072
Kernel command line: root=/dev/sda3 ro console=ttyS0 rhgb quiet 
[boot]0020 XICS Init
xics: PCI 8259 intack at 0x000003fffdf091f0
i8259 legacy interrupt controller initialized
[boot]0021 XICS Done
PID hash table entries: 4096 (order: 12, 32768 bytes)
time_init: decrementer frequency = 125.288300 MHz
time_init: processor frequency   = 1002.000000 MHz
Console: colour dummy device 80x25
Dentry cache hash table entries: 1048576 (order: 7, 8388608 bytes)
Inode-cache hash table entries: 524288 (order: 6, 4194304 bytes)
freeing bootmem node 0
freeing bootmem node 1
Memory: 8209280k/8388608k available (4544k kernel code, 179328k reserved, 1344k
data, 782k bss, 320k init)
Calibrating delay loop... 250.36 BogoMIPS (lpj=500736)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 4096
Processor 1 found.
Processor 2 found.
Processor 3 found.
Brought up 4 CPUs
Node 0 CPUs: 0-1
Node 1 CPUs: 2-3
sizeof(vma)=176 bytes
sizeof(page)=64 bytes
sizeof(inode)=768 bytes
sizeof(dentry)=232 bytes
sizeof(ext3inode)=1040 bytes
sizeof(buffer_head)=96 bytes
sizeof(skbuff)=240 bytes
migration_cost=0,912
PM: Adding info for No Bus:platform
NET: Registered protocol family 16
PM: Adding info for platform:serial8250.0
PCI: Probing PCI hardware
PM: Adding info for No Bus:pci0000:00
Failed to request PCI IO region on PCI domain 0000
Using INTC for W82c105 IDE controller.
IOMMU table initialized, virtual merging enabled
PM: Adding info for pci:0000:00:01.0
PM: Adding info for pci:0000:00:02.0
PM: Adding info for pci:0000:00:02.2
PM: Adding info for pci:0000:00:02.4
PM: Adding info for pci:0000:00:02.6
PM: Adding info for pci:0000:00:03.0
PM: Adding info for pci:0000:00:03.1
PM: Adding info for pci:0000:21:01.0
PM: Adding info for pci:0000:41:01.0
PM: Adding info for pci:0000:41:01.1
PM: Adding info for No Bus:pci0001:00
PM: Adding info for pci:0001:00:02.0
PM: Adding info for pci:0001:00:02.2
PM: Adding info for pci:0001:00:02.6
PM: Adding info for pci:0001:21:01.0
ISA bridge at 0000:00:03.0
mapping IO 3fd30000000 -> d000080000000000, size: 100000
mapping IO 3fd50000000 -> d000080000100000, size: 100000
PCI: Probing PCI hardware done
Registering pmac pic with sysfs...
usbcore: registered new driver usbfs
usbcore: registered new driver hub
NetLabel: Initializing
NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default
NET: Registered protocol family 2
IP route cache hash table entries: 262144 (order: 5, 2097152 bytes)
TCP established hash table entries: 524288 (order: 8, 16777216 bytes)
TCP bind hash table entries: 65536 (order: 5, 2097152 bytes)
TCP: Hash tables configured (established 524288 bind 65536)
TCP reno registered
PM: Adding info for vio:vio
IBM eBus Device Driver
PM: Adding info for ibmebus:ibmebus
PM: Adding info for platform:pcspkr
RTAS daemon started
RTAS: event: 500, Type: EPOW, Severity: 2
RTAS: event: 501, Type: Internal Device Failure, Severity: 2
audit: initializing netlink socket (disabled)
audit(1158816078.051:1): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 8192 (order 0, 65536 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key 3ED3791291A29C07
- User ID: Red Hat, Inc. (Kernel Module GPG key)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
vio_register_driver: driver hvc_console registering
HVSI: registered 0 devices
Generic RTC Driver v1.07
Linux agpgart interface v0.101 (c) Dave Jones
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
PM: Adding info for platform:serial8250
serial8250.0: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250.0: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
serial8250.0: ttyS2 at I/O 0x898 (irq = 10) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 16384K size 4096 blocksize
PM: Adding info for platform:windfarm.0
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
W82C105: IDE controller at PCI slot 0000:00:03.1
PCI: Enabling device: (0000:00:03.1), cmd 141
W82C105: chipset revision 5
W82C105: 100% native mode on irq 86
    ide0: BM-DMA at 0xf040-0xf047, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf048-0xf04f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: HL-DT-ST CD-ROM GCR-8480B, ATAPI CD/DVD-ROM drive
PM: Adding info for No Bus:ide0
hda: selected PIO 4 (120ns) (0240)
hda: DMA enabled
ide0 at 0xf000-0xf007,0xf012 on irq 86
PM: Adding info for ide:0.0
RTAS: event: 502, Type: EPOW, Severity: 2
Probing IDE interface ide1...
Probing IDE interface ide1...
ide-floppy driver 0.99.newide
usbcore: registered new driver libusual
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
PM: Adding info for platform:i8042
serio: i8042 AUX port at 0x60,0x64 irq 12
PM: Adding info for serio:serio0
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice
PM: Adding info for serio:serio1
atkbd.c: keyboard reset failed on isa0060/serio1
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
atkbd.c: keyboard reset failed on isa0060/serio0
md: bitmap version 4.39
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
VFS: Cannot open root device "sda3" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Comment 1 Zoltan Kota 2006-09-21 06:31:32 EDT
It's the same for me on an iMac G5.
Additional info: starting/during the installation I get error messages like this:
"Attempt to read sectors 0-127 outside of partition on /dev/sda".
Ignoring/cancelling the popup window the installation seems to continue
normally. After finishing and rebooting I get the same kernel panic: Cannot open
root device ...
Comment 2 Anssi Johansson 2006-09-22 18:03:23 EDT
A very wild guess, but if it's anything like bug 205347, the initrd doesn't get
installed properly. Please boot your system in rescue mode, and have a look at
/root/install.log if there are any suspicious error messages. Your
/etc/grub.conf might also be informative.
Comment 3 Anssi Johansson 2006-09-22 18:36:47 EDT
If my wild guess is correct, see bug 206453 for even more information about the
issue, and bug 206513 for a workaround.
Comment 4 Yao Qi 2006-09-24 23:09:54 EDT
Yes, your wild guess is correct! 
There is no initrd in the /boot and no initrd line in yaboot.conf.

We could boot that box up with a workaround from  Bug#20651.
Mark this bug as the duplicate of bug#206453.





*** This bug has been marked as a duplicate of 206453 ***

Note You need to log in before you can comment on or make changes to this bug.