This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 208780 - fish conflicts with html-xml-utils and bash
fish conflicts with html-xml-utils and bash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fish (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Liljencrantz
Fedora Extras Quality Assurance
:
: 297151 424781 428349 (view as bug list)
Depends On: 208781
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-10-01 19:19 EDT by Michael Schwendt
Modified: 2008-01-15 03:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 04:28:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2006-10-01 19:19:09 EDT
The packages conflict with other packages in either Extras or Core. Details following in next comment.
Comment 1 Michael Schwendt 2006-10-01 19:29:48 EDT
fish-1.21.12-0.fc5.i386.rpm
  File conflict with: /usr/bin/count
  File conflict with: /usr/share/man/man1/count.1.gz
  => Package conflicts with: html-xml-utils - 3.7-3.fc5.i386
Comment 2 Axel Liljencrantz 2006-10-01 20:08:06 EDT
This is unfortunate. The count command in fish uses this very generic names
since it is the recommended way to find out the size of an array:

count $foo

will write the size of the array $foo to the commandline. Because this is one of
the common operations on arrays, it is very often performed in fish
shellscripts, meaning that it would be a big source of bugs, confusion and
backward compatibility woes to try to rename this command on the fish side.

If would be possible to implement count as a shellscript function instead of a
command. I would classify that is a major kludge, but it would certainly be
possible if it is impossible to change this in the html-xml-utils package.
Comment 3 Oliver Falk 2007-08-31 03:45:12 EDT
Ping. what do we do with this?
Has there been a change in html-xml-utils or has something changed in fish? Who
can investigate?
Comment 4 Oliver Falk 2008-01-08 05:38:45 EST
Axel, it shouldn't be to tragic to move count to fishcount and check the
occurrences of count in share/*... I had a quick look and I guess it's not too
hard. You can also check if the count problem from html-xml-utils does the same
as your fishcount and if, simply remove it and let fish depend on
%{_bindir}/count - at least in f7 and later.

You'll also need the following exludes in your file-list to not conflict with bash:
%exclude %_mandir/man1/count*
%exclude %_mandir/man1/alias*
%exclude %_mandir/man1/bg*
%exclude %_mandir/man1/bind*
%exclude %_mandir/man1/break*
%exclude %_mandir/man1/builtin
%exclude %_mandir/man1/cd*
%exclude %_mandir/man1/command*
%exclude %_mandir/man1/complete*
%exclude %_mandir/man1/continue*
%exclude %_mandir/man1/dirs*
%exclude %_mandir/man1/eval*
%exclude %_mandir/man1/exec*
%exclude %_mandir/man1/exit*
%exclude %_mandir/man1/fg*
%exclude %_mandir/man1/help*
%exclude %_mandir/man1/jobs*
%exclude %_mandir/man1/popd*
%exclude %_mandir/man1/pushd*
%exclude %_mandir/man1/read*
%exclude %_mandir/man1/return*
%exclude %_mandir/man1/set*
%exclude %_mandir/man1/source*
%exclude %_mandir/man1/trap*
%exclude %_mandir/man1/type*
%exclude %_mandir/man1/ulimit*
%exclude %_mandir/man1/umask*
Comment 5 Oliver Falk 2008-01-11 03:13:02 EST
*** Bug 428349 has been marked as a duplicate of this bug. ***
Comment 6 Γριφεγ 2008-01-11 07:40:52 EST
I don't think anyone would want to access fish specific manpages from outside
fish, so instead of replacing system manpages, they could be placed in a
distinct section, for example '1fish', and fish's man command could be modified
to look there first.

Axel: Does this make sense?
Comment 7 Axel Liljencrantz 2008-01-13 10:23:00 EST
This issue should be fixed in the latest upstream release of fish. Could someone
try building a fish 1.23.0 package and verify that these problems are fixed?
Comment 8 Axel Liljencrantz 2008-01-13 10:24:07 EST
Also, sorry about being so unresponsive on this bug. I actually sent a reply to
this a couple of weeks ago, but it seems to have gotten lost.
Comment 9 Oliver Falk 2008-01-14 04:29:18 EST
If you're happy with rawhide version I can sync it to f8 (and earlier?).
Comment 10 Axel Liljencrantz 2008-01-14 04:54:32 EST
I'm afraid I can't currently test this package as my desktop machine (which was
the one running fedora) died a while ago and I haven't had time to replace it.
But if this package works than I would definitely suggest upgrading the f8 and
f7 package as well, so we can close the conflict bugs as resolved in the current
fedora versions and not just in rawhide.
Comment 11 Oliver Falk 2008-01-15 03:28:40 EST
OK. Pkgs have been built for f8 and f7 as well.
Comment 12 Axel Liljencrantz 2008-01-15 03:40:15 EST
*** Bug 297151 has been marked as a duplicate of this bug. ***
Comment 13 Axel Liljencrantz 2008-01-15 03:40:57 EST
*** Bug 424781 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.