Bug 210001 - mono uses TLS method that is inefficient on xen
mono uses TLS method that is inefficient on xen
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
: 213353 214148 220572 220753 231409 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 10:19 EDT by Paul W. Frields
Modified: 2008-11-02 12:54 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-02 12:54:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2006-10-09 10:19:22 EDT
Description of problem:
The following messages appear ad nauseum in the kernel message logs:
4gb seg fixup, process beagled (pid 3608), cs:ip 73:0811cbff

Version-Release number of selected component (if applicable):
beagle-0.2.10-3.fc6
kernel-xen-2.6.18-1.2747.fc6

How reproducible:
Every time

Steps to Reproduce:
1. Boot, log in as user with beagle enabled.
2. Read kernel message logs.
  
Actual results:
Message as described above

Expected results:
Relative silence

Additional info:
Comment 1 Alexander Larsson 2006-10-11 14:43:49 EDT
Maybe this is some sort of mono/xen conflict.
Comment 2 Alexander Larsson 2006-10-11 14:46:55 EDT
This is apparently mono doing TLS in a way that is inefficient on xen.
Comment 3 Alexander Larsson 2006-10-12 10:31:05 EDT
miguel says we can fix this by building mono with:
./configure --with-xen_opt=yes

I'll take a look at exactly what that does.
Comment 4 Alexander Larsson 2006-10-12 10:40:06 EDT
It adds -mno-tls-direct-seg-refs to the build, and makes the jit runtime detect
xen and use another TLS approach if running in xen. Seems safe to turn on.
Comment 5 Alexander Larsson 2006-10-12 11:38:59 EDT
built as mono-core-1.1.17.1-3.fc6
Comment 6 Daniel Berrange 2006-10-26 15:17:56 EDT
This does not appear to have had any effect on supressing the TLS / 4gb
messages. I'm running latest FC6 updates:

  mono-core-1.1.17.1-3.fc6
  beagle-0.2.10-5.fc6


$ beagled 
# tail /var/log/messages

Oct 26 15:15:37 localhost kernel: 4gb seg fixup, process mono (pid 17412), cs:ip
73:0811cd78
Oct 26 15:15:37 localhost kernel: 4gb seg fixup, process mono (pid 17412), cs:ip
73:42882e6f
Oct 26 15:15:37 localhost kernel: 4gb seg fixup, process mono (pid 17412), cs:ip
73:0811ccc1
Oct 26 15:15:44 localhost kernel: printk: 104092 messages suppressed.
Oct 26 15:15:44 localhost kernel: 4gb seg fixup, process beagled (pid 17412),
cs:ip 73:0811cbff
Oct 26 15:15:49 localhost kernel: printk: 13 messages suppressed.
Oct 26 15:15:49 localhost kernel: 4gb seg fixup, process beagled (pid 17412),
cs:ip 73:0811cbff
Oct 26 15:15:54 localhost kernel: printk: 5 messages suppressed.
Oct 26 15:15:54 localhost kernel: 4gb seg fixup, process beagled (pid 17412),
cs:ip 73:0811cbff
Oct 26 15:15:59 localhost kernel: printk: 7 messages suppressed.
Oct 26 15:15:59 localhost kernel: 4gb seg fixup, process beagled (pid 17412),
cs:ip 73:0811cbff
Oct 26 15:16:04 localhost kernel: printk: 5 messages suppressed.
Comment 7 Alexander Larsson 2006-10-27 04:21:54 EDT
And beagled was restarted after the upgrade?

Very strange, i wonder whats causing that now. I'm not sure how to debug it
though...
Comment 8 Paul Finnigan 2006-11-06 14:55:46 EST
For information I too have installed Xen on Fedora Core 6 and am getting similar
messages. I have installed:

beagle.i386                              0.2.10-6.fc6           installed       
mono-core.i386                           1.1.17.1-3.fc6         installed


The messages I have got are:

Nov  6 15:46:41 lin kernel: 4gb seg fixup, process expr (pid 11181), cs:ip
73:41e825b9

...

Nov  6 17:31:11 lin kernel: 4gb seg fixup, process beagled-helper (pid 4602),
cs:ip 73:0811cb2a

...

Nov  6 19:48:01 lin kernel: 4gb seg fixup, process beagled (pid 4485), cs:ip
73:0811cbff

If I can help and you need more information then please ask.
Comment 9 Alexander Larsson 2006-11-08 06:44:59 EST
*** Bug 214148 has been marked as a duplicate of this bug. ***
Comment 10 Alexander Larsson 2006-11-08 06:45:36 EST
Reopening, as the fix doesn't seem to have helped.
Comment 11 Alexander Larsson 2006-11-08 11:44:45 EST
*** Bug 213353 has been marked as a duplicate of this bug. ***
Comment 12 Oldrich Plchot 2006-11-09 18:58:09 EST
I am experiencing the same problems as well, additionaly it seems that this
freezes my virtual machine. I have one X-enabled and one without Xorg. The one
with xorg crashes after some time and I have to destroy it in virt-manager. The
one without X seems to work fine, maybe because beagle is not running there.
Comment 13 Martin A. Boegelund 2007-01-05 16:00:59 EST
Am having the same problem.

mono-core-1.1.17.1-3.fc6
beagle-0.2.13-1.fc6

Output from dmesg:
[...]
printk: 426 messages suppressed.
4gb seg fixup, process beagled-helper (pid 4178), cs:ip 73:0811cb2a
printk: 104241 messages suppressed.
4gb seg fixup, process beagled-helper (pid 4178), cs:ip 73:0811cb2a

Comment 14 Alexander Larsson 2007-01-11 06:18:08 EST
*** Bug 220572 has been marked as a duplicate of this bug. ***
Comment 15 Alexander Larsson 2007-01-11 06:18:37 EST
*** Bug 220753 has been marked as a duplicate of this bug. ***
Comment 16 Alexander Larsson 2007-03-29 09:41:41 EDT
*** Bug 231409 has been marked as a duplicate of this bug. ***
Comment 17 Bug Zapper 2008-05-13 22:24:35 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Paul F. Johnson 2008-10-20 08:16:56 EDT
Can you please check if this is still happening with the version shipped with F9?
Comment 19 Xavier Lamien 2008-10-21 17:05:31 EDT
ping ?
Comment 20 Răzvan Sandu 2008-10-24 09:47:58 EDT
Hello,

According to my experiences, this was resolved long ago - at least, there are no more messages displayed continuously on console.

Since I'm not a programmer, I cannot give you more in-depth information.

Regards,
Răzvan
Comment 21 Paul Finnigan 2008-10-25 05:22:22 EDT
I have not seen this since Fedora 9.
Comment 22 Chris Lalancette 2008-11-02 12:54:17 EST
Based on the last two comments, I'm going to close this out as CURRENTRELEASE.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.