Bug 210808 - python-xeninst does not update
python-xeninst does not update
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 211408 211655 212690 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-15 10:19 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 15:53:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-10-15 10:19:10 EDT
I think this is more of a yum or rpm problem, since a failure is being reported
as a success.

Bugzilla doesn't seem to have any bugs for this.

# yum -y upgrade
[snip]
Running Transaction
  Installing: python-virtinst              ######################### [1/2] 
error: unpacking of archive failed on file
/usr/lib/python2.4/site-packages/xeninst: cpio: rename

Installed: python-virtinst.noarch 0:0.95.0-1.fc6
Replaced: python-xeninst.noarch 0:0.94.0-1
Complete!
Comment 1 Need Real Name 2006-10-16 15:43:51 EDT
Relevant lines from strace:

chown32("/usr/lib/python2.4/site-packages/virtinst/util.pyo", 0, 0) = 0
chmod("/usr/lib/python2.4/site-packages/virtinst/util.pyo", 0644) = 0
utime("/usr/lib/python2.4/site-packages/virtinst/util.pyo",
[2006/10/13-06:14:35, 2006/10/13-06:14:35]) = 0
lstat64("/usr/lib/python2.4/site-packages/xeninst;4533e0b1", 0x93210ec) = -1
ENOENT (No such file or directory)
symlink("virtinst", "/usr/lib/python2.4/site-packages/xeninst;4533e0b1") = 0
ioctl(1, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
  Installing: python-virtinst              #####################     [1/2]) = 75
[1/2]", 75
rename("/usr/lib/python2.4/site-packages/xeninst;4533e0b1",
"/usr/lib/python2.4/site-packages/xeninst") = -1 EISDIR (Is a directory)
close(14)                               = 0
munmap(0xb79d3000, 4096)                = 0
munmap(0xb79d1000, 8192)                = 0
ioctl(1, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
  Installing: python-virtinst              ######################### [1/2]) = 75
[1/2]", 75
write(1, " \n", 2 
)                      = 2
write(2, "error: ", 7error: )                  = 7
write(2, "unpacking of archive failed on file
/usr/lib/python2.4/site-packages/xeninst: cpio: rename\n", 91unpacking of
archive failed on file /usr/lib/python2.4/site-packages/xeninst: cpio: rename
) = 91
close(12)                               = 0
gettimeofday({1161027762, 910996}, NULL) = 0
send(3, "<14>Installed: python-virtinst.noarch 0.95.0-1.fc6\0", 51, 0) = 51
Comment 2 Jeremy Katz 2006-10-16 15:53:00 EDT
python-xeninst was a new package in FC6 and has to be renamed -- so that we can
retain compatibility and not have to rebuild the world at this point, we had to
go with the non-upgradable version of the change.

This is why upgrades from rawhide -> final can't always be supported.
Comment 3 Need Real Name 2006-10-16 15:54:07 EDT
Okay, fair enough, I'll remove it then.
Comment 4 Jeremy Katz 2006-10-18 21:33:20 EDT
*** Bug 211408 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2006-10-20 14:20:30 EDT
*** Bug 211655 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2006-10-30 11:55:25 EST
*** Bug 212690 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.