Bug 2127507 - Pcre Deprecation
Summary: Pcre Deprecation
Keywords:
Status: MODIFIED
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Javorsky
QA Contact:
URL:
Whiteboard:
Depends On: 1938979 2128266 2128267 2128269 2128270 2128271 2128272 2128273 2128278 2128279 2128281 2128283 2128284 2128285 2128286 2128287 2128288 2128294 2128297 2128298 2128299 2128303 2128305 2128306 2128307 2128312 2128314 2128315 2128316 2128317 2128318 2128320 2128321 2128324 2128325 2128326 2128327 2128329 2128330 2128332 2128333 2128334 2128336 2128338 2128340 2128341 2128342 2128343 2128344 2128345 2128346 2128354 2128355 2128357 2128358 2128359 2128360 2128361 2128362 2128364 2128365 2128366 2128369 2128370 2128371 2128372 2128373 2128374 2128376 2128383 2128385 2128386 2128387 2128388 2128389 2128390 2128391 2128392 2128393 2128394 2128397 2128398 2128399 2128400 2128265 2128274 2128275 2128276 2128277 2128282 2128289 2128290 2128291 2128292 2128293 2128300 2128301 2128304 2128308 2128309 2128310 2128311 2128313 2128319 2128322 2128323 2128328 2128335 2128339 2128347 2128348 2128350 2128351 2128353 2128356 2128363 2128368 2128377 2128379 2128381 2128395 2128396 2128401
Blocks: F38Changes
TreeView+ depends on / blocked
 
Reported: 2022-09-16 15:32 UTC by Ben Cotton
Modified: 2022-09-26 06:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: ---


Attachments (Terms of Use)

Description Ben Cotton 2022-09-16 15:32:38 UTC
This is a tracking bug for Change: Pcre Deprecation
For more details, see: https://fedoraproject.org/wiki/PcreDeprecation

Upstream stopped the support for the old 'pcre' package. It only supports the new 'pcre2' version, so Fedora should deprecate it so it could later be retired and removed from Fedora entirely.

If you encounter a bug related to this Change, please do not comment here. Instead create a new bug and set it to block this bug.

Comment 1 Lukas Javorsky 2022-09-19 13:49:20 UTC
Commit that deprecated the package and its sub-packages have been added to the rawhide branch.
https://src.fedoraproject.org/rpms/pcre/c/39c21a60f248df1e9dd5aadff503636234e17d40?branch=rawhide

Do we need to rebuild this package as well, or is the work done for the deprecation?


Note You need to log in before you can comment on or make changes to this bug.