Bug 213027 - S-C-D error: ValueError: need more than 1 value to unpack
S-C-D error: ValueError: need more than 1 value to unpack
Status: CLOSED DUPLICATE of bug 236327
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Reopened
: 220684 222610 223430 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 11:51 EST by Clyde E. Kunkel
Modified: 2008-04-11 14:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 14:53:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf in play when error occurs (2.89 KB, text/plain)
2006-10-30 11:51 EST, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2006-10-30 11:51:01 EST
Description of problem:
As root from a terminal:
[root@P4C800ED ~]# system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 311, in ?
    hardware_state = XF86HardwareState(xconfig)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 177, in __init__
    self.init_from_xconfig(xconfig)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 296, in
init_from_xconfig
    self.all_resolutions.sort (compare_resolution)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 60, in
compare_resolution
    (w1, h1) = resolution_from_string(res1)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 49, in
resolution_from_string
    (w, h) = string.split (res, "x")
ValueError: need more than 1 value to unpack


Version-Release number of selected component (if applicable):
system-config-display-1.0.45-1

How reproducible:
Every time, except when --reconfig parameter is used.

Steps to Reproduce:
1. as root in a terminal:  system-config-display
2.
3.
  
Actual results:
Error as above

Expected results:
gui comes up allowing changes to xorg configuration.

Additional info:  xorg.conf attached (renamed xorg.conf.bad)
Comment 1 Clyde E. Kunkel 2006-10-30 11:51:01 EST
Created attachment 139731 [details]
xorg.conf in play when error occurs
Comment 2 Adam Jackson 2006-10-30 19:07:10 EST
Yep, check out the capital X in "1680X1050".  Does it work if you change that to
lowercase x?
Comment 3 Clyde E. Kunkel 2006-10-30 22:09:03 EST
Yep.  Gui comes up.
Comment 4 Adam Jackson 2006-10-31 17:47:31 EST
Sweet, taking.
Comment 5 Adam Jackson 2007-01-29 19:26:19 EST
*** Bug 223430 has been marked as a duplicate of this bug. ***
Comment 6 Adam Jackson 2007-01-29 19:26:30 EST
*** Bug 222610 has been marked as a duplicate of this bug. ***
Comment 7 Adam Jackson 2007-01-30 09:28:26 EST
*** Bug 220684 has been marked as a duplicate of this bug. ***
Comment 8 Adam Jackson 2007-03-26 17:29:29 EDT
Should be fixed in rhpxl 0.44, coming soon to a theater near you.
Comment 9 Michal Jaegermann 2007-06-20 20:49:47 EDT
Still broken with rhpxl-0.47-1.fc7.  I got this on F7 x86_64 installation
trying to configure dual-head display (system-config-display-1.0.51-1.fc7):

Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 137, in ok
    lower_vrefresh, upper_vrefresh =
string.split(str(self.second_monitor_vrefresh), "-")
ValueError: need more than 1 value to unpack
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 137, in ok
    lower_vrefresh, upper_vrefresh =
string.split(str(self.second_monitor_vrefresh), "-")
ValueError: need more than 1 value to unpack

What is even more interesting - by picking up a lower resolution
for the second monitor one may even get this to work.
Comment 10 Michal Jaegermann 2007-06-21 15:19:14 EDT
I done some more experiments.  If I will tell s-c-d that the second
monitor for a dual panel is "Generic LCD Display 1680x1050" then
I am getting consistently a traceback like in a comment #9.  OTOH
if I will drop resolution to 1440x900 then something gets written.
I did not try all possible resolutions.

Even if xorg.conf is produced then for dualhead is not really
usable without firing up editor and fixing results.  Regardless
how I try to set up first and second monitors something is always
screwy if not that hard to straighten up if you have some idea what
could be a meaning of various entries in that file.  Try yourself
starting with a blank xorg.conf.
Comment 11 Adam Jackson 2008-04-11 14:53:57 EDT
That's a different bug, which is fixed in git now.

*** This bug has been marked as a duplicate of 236327 ***

Note You need to log in before you can comment on or make changes to this bug.