Bug 219029 - mock stops with error about YumAvailablePackageSqlite
mock stops with error about YumAvailablePackageSqlite
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 219077 219083 219127 219188 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-09 11:04 EST by Mamoru TASAKA
Modified: 2014-01-21 17:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-09 22:35:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock build log of xscreensaver (5.55 KB, text/plain)
2006-12-09 11:04 EST, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2006-12-09 11:04:27 EST
Description of problem:
After I upgrade with python 2.5, mock fails with the following
message at last.

AttributeError: YumAvailablePackageSqlite instance has no attribute 'pkgID'

Version-Release number of selected component (if applicable):
python-2.5-2.fc7
yum-3.0.1-3.fc7
mock-0.6.8-4.fc7

How reproducible:
100%

Steps to Reproduce:
1. try to some srpm by mock
2.
3.
  
Actual results:
mock stops with:
AttributeError: YumAvailablePackageSqlite instance has no attribute 'pkgID'
See the details on attached.
Comment 1 Mamoru TASAKA 2006-12-09 11:04:27 EST
Created attachment 143218 [details]
mock build log of xscreensaver
Comment 2 Mamoru TASAKA 2006-12-09 21:49:56 EST
Changing pkgID to pkgId in yum/sqlitesack.py works for me.
Comment 3 Seth Vidal 2006-12-09 22:35:27 EST
yah, that's been fixed in upstream. thanks.
Comment 4 Seth Vidal 2006-12-11 00:48:14 EST
*** Bug 219077 has been marked as a duplicate of this bug. ***
Comment 5 Seth Vidal 2006-12-11 00:48:15 EST
*** Bug 219083 has been marked as a duplicate of this bug. ***
Comment 6 Seth Vidal 2006-12-11 08:30:42 EST
*** Bug 219127 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2006-12-11 12:58:07 EST
And fixed in yum-3.0.1-4 for rawhide
Comment 8 Jeremy Katz 2006-12-11 15:19:41 EST
*** Bug 219188 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.