Bug 22875 - [opl3, midi] fails on ESS ES1869
[opl3, midi] fails on ESS ES1869
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Florence Gold
:
: 23377 29948 (view as bug list)
Depends On:
Blocks: 26860
  Show dependency treegraph
 
Reported: 2000-12-27 06:03 EST by Michael Redinger
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-16 17:59:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-12-27 06:03:48 EST
sndconfig fails when using the card ESS ES1869 PNP AudioDrive.
The sound example is played correctly, but when trying to play
the MIDI demo, the following error is displayed:

The following error occurred running the modprobe program:

/lib/modules/2.4.0-0.43.6/kernel/drivers/sound/opl3.o:
init_module: No such device
/lib/modules/2.4.0-0.43.6/kernel/drivers/sound/opl3.o: insmod
/lib/modules/2.4.0-0.43.6/kernel/drivers/sound/opl3.o failed
/lib/modules/2.4.0-0.43.6/kernel/drivers/sound/opl3.o: insmod
midi failed

sndconfig then says that automatic configuration failed, 
dropping me to manual configuration. Did choose ESS ES1868
there (1869 isn't listed) and did try various hardware
settings, bot none worked.
Comment 1 Glen Foster 2001-01-11 16:05:07 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 2 Bill Nottingham 2001-01-11 16:33:04 EST
What's your /etc/modules.conf look like?
Comment 3 Bill Nottingham 2001-01-30 19:26:00 EST
*** Bug 23377 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2001-02-12 14:24:57 EST
*** Bug 26860 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2001-02-12 14:26:01 EST
Apparent kernel bug; the opl3 driver refuses to load, even with the correct
parameters.
Comment 6 Michael K. Johnson 2001-02-13 19:28:13 EST
Arjan, if this is trivial and obvious to you, please fix it.
Otherwise, assign it back to me and I'll hunt around for
hardware and figure out who needs to work on it.
Comment 7 Arjan van de Ven 2001-02-14 07:13:51 EST
This is non-trivial. The midi paths in the 2.4 kernel are not well tested
and several drivers are known broken with it. Will hunt for more info.
Comment 8 Bill Nottingham 2001-02-15 17:27:48 EST
(goes and pokes at a machine with an SB16 with the same problem)

It *appears* it's some sort of bizarre interaction with the isapnp
support and initialization, and whether soundcore is loaded, and
whether sound is loaded, and whether you ran isapnp, or used the kernel's
isapnp code, or specified module parameters, and this is just really screwed up.
Comment 9 Bill Nottingham 2001-02-16 17:14:06 EST
It *appears* that what's wrong here is that the sb driver, on
unload, deactivates the isapnp configuration, so the IO port
for the opl3 isn't active. Without running userspace isapnp tools,
the only time you can load the opl3 module is while the sb module
is loaded.
Comment 10 Bill Nottingham 2001-02-21 12:36:17 EST
patch posted internally, waiting for comments.
Comment 11 Bill Nottingham 2001-02-27 23:31:05 EST
*** Bug 29948 has been marked as a duplicate of this bug. ***
Comment 12 Bill Nottingham 2001-03-16 18:00:39 EST
This is worked around in sndconfig-0.64.5-1; it will no longer cause
this error.

Note You need to log in before you can comment on or make changes to this bug.