Bug 243097 - Broadcom bcm43xxx driver doesn't work with WPA
Broadcom bcm43xxx driver doesn't work with WPA
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 05:56 EDT by Marcin Jurczuk
Modified: 2008-04-24 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 11:37:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
use old bcm43xx module (script from j. linville), download fixed (864 bytes, application/x-shellscript)
2007-07-06 06:39 EDT, Martin Jürgens
no flags Details
bcm43xx-old-config (592 bytes, application/x-shellscript)
2007-07-12 17:07 EDT, John W. Linville
no flags Details
bcm43xx-override (1.27 KB, text/plain)
2007-10-03 09:01 EDT, John W. Linville
no flags Details

  None (edit)
Description Marcin Jurczuk 2007-06-07 05:56:03 EDT
Description of problem:

There is no way to connect to WPA Personal WiFi network using bcm43xx driver.
NetworkManager asks for password ... trying to connect and asks for password again.
AP: Linksys WAG55

Version-Release number of selected component (if applicable):
Basic FC7 live CD installation

How reproducible:
Every time when you try to connect.

Steps to Reproduce:
1.unpack bcm firmware to /lib/firmware
2. try to connect to WPA-PSK network
3.
  
Actual results:

No connection

Expected results:
Successfull conection


Additional info:
I can establish connection on this hardware using Windows XP and OpenSUSE 10.2
Comment 1 Christopher Aillon 2007-06-07 13:22:25 EDT
There was an update to NetworkManager and wpa_supplicant that many people have
reported makes NM work with WPA.  Does this update work for you (not entirely
sure how you update using a livecd)
Comment 2 Martin Jürgens 2007-06-08 12:06:14 EDT
I experience the same issue with bcm43xx_mac80211 and it has not been fixed by
the  new NetworkManager version. I can't connect to unencrypted networks either.

Works fine on Ubuntu and SuSE for me.
Comment 3 Phillip Ezolt 2007-06-08 20:23:56 EDT
I've tried both the default broadcom driver (with v4 firmware), and ndiswrapper,
and both fail when using NetworkManager.  These both worked with FC5. 
(This is running FC7 with the latest updates as of 5 minutes ago.)

However, wlassistant works (with the default broadcom driver AND ndiswrapper).

Is there any sort of debugging info that could help? 
Comment 4 Marcin Jurczuk 2007-06-09 07:07:34 EDT
Still doesn't work like for people above.
Also trying using manual wpa_supplicant WPA setup - no sucess :(
I'll try to attach some logs from wpa_supplicant soon.
Comment 5 Oscar Valdez 2007-06-23 16:03:05 EDT
I have the exact same problem with a Dell laptop, Fedora 7, the infamous 
Broadcomm 4311 chipset, and the 4.80.53.0 firmware extracted with
bcm43xx-fwcutter.

I thought the 2.6.21-1.3228.fc7 would make it work with the
bcm43xx_mac80211 driver, but it didn't. I've fiddled extensively with
wpa_supplicant and NetworkManager, but nothing makes it work.
Comment 6 Oscar Valdez 2007-06-27 12:04:39 EDT
This bug is a duplicate of bugs 242338, 242585, 243487, 243585,  244529, and
245084. It' obviously a problem for many users.

The fix posted on fedora-list by John W. Linville here:
 https://www.redhat.com/archives/fedora-list/2007-June/msg01009.html 
doesn't work (at least for me, and, I suspect, for many others).

Please pay attention to this bug. I think it's a NetworkManager problem.
Comment 7 Oscar Valdez 2007-07-05 23:47:41 EDT
Is there any information I could provide, or tests I could run, to help solve
this issue? Personally, I think it's "a very bad thing" not to be able to
connect to wireless networks with Fedora 7, and I'm willing to help solve this
issue.
Comment 8 Martin Jürgens 2007-07-06 06:39:11 EDT
I think that your problem is that you have an older chip which does not work
with the bcm43xx_mac80211 driver (like me), which is loaded by default.

The fix at https://www.redhat.com/archives/fedora-list/2007-June/msg01009.html
should work theretically, but the bcm43xx download is not available anymore.

I'd suggest you first to see that your /etc/modprobe.d/blacklist does not
contain "blacklist bcm43xx-mac80211", that your /etc/modprobe.conf does not
contain "options bcm43xx fwpostfix=v3" and that your /etc/rc.local does not
contain "modprobe bcm43xx". Also remove the next line in /etc/rc.local.

I modified Linville's script so that the download should work again. It is
attached. chmod 755 it and run it.
Comment 9 Martin Jürgens 2007-07-06 06:39:53 EDT
Created attachment 158649 [details]
use old bcm43xx module (script from j. linville), download fixed
Comment 10 Oscar Valdez 2007-07-07 11:29:10 EDT
Still not working.

I have:

the firmware cut from WMP54GSv1.1_20050428.exe in /lib/firmware

in /etc/rc.local:
   modprobe bcm43xx
   echo "14e4 4311 14e4 170c" > /sys/bus/pci/drivers/bcm43xx/new_id

in /etc/modprobe.d/blacklist
  blacklist bcm43xx-mac80211

in /etc/modprobe.conf
  options bcm43xx fwpostfix=v3

When the laptop boots, or whenever I try to start the wpa_supplicant service on
it, I get this:

ioctl[SIOCSIWPMKSA]: No such device
ioctl[SIOCSIWMODE]: No such device
Could not configure driver to use managed mode
ioctl[SIOCGIFFLAGS]: No such device
Could not set interface 'wlan0' UP
ioctl[SIOCGIWRANGE]: No such device
ioctl[SIOCGIFINDEX]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
Failed to disable WPA in the driver.
/bin/bash: line 1:  3608 Segmentation fault  wpa_supplicant -c
/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dndiswrapper -B

The WiFi led on the laptop never goes on.
Comment 11 Oscar Valdez 2007-07-10 20:11:24 EDT
Since my laptop has another Broadcomm PCI device, the line
   lspci -n | grep 14e4 | awk '{ print $3 }' | sed -e 's/:/ /'
from the bcm43xx module script from j. linville was producing two lines of output:
   14e4 4311
   14e4 170c
so I had
   echo "14e4 4311 14e4 170c" > /sys/bus/pci/drivers/bcm43xx/new_id
in /etc/rc.local

When I shortened it to
   echo "14e4 4311" > /sys/bus/pci/drivers/bcm43xx/new_id
I was able to associate and connect.

That line in the script should be changed to:
  BCM43XX_PCI_ID=`lspci -n | grep 14e4:43 | awk '{ print $3 }' | sed -e 's/:/ /'`
Comment 12 John W. Linville 2007-07-12 17:07:21 EDT
Created attachment 159095 [details]
bcm43xx-old-config

Updated version of "use old bcm43xx module" script
Comment 13 Peter Wainwright 2007-10-03 05:06:06 EDT
I fixed my bcm4318 + WPA by patching the kernel, copying the old
drivers/net/bcm43xx directory into the source.

However, this is just a temporary fix.  If Fedora insists on 
disabling the old driver, may I ask when the new driver (b43.ko)
will be fixed to support WPA?
Comment 14 John W. Linville 2007-10-03 09:00:19 EDT
Ummmm...huh?  The bcm43xx driver is already built in the Fedora kernels, no 
need to rebuild it.  It has it's PCI ID table pruned by default, but you can 
configure around that.  The attachment in comment 12 provides a means of doing 
it, or I'll attach a cleaner method following this comment.

As for the b43 driver, if it works with your hardware than WPA should work 
fine.  If you can get b43 to work with an unencrypted network but not with 
WPA, then you should open a bug specific to that.
Comment 15 John W. Linville 2007-10-03 09:01:17 EDT
Created attachment 214621 [details]
bcm43xx-override
Comment 16 Dan Williams 2008-04-22 14:55:59 EDT
Is this still an issue with the latest F7 kernels and NM 0.6.6 from F7 updates?
Comment 17 Marcin Jurczuk 2008-04-23 16:10:28 EDT
Info from me: Right now system is F9 and everything works like charm ..

Note You need to log in before you can comment on or make changes to this bug.