Bug 243585 - knetworkmanager hangs at 28% using bcm43xx driver
knetworkmanager hangs at 28% using bcm43xx driver
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-10 04:16 EDT by Chris Hackmeyer
Modified: 2008-04-22 15:13 EDT (History)
0 users

See Also:
Fixed In Version: 0.6.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 14:59:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg after several attempts to connect using interface wlan0 (the Broadcom card) and knetworkmanager (20.71 KB, application/octet-stream)
2007-06-10 04:16 EDT, Chris Hackmeyer
no flags Details
/var/log/messages (234.92 KB, application/octet-stream)
2007-06-24 17:44 EDT, Chris Hackmeyer
no flags Details

  None (edit)
Description Chris Hackmeyer 2007-06-10 04:16:57 EDT
Description of problem:

When using the native bcm43xx driver with my HP dv2000z's built-in Broadcom 4310
wireless card, knetworkmanager hangs for approx. 45 sec. at 28% and then fails
to connect to any wireless network.  It doesn't seem to make any difference
whether any sort of encryption is used - this occurs even on open networks. 
Also, this problem does not occur when using the Windows drivers with
ndiswrapper, nor does it happen using the legacy rt73 driver from serialmonkey
when using a USB wireless card I have with a Ralink chipset.  However, I prefer
to use the bcm43xx driver because in my experience ndiswrapper is unstable and
the USB card's reception is very poor.  Furthermore, the card works flawlessly
with bcm43xx if I use the ifupdown method from the command line - just not with
knetworkmanager.  I looked through dmesg after several attempts to connect to my
wireless router using knetworkmanager, and the only lines that seem to be
relevant are the following (eth1 being my wired ethernet card, which was not
connected):

eth1: no link during initialization.
ADDRCONF(NETDEV_UP): eth1: link is not ready
eth1: no link during initialization.
ADDRCONF(NETDEV_UP): eth1: link is not ready
NetworkManager[15942] trap int3 rip:4210ad rsp:7fff0b1053d0 error:0
NetworkManager[15943] trap int3 rip:4210ad rsp:7fff623b2660 error:0
NetworkManager[15944] trap int3 rip:4210ad rsp:7fff2b7faab0 error:0
NetworkManager[15945] trap int3 rip:4210ad rsp:7fff725f2020 error:0
eth1: no link during initialization.
ADDRCONF(NETDEV_UP): eth1: link is not ready
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
wlan0: no IPv6 routers present
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
wlan0: no IPv6 routers present

Version-Release number of selected component (if applicable):

0.1-0.9.svn20070409.fc7@x86_64

How reproducible:

Attempt to connect to any wireless network using knetworkmanager with a Broadcom
4310 wireless card (and perhaps others) and the bcm43xx driver.

Steps to Reproduce:
1. Install bcm43xx-fwcutter, extract firmware to /lib/firmware, etc.
2. modprobe bcm43xx
3. Wireless network shows up in knetworkmanager.  Click on it and wait for
connection to be established.
  
Actual results:

knetworkmanager connection dialog hangs at 28% for about 45 sec., then says that
it could not connect to the network.

Expected results:

knetworkmanager configures the wireless device, obtains an IP address through
DHCP, and establishes a stable connection to the wireless router.

Additional info:

I can't really tell if this is a problem with knetworkmanager or NetworkManager
itself, so if anyone has any ideas about how to determine that, please let me
know.  Also, I don't know how relevant this is, but the same card with the same
firmware and everything connected properly using the knetworkmanager bundled
with Kubuntu 7.04. albeit with a very slow, unstable connection.  If needed, I
would be glad to try suggestions, post logfiles, or whatever is needed to get
this working - it's really the only problem I've had with Fedora 7 to speak of,
and it would be great to be able to get this fixed.
Comment 1 Chris Hackmeyer 2007-06-10 04:16:58 EDT
Created attachment 156662 [details]
dmesg after several attempts to connect using interface wlan0 (the Broadcom card) and knetworkmanager
Comment 2 Dennis Gilmore 2007-06-10 12:12:26 EDT
can you try using the nm-applet application?  I suspect this is NetworkManager 
related and not knetworkmanager related.  knetworkmanager is just the client 
side.
Comment 3 Chris Hackmeyer 2007-06-10 12:47:04 EDT
Right - I'll try that later today and let you know how it goes.
Comment 4 Chris Hackmeyer 2007-06-10 15:25:52 EDT
You were right.  I tried nm-applet and got exactly the same result.  I'll go
ahead and change the component to NetworkManager.
Comment 5 Chris Hackmeyer 2007-06-24 17:37:40 EDT
I've played around with this a bit more after having some trouble with the
bcm43xx_mac80211 driver itself after a recent kernel update.  After getting the
driver working again, I'm still having the same problem with NetworkManager. 
Looking through /var/log/messages, I found that it is apparently failing while
trying to associate with the router.  This is odd, since the interface still
associates just fine with the router as long as it is configured manually with
ifconfig, iwconfig, dhclient, etc., and in fact I am sending this using the
manually configured interface right now.  You should be able to see where it
fails (and then where I succeed in connecting manually) near the end of
/var/log/messages, which I'll attach.
Comment 6 Chris Hackmeyer 2007-06-24 17:44:29 EDT
Created attachment 157724 [details]
/var/log/messages

My most recent failed attempt at connecting with knetworkmanager starts at Jun
24 16:20:24.  Note that it fails at 16:20:45, saying that association took
>20s.  Then, near the very end of the file, you can see where I use iwconfig to
manually set the essid and use dhclient to get an ip address, which worked
fine.
Comment 7 Oscar Valdez 2007-06-27 12:04:55 EDT
This bug is a duplicate of bugs 242338, 242585, 243097, 243487,  244529, and
245084. It' obviously a problem for many users.

The fix posted on fedora-list by John W. Linville here:
 https://www.redhat.com/archives/fedora-list/2007-June/msg01009.html 
doesn't work (at least for me, and, I suspect, for many others).

Please pay attention to this bug. I think it's a NetworkManager problem.
Comment 8 Chris Hackmeyer 2007-06-27 22:25:54 EDT
Actually, after more experimentation with using different firmware versions, I
have discovered that my problem may have more to do with the driver than I
originally thought.  Briefly, I had installed ndiswrapper a while back and
apparently it had written an 'alias wlan0 ndiswrapper' or something along those
lines to /etc/modprobe.d/ndiswrapper, so evidently ndiswrapper was loading
without my knowledge each time I did ifconfig wlan0 up, hence my success getting
the card to work only from the command line.  Stupid me...

Interestingly, even after verifying that the ndiswrapper module has been
removed, and then loading bcm43xx_mac80211, I can still associate with the
router (sort of, at least from the command line), but dhclient wlan0 just sits
there and times out, so I can't get an IP address.  I'm not sure why this
happens, but I've noticed two things that may be relevant.

First of all, when I load the bcm43xx_mac80211 module, the following line comes
up in /var/log/messages:

localhost kernel: bcm43xx_mac80211: !WARNING! Idle-TSSI phy->cur_idle_tssi
measuring failed. (cur=36, tgt=120). Disabling TX power adjustment
.

I have also noticed this appearing on startup.

Perhaps more significantly, I get this in /var/log/messages as soon as I issue
the dhclient wlan0 command:

localhost dhclient: wmaster0: unknown hardware address type 801

I suspect that this is significant because it is dhclient that doesn't work when
using the native driver, and this line appears ONLY when using that driver.  If
I use ndiswrapper, it doesn't appear, and I can get an IP address.

One other item that is perhaps significant (although I have always had this
problem with the bcm43xx family of drivers) is that iwconfig wlan0 gives
nonsensical readings for the signal strength (like Link Quality = 211/146).  I
really think the problem has something to do with the "unknown hardware address
type 801" message, though.  I just don't know enough about how the kernel
handles wireless devices to make sense of that message.  I wonder if anyone else
who is having similar problems has observed this...

So what do you think Mr. Aillon?  Is this still possibly a NetworkManager issue,
or does it need to be reassigned yet again?
Comment 9 Chris Hackmeyer 2007-06-27 22:48:01 EDT
Actually, after more experimentation with using different firmware versions, I
have discovered that my problem may have more to do with the driver than I
originally thought.  Briefly, I had installed ndiswrapper a while back and
apparently it had written an 'alias wlan0 ndiswrapper' or something along those
lines to /etc/modprobe.d/ndiswrapper, so evidently ndiswrapper was loading
without my knowledge each time I did ifconfig wlan0 up, hence my success getting
the card to work only from the command line.  Stupid me...

Interestingly, even after verifying that the ndiswrapper module has been
removed, and then loading bcm43xx_mac80211, I can still associate with the
router (sort of, at least from the command line), but dhclient wlan0 just sits
there and times out, so I can't get an IP address.  I'm not sure why this
happens, but I've noticed two things that may be relevant.

First of all, when I load the bcm43xx_mac80211 module, the following line comes
up in /var/log/messages:

localhost kernel: bcm43xx_mac80211: !WARNING! Idle-TSSI phy->cur_idle_tssi
measuring failed. (cur=36, tgt=120). Disabling TX power adjustment
.

I have also noticed this appearing on startup.

Perhaps more significantly, I get this in /var/log/messages as soon as I issue
the dhclient wlan0 command:

localhost dhclient: wmaster0: unknown hardware address type 801

I suspect that this is significant because it is dhclient that doesn't work when
using the native driver, and this line appears ONLY when using that driver.  If
I use ndiswrapper, it doesn't appear, and I can get an IP address.

One other item that is perhaps significant (although I have always had this
problem with the bcm43xx family of drivers) is that iwconfig wlan0 gives
nonsensical readings for the signal strength (like Link Quality = 211/146).  I
really think the problem has something to do with the "unknown hardware address
type 801" message, though.  I just don't know enough about how the kernel
handles wireless devices to make sense of that message.  I wonder if anyone else
who is having similar problems has observed this...

So what do you think Mr. Aillon?  Is this still possibly a NetworkManager issue,
or does it need to be reassigned yet again?
Comment 10 Chris Hackmeyer 2007-07-20 23:42:39 EDT
The issues described in this bug report seem to have basically been resolved by
the latest kernel update as of 07-20-2007.  I'm still having some issues with
the driver, but they are not related to this bug.  So as far as I'm concerned,
case closed.
Comment 11 Dan Williams 2008-04-22 14:59:13 EDT
closing per comment #10

Note You need to log in before you can comment on or make changes to this bug.