Bug 244529 - bcm43xx wireless not functional
bcm43xx wireless not functional
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2007-06-16 14:25 EDT by Jackie
Modified: 2008-06-16 21:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 21:37:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
bcm43xx dmesg output (1.29 KB, text/plain)
2007-06-16 14:25 EDT, Jackie
no flags Details

  None (edit)
Description Jackie 2007-06-16 14:25:10 EDT
Description of problem:
I have found several other bcm43xx bugs on the list, but this does not seem to
fit those descriptions. I have used both ndiswrapper and bcm43xx-fwcutter and
still cannot get this to work fully. I am using a Dell B130 with an internal
BCM4318 wireless card. I am using the bcmwl5.sys driver that actually is the
driver that works on my windows side so I know the driver is good and it up to
date. I install the firmware using the fwcutter and update the kernel mods and
all seem fine and dandy. The problem comes when I bring the wireless up. I keep
getting this :
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device eth1 ; Operation not supported.

I also get the messages which I have attached when I use 'dmesg'. I also see the
following error repeating on my access point server when I bring the wireless
device on my laptop up:
Wifi0: Stuck beacon; resetting (bmiss count 4) 

I have tried to change the channels around with the same result.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. See above
Actual results:
See above

Expected results:
Fully functional wireless

Additional info:
Comment 1 Jackie 2007-06-16 14:25:10 EDT
Created attachment 157200 [details]
bcm43xx dmesg output
Comment 2 Oscar Valdez 2007-06-27 12:05:11 EDT
This bug is a duplicate of bugs 242338, 242585, 243097, 243487, 243585, and
245084. It' obviously a problem for many users.

The fix posted on fedora-list by John W. Linville here:
doesn't work (at least for me, and, I suspect, for many others).

Please pay attention to this bug. I think it's a NetworkManager problem.
Comment 3 Ronald vd Meer 2007-12-20 17:58:07 EST
Some useful information:

[root@localhost ~]# iwconfig
lo        no wireless extensions.
eth0      no wireless extensions.
wmaster0  no wireless extensions.
wlan0     IEEE 802.11g  ESSID:""  
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
          Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

[root@localhost ~]# lsmod | grep b43
b43                   129637  0 
rfkill                  9297  1 b43
mac80211              112461  1 b43
input_polldev           7241  1 b43
ssb                    29893  1 b43

[root@localhost ~]# ifup wlan0
SIOCSIFFLAGS: Operation not supported
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.
SIOCSIFMTU: Invalid argument

Determining IP information for wlan0...SIOCSIFFLAGS: Operation not supported
SIOCSIFFLAGS: No such device

[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-wlan0 
# Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express

Note: The last config file is created by system-config-network. When checking
this file it came to my attention that the comment (#) is the same as the eth0?
Although I dont think this is the issue, it just came to my attention.
Comment 4 Ronald vd Meer 2007-12-21 02:19:10 EST
By the way: the first error SIOCSIFFLAGS comes from the os trying to bring the
interface up. 

See file: /etc/sysconfig/network-scripts/ifup-wireless:
/sbin/ip link set dev ${DEVICE} up ("ifup-wireless" line 34 of 102 --33%-- col 1
Comment 5 Ronald vd Meer 2007-12-21 16:15:25 EST
Ok, I found a solution for my problem.


Also blacklist the ssb module in /etc/modprobe.d/blacklist

[root@localhost ~]# cat /etc/modprobe.d/blacklist | grep "blacklist ssb"
blacklist ssb
[root@localhost ~]#

The short solution is rebooting the system or else try to unload the ssb module.
Comment 6 Ronald vd Meer 2007-12-21 18:06:41 EST
To get the module loaded during startup put the following line in the

alias wlan0 b43

The website I mentioned above says there should be something like:
alias wlan0 bcm43xx_mac80211 in the modprobe file.

For newer kernels (tested on fedora 7) this is not working. Load b43 instead and
it will work!

Comment 7 Bug Zapper 2008-05-14 09:08:31 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2008-06-16 21:37:22 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.