Bug 243487 - wireless not working in F-7 (bcm43xx_mac80211, 4311 chipset)
wireless not working in F-7 (bcm43xx_mac80211, 4311 chipset)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 19:46 EDT by Dave Maley
Modified: 2008-04-22 15:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.22.2-57.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 11:12:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (26.13 KB, text/plain)
2007-06-08 19:57 EDT, Dave Maley
no flags Details
syslog (2.54 MB, text/plain)
2007-06-08 19:59 EDT, Dave Maley
no flags Details
bcm43xx-old-config (592 bytes, application/x-shellscript)
2007-07-16 10:17 EDT, John W. Linville
no flags Details

  None (edit)
Description Dave Maley 2007-06-08 19:46:40 EDT
Description of problem:

Just did a fresh install of Fedora 7 on my laptop (HP dv2120) and come to find
that my wireless is no longer working.  It's a broadcom 4311 chip:

[dave@smithers broadcom-wl-4.80.53.0]$ sudo lspci -n | grep 01:00.0
01:00.0 0280: 14e4:4311 (rev 01)

The bcm43xx_mac80211 module loads properly and is able to scan the surrounding
networks, but it's unable to connect.  I started out trying to use
NetworkManager but I've also attempted to bring up the interface manually.

I'm using v4 firmware (4.80.53.0) and have also tried cutting the (v4) driver
that came bundled w/ the laptop.

Will attach dmesg and syslog shortly, just let me know what else I can
provide/do to help.


Version-Release number of selected component (if applicable):

kernel-2.6.21-1.3194.fc7.x86_64


How reproducible:

every time


Steps to Reproduce:
1. attempt to connect to AP using NetworkManager
2. 
3.

  
Actual results:

fails to connect


Expected results:

connection


Additional info:

lspci -vvv:

01:00.0 Network controller: Broadcom Corporation Dell Wireless 1390 WLAN
Mini-PCI Card (rev 01)
        Subsystem: Hewlett-Packard Company Unknown device 1363
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 19
        Region 0: Memory at c3000000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=2 PME-
        Capabilities: [58] Message Signalled Interrupts: Mask- 64bit- Queue=0/0
Enable-
                Address: 00000000  Data: 0000
        Capabilities: [d0] Express Legacy Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
                Device: Latency L0s <4us, L1 unlimited
                Device: AtnBtn- AtnInd- PwrInd-
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s, Port 0
                Link: Latency L0s <4us, L1 <64us
                Link: ASPM Disabled RCB 64 bytes CommClk- ExtSynch-
                Link: Speed 2.5Gb/s, Width x1
Comment 1 Dave Maley 2007-06-08 19:57:30 EDT
Created attachment 156630 [details]
dmesg
Comment 2 Dave Maley 2007-06-08 19:59:47 EDT
Created attachment 156631 [details]
syslog
Comment 3 Dave Maley 2007-06-08 20:15:16 EDT
some other things I've tried ....

kernel-2.6.21-1.3194.fc7.x86_64 bcm43xx softmac
* modules loads fine and can scan nets but also can't connect.  using same fw
version (3.100.64.0) that worked in fc6.

kernel-xen-2.6.20-2925.9.fc7.x86_64 bcm43xx softmac
* this actually works for me.  it's a painfully slow connection just like
(un-patched) fc6 2.6.20 kernels.

wireless-dev mac80211 (git cloned 6/7/07)
* same as kernel-2.6.21-1.3194.fc7.x86_64.
Comment 4 Dave Maley 2007-06-13 02:28:17 EDT
update to comment #3 ...

kernel-2.6.21-1.3194.fc7.x86_64 bcm43xx softmac actually does work, after doing:

   # echo "14e4 4311" > /sys/bus/pci/drivers/bcm43xx/new_id


For anybody looking to use the old bcm43xx (softmac) driver I highly recommend
just using the script Mr. Linville posted:

   https://www.redhat.com/archives/fedora-list/2007-June/msg01009.html
Comment 5 Oscar Valdez 2007-06-27 12:04:35 EDT
This bug is a duplicate of bugs 242338, 242585, 243097, 243585,  244529, and
245084. It' obviously a problem for many users.

The fix posted on fedora-list by John W. Linville here:
 https://www.redhat.com/archives/fedora-list/2007-June/msg01009.html 
doesn't work (at least for me, and, I suspect, for many others).

Please pay attention to this bug. I think it's a NetworkManager problem.
Comment 6 John W. Linville 2007-07-16 10:17:27 EDT
Created attachment 159323 [details]
bcm43xx-old-config

Updated version of "use old bcm43xx driver" script.
Comment 7 John W. Linville 2007-07-16 10:19:20 EDT
Regarding comment 5...Oscar, spamming bugzilla is not very helpful.  The fact 
that the bugs you listed all involve bcm43xx hardware does not make them the 
same bug.

Did you actually open a bug specific to the issues you are experiencing?
Comment 8 Oscar Valdez 2007-07-16 10:34:28 EDT
I don't think I was spamming. I reviewed all the bugs that I listed, and in my
opinion, they are the same bug.

I just seemed to me that they needed to be properly flagged as being the same
bug, and that more attention needed to be devoted to it.
Comment 9 John W. Linville 2007-07-16 10:49:35 EDT
Oscar, "bcm43xx doesn't work" does not make them the same bug.  Please open a 
bug describing the specific problem you are seeing.
Comment 10 John W. Linville 2007-08-02 15:34:54 EDT
Dave, could you try the bcm43xx-mac80211 driver in current 2.6.22.1-41.fc7?  
How does it perform with the 4311?
Comment 11 Dave Maley 2007-08-15 11:38:48 EDT
Hey John, been meaning to post an update here for a while now ...

I'm still unable to connect using bcm43xx-mac80211 at my house (128bit wep). 
However I had a chance to test it at my in-laws and it worked quite reliably. 
They leave their AP unsecured so I was thinking it might be a wep issue, but I
tested at home w/out wep and still can't connect.  We both have Linksys WRT54G
routers but I'm fairly sure they're different revisions.
Comment 12 Martin Jürgens 2007-08-15 13:16:37 EDT
Hi guys,

I think that I am running into the same symptoms but it was the same with Ubuntu.

I can't connect to open and closed APs when I use the bcm43xx_mac80211 driver.
When I use the bcm43xx one, everything works. I remember reading that the
_mac80211 driver does not support older hardware chipsets, but I do not remember
where and it was a long time ago.

00:06.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g]
802.11g Wireless LAN Controller (rev 02)
        Subsystem: Unknown device 17f9:0006
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
        Latency: 64
        Interrupt: pin A routed to IRQ 19
        Region 0: Memory at d0000000 (32-bit, non-prefetchable) [size=8K]

Comment 13 Dave Maley 2007-08-20 18:29:31 EDT
OK so w/ the latest kernel (2.6.22.1-41.fc7) my inability to establish a
connection is indeed WEP specific.

Over the weekend I had to replace my Linksys so I ended up picking up a Netgear
WGR614NA.  I quickly tested bcm43xx-mac80211 against the router before enabling
WEP and bingo it worked like a champ.  However after enabling WEP
bcm43xx-mac80211 wouldn't work, although bcm43xx continues to works great ....
Comment 14 John W. Linville 2007-08-21 13:45:04 EDT
Dave, try the -57 kernels (currently in updates-testing):

   http://koji.fedoraproject.org/koji/buildinfo?buildID=13752

Do these work better?
Comment 15 Dave Maley 2007-08-22 11:09:03 EDT
John - The b43 module in the -57 kernel is working like a champ w/ WEP enabled,
so this would appear to resolve my issues reported here.  Thanks much!
Comment 16 John W. Linville 2007-08-22 11:12:40 EDT
Phew...closing based on above feedback! :-)

Note You need to log in before you can comment on or make changes to this bug.