Bug 244757 - oggdec produces files with no sound
oggdec produces files with no sound
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vorbis-tools (Show other bugs)
7
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
:
: 313471 349221 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 20:09 EDT by Jim Simmons
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.1.1.svn20070412-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 22:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix bug which used wrong output buffer when not remapping channels (833 bytes, patch)
2007-07-14 07:49 EDT, Ian Malone
no flags Details | Diff
Patch against F-7 branch of vorbist-tools to apply upstream patch (2.75 KB, patch)
2007-09-13 16:42 EDT, Todd Zullinger
no flags Details | Diff

  None (edit)
Description Jim Simmons 2007-06-18 20:09:17 EDT
Description of problem:

oggdec in vorbis-tools-1.1.1.svn20070412-2.fc7 does not work for me.  It
produces an output file (either raw or wav), but the file has no sound when
played back and if you do a "od -c" on a wav output file you see that most
of the file is nulls.

Version-Release number of selected component (if applicable):

vorbis-tools-1.1.1.svn20070412-2.fc7

How reproducible:

Always on this machine.

Steps to Reproduce:
1. Start with any ogg format sound file.
2. oggdec -o /tmp/xxx.wav /usr/share/sounds/Kopete_Event.ogg
3. play /tmp/xxx.wav
4. od -c /tmp/xxx.wav
  
Actual results:

Results from the od -c:

0000000   R   I   F   F   $ 030 003  \0   W   A   V   E   f   m   t
0000020 020  \0  \0  \0 001  \0 002  \0   D 254  \0  \0 020 261 002  \0
0000040 004  \0 020  \0   d   a   t   a  \0 030 003  \0  \0  \0  \0  \0
0000060  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
*
0614040  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
0614054


Expected results:

Same as "play /usr/share/sounds/Kopete_Event.ogg

Additional info:

I can copy the ogg file to an OpenBSD 4.1 system and use vorbis-tools-1.1.1
there and everything works as expected.  This system has all patches installed
as of today.
Comment 1 Joshua M. Thompson 2007-07-03 00:22:30 EDT
Same problem here, just noticed it today when I couldn't figure out why the CD I
had just burned didn't play in my car. My system is also completely up to date.
Comment 2 Douglas Kilpatrick 2007-07-12 10:08:04 EDT
same for me, on x86_64.
 oggdec -o foo-dec.wav rock/Nirvana-Nevermind-01.ogg
oggdec from vorbis-tools 1.1.1.svn20070412
Decoding "rock/Nirvana-Nevermind-01.ogg" to "foo-dec.wav"
        [100.0%]
$ ogg123 -d wav -f foo-123.wav rock/Nirvana-Nevermind-01.ogg

Audio Device:   WAV file output

Playing: rock/Nirvana-Nevermind-01.ogg
Ogg Vorbis stream: 2 channel, 44100 Hz
Album: Nevermind
Artist: Nirvana
Date: 1991
Description:
Genre: Rock
Title: Smells Like Teen Spirit
Track number: 1

Done.
$ file foo*wav
foo-123.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, 
stereo 44100 Hz
foo-dec.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, 
stereo 44100 Hz
$ md5sum foo*wav
328c86248cf99129f03f91c40d28a47a  foo-123.wav
a918b1ede4d08a83c9c1bdac6e21f111  foo-dec.wav
$ od -c foo-123.wav | wc -l
3317327
$ od -c foo-dec.wav
0000000   R   I   F   F   T 325   * 003   W   A   V   E   f   m   t
0000020 020  \0  \0  \0 001  \0 002  \0   D 254  \0  \0 020 261 002  \0
0000040 004  \0 020  \0   d   a   t   a   0 325   * 003  \0  \0  \0  \0
0000060  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
*
312552520  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
312552534
Comment 3 Boris Glawe 2007-07-12 18:47:30 EDT
I can confirem that, too!!

As the tool is not working at al, I would suggest to increase to priority from
low to high!

greets Boris
Comment 4 Ian Malone 2007-07-14 04:41:36 EDT
Can confirm here.

Problem appears to be in vorbis-tools: building 
http://svn.xiph.org/tags/vorbis1_0_1_public_release/vorbis-tool (after removing
the CURLOPT_MUTE line as per https://trac.xiph.org/ticket/1097) produces an
oggdec that works properly.

I haven't been able to build current vorbis-tools SVN, if I get a chance will
look at what's been done to the F7 package to get it to build.
Comment 5 Ian Malone 2007-07-14 07:49:05 EDT
Created attachment 159267 [details]
fix bug which used wrong output buffer when not remapping channels

Expect this will be fixed in upstream shortly, here's the patch for anyone in a
rush.
Comment 6 Ian Malone 2007-07-15 11:38:33 EDT
Fixed in upstream
Comment 7 Matthew Flaschen 2007-08-02 01:51:53 EDT
I built the svn, and can confirm the fix works.
Comment 8 Paul W. Frields 2007-08-14 12:08:25 EDT
Tickle.  When will we see this in the repos?
Comment 9 Ian Malone 2007-09-11 10:21:37 EDT
Package appears to be abandoned currently (see bug 226532), I have asked on
Fedora-devl-list if F8 can use a newer svn.  A fixed F7 i386 package is
available from
http://www.imalone.co.uk/tmp/vorbis-tools-1.1.1.svn20070412-3.fc7.i386.rpm
debuginfo
http://www.imalone.co.uk/tmp/vorbis-tools-debuginfo-1.1.1.svn20070412-3.fc7.i386.rpm

I can provide the updated .src.rpm too if anyone cares.
Comment 10 Behdad Esfahbod 2007-09-11 18:49:28 EDT
Bastien, any idea?
Comment 11 Bastien Nocera 2007-09-12 05:17:20 EDT
(In reply to comment #9)
> Package appears to be abandoned currently (see bug 226532), I have asked on

The package isn't orphaned, the maintainer's just very busy. And the lack of
merge review means nothing apart from no people to review it...

> Fedora-devl-list if F8 can use a newer svn.  A fixed F7 i386 package is
> available from
> http://www.imalone.co.uk/tmp/vorbis-tools-1.1.1.svn20070412-3.fc7.i386.rpm
> debuginfo
>
http://www.imalone.co.uk/tmp/vorbis-tools-debuginfo-1.1.1.svn20070412-3.fc7.i386.rpm
> 
> I can provide the updated .src.rpm too if anyone cares.

Applying the patch would be just fine, unless there's a new upstream release we
can use.
Comment 12 Todd Zullinger 2007-09-13 16:42:20 EDT
Created attachment 195221 [details]
Patch against F-7 branch of vorbist-tools to apply upstream patch

I ran into this one a few weeks back and meant to add a comment here to confirm
the patch seemed to solve the problem, as well as to post a diff against CVS
(F-7 branch) to make it easier to apply and push a new build.  So belatedly,
here's that patch.  Same thing will apply to the devel branch with the release
bumped (since the devel branch was rebuilt to pick up the build id feature).

I'm happy to apply this to CVS and push a build through bodhi if it'd help out.
 I'm sure this bug isn't a big deal to many people, but it's somewhat annoying
when you do run into it. :)
Comment 13 Ian Malone 2007-09-14 17:32:42 EDT
Hi, just some feedback; an upstream release is probably due, but not planned.
Changeset [13263] is a couple of benign bugfixes (including this one) past the
current F7 package. Thanks for taking action on this (was just a bit worried
that F8 looked like it might ship with it).
Comment 14 Matthias Clasen 2007-10-04 23:35:18 EDT
Todd, I think it would be just fine if you build and push an update with that
patch. Behdad is currently traveling.
Comment 15 Matthias Clasen 2007-10-04 23:35:36 EDT
*** Bug 313471 has been marked as a duplicate of this bug. ***
Comment 16 Matthias Clasen 2007-10-04 23:37:03 EDT
Oh, and if you'd also build it for F8, that would be great.
Comment 17 Todd Zullinger 2007-10-05 00:59:38 EDT
Matthias, I've committed the changes to CVS for the F-7 and devel branches.  I
emailed rel-eng to make sure they'll be alright tagging the build for F8.  As
soon as they okay that I'll build and push.

(Thanks Ian for the patch and prodding.)
Comment 18 Fedora Update System 2007-10-10 15:33:02 EDT
vorbis-tools-1.1.1.svn20070412-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vorbis-tools'
Comment 19 Amadeus 2007-10-10 18:14:10 EDT
It doesn't seam to have been added yet. ???

~$ su -c 'yum --enablerepo=updates-testing update vorbis-tools'
Password: 
adobe-linux-i386          100% |=========================|  951 B    00:00     
fedora                    100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 3.8 MB    11:52     
updates-testing           100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 244 kB    01:03     
updates                   100% |=========================| 2.3 kB    00:00     
freshrpms                 100% |=========================| 2.1 kB    00:00     
Excluding Packages in global exclude list
Finished
Setting up Update Process
Could not find update match for vorbis-tools
No Packages marked for Update
~$ 

Comment 20 Ian Malone 2007-10-11 07:48:07 EDT
It sometimes takes time for the update to get to the repositories. It's now
installed and working here; I think this can be closed.  Cheers for getting the
new package out.
Comment 21 Fedora Update System 2007-10-17 22:23:19 EDT
vorbis-tools-1.1.1.svn20070412-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Hans de Goede 2007-10-23 17:03:45 EDT
*** Bug 349221 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.