Bug 245084 - bcm43xx doesn't work
bcm43xx doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-20 18:33 EDT by Tim Kitsos
Modified: 2008-01-15 08:49 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23.9-85.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 08:49:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci + dmesg (26.68 KB, text/plain)
2007-06-20 18:33 EDT, Tim Kitsos
no flags Details
var/log/messages (59.04 KB, text/plain)
2007-11-03 00:40 EDT, Tim Kitsos
no flags Details
Terminal history#1 (11.18 KB, text/plain)
2007-11-30 17:24 EST, Tim Kitsos
no flags Details
Terminal history#2 (1.53 KB, text/plain)
2007-11-30 17:25 EST, Tim Kitsos
no flags Details
var/log/messages for F* (449.30 KB, text/plain)
2007-11-30 17:26 EST, Tim Kitsos
no flags Details
var/log/messages F8 01/11/07 (1.33 MB, text/plain)
2008-01-11 22:51 EST, Tim Kitsos
no flags Details

  None (edit)
Description Tim Kitsos 2007-06-20 18:33:29 EDT
Description of problem:

Linux 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 15:37:31 EDT 2007

Was able to get bcm43xx working with f6 (bcmwl5.sys), but can't with f7.

Steps to Reproduce:
1.Tried method #1 seem to show up in ethernet list instead of wireless list.
2. Tried method #2 says Temporary failure in name resolution.
3. Not sure if I'm doing it right or what to do next.
Comment 1 Tim Kitsos 2007-06-20 18:33:29 EDT
Created attachment 157504 [details]
lspci + dmesg
Comment 2 Oscar Valdez 2007-06-27 12:05:38 EDT
This bug is a duplicate of bugs 242338, 242585, 243097, 243487, 243585,  and
244529. It' obviously a problem for many users.

The fix posted on fedora-list by John W. Linville here:
 https://www.redhat.com/archives/fedora-list/2007-June/msg01009.html 
doesn't work (at least for me, and, I suspect, for many others).

Please pay attention to this bug. I think it's a NetworkManager problem.
Comment 3 Robin Green 2007-07-05 15:16:01 EDT
Tim - what are you talking about when you say method #1 and method #2?
Comment 4 Peter Wainwright 2007-07-08 16:14:29 EDT
Upgrade to Fedora 7 (kernel 2.6.21-1.3194.fc7) has also broken my BCM4318.
It will not associate to the AP.  I suspect that WPA-PSK is not working.

I had the "FIRMWARE TOO OLD" problem and cut the new firmware as
suggested in https://www.redhat.com/archives/fedora-list/2007-June/msg01009.html.
Now, when I start "/etc/init.d/wpa_supplicant start" I still
see the following:

Starting wpa_supplicant: ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 -                              [  OK  ]

and when I execute "/sbin/ifup eth1" the interface appears to be up
but I cannot connect to 192.168.1.1 (the AP) because there is
"no route to host".

This is definitely a Fedora problem.  I have a homebrew kernel from
kernel.org (2.6.21.5) which works perfectly (uses the old bcm43xx driver
and older firmware).  I have reverted to this.

Do you think the failed ioctl is related to a failure of WPA (the
name SIOCSIWAUTH seems to indicate an authentication issue)?

Comment 5 Tim Kitsos 2007-08-25 18:21:05 EDT
(In reply to comment #3)
> Tim - what are you talking about when you say method #1 and method #2?

I did the two methods that John W. Linville recommended:

http://marc.info/?l=fedora-list&m=118096307315653

You can also see exactly what I did in my comment #1 listed above.

==========
I've beening using Redhat since RH7.3 and now Fedora.  Since I switched to
wireless use only, when it doesn't work I go back to WinXP. I guess this is
going to be one of those year long waits.  Back to WinXP  Just updated to
current Kernel today but still no luck. I like Linux Fedora but too hard to keep
equipment working - so I never recommended it to non geeks.  It's absolutely
ready for the desktop if you can get your equipment to work.
Comment 6 Jackie 2007-08-25 22:45:15 EDT
I have reverted back to using FC6 until either F8 comes out or we have a
breakthrough with this issue. I would love to find the time to compare the
kernel I have in FC6 to the kernels released to F7, but I have started school
back up and I am working full time so time is very limited. It has got to be
something that was changed in the kernel and not an issue with the driver
itself. But, that is just a wild guess on my part.
Comment 7 Tim Kitsos 2007-08-30 23:34:47 EDT
Thanks for the info.  Guess it's not a Fedora problem, it's a kernel problem. 
May go back to FC6 or wait it out.
Comment 8 Christopher Brown 2007-09-17 07:37:26 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

I'm re-assigning to the wireless maintainer who may review this further.

My comment would be that the broadcom driver is still very new undergoing heavy
development, not helped by zero assistance from broadcom. You may wish to test
with 2.6.23 when this arrives as there is possibly further updates in this.

Cheers
Chris
Comment 9 Tim Kitsos 2007-09-18 19:18:39 EDT
Thanks!  I appreciate your hard work.
Comment 10 John W. Linville 2007-10-22 17:07:23 EDT
What sort of network are you you using?  Can you post your 
wpa_supplicant.conf?

Can you connect to an open or WEP network?  Without either wpa_supplicant or 
NetworkManager?

Alternatively, can you try _not_ starting wpa_supplicant and using 
NetworkManager instead?
Comment 11 Tim Kitsos 2007-10-23 00:14:27 EDT
Hope this information helps and is what you wanted. If not let me know. Thanks
again for you help.

Using AT&T (former SBC) SBC Yahoo DSL 2700HG-B Gateway 2Wire PPPoE  IPv4
Automatically obtain IP address:dhcp
Automatically obtain DNS infor from provider.

Using Network Configuration New Devices doesn't see wireless Broadcom card so I
can't create a new wireless connection. But wireless card shows up under
hardware as a Ethernet card eth1.

NetworkManager Applet 0.6.5 sees my wired & wireless networks. It also sees two
neighbors wireless networks.
Able to connect with wired ethernet eth0 cable only.

System/Administration/Services/Service Configuration/
Network Manager (box checked)  Status Network Manager (pid 2371) is running...
Wpa_Supplicant (box not checked)  Status  Wpa_Supplicant is stopped

File: wpa_supplicant.conf

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
        <policy user="root">
                <allow own="fi.epitest.hostap.WPASupplicant"/>

                <allow send_destination="fi.epitest.hostap.WPASupplicant"/>
                <allow send_interface="fi.epitest.hostap.WPASupplicant"/>
        </policy>
        <policy at_console="true">
                <allow send_destination="fi.epitest.hostap.WPASupplicant"/>
                <allow send_interface="fi.epitest.hostap.WPASupplicant"/>
        </policy>
        <policy context="default">
                <deny own="fi.epitest.hostap.WPASupplicant"/>
                <deny send_destination="fi.epitest.hostap.WPASupplicant"/>
                <deny send_interface="fi.epitest.hostap.WPASupplicant"/>
        </policy>
</busconfig>
Comment 12 John W. Linville 2007-11-02 15:24:51 EDT
FWIW, you didn't manage to actually attach wpa_supplicant.conf.  But, I don't 
really think we need it as long as you are using NetworkManager.

Can you attach the contents of /var/log/messages after trying to connect to 
your wireless network?  Thanks!
Comment 13 Tim Kitsos 2007-11-03 00:40:53 EDT
Created attachment 247191 [details]
var/log/messages

file var/log/messages
Comment 14 Tim Kitsos 2007-11-30 17:24:31 EST
Created attachment 274421 [details]
Terminal history#1
Comment 15 Tim Kitsos 2007-11-30 17:25:36 EST
Created attachment 274441 [details]
Terminal history#2
Comment 16 Tim Kitsos 2007-11-30 17:26:48 EST
Created attachment 274461 [details]
var/log/messages for F*
Comment 17 Tim Kitsos 2007-11-30 17:31:12 EST
Deleted & Resized & Created New partition.  Installed Fedora 8, did online
updates. Followed instruction from:
http://fedoramobile.org/fc-wireless/bcm43xx-yum-extras/  (For bcm43xx).  Wait
back and did (For b43)also. Blue light on front of laptop came on indicating
Wireless is on.  Network Manager Applet shows my wifi and two other wifi
signals. One of which doesn't require a access key. Not able to connect to that
one or my own wifi. iwlist scan shows all three wifi signals. Ethernet cable to
internet works.
Comment 18 Tim Kitsos 2007-11-30 17:44:38 EST
In network configuration: card now shows up as a inactive wireless card.  wlan0
 Not able to activate.
Comment 19 John W. Linville 2007-12-01 15:17:21 EST
Nov 29 07:29:53 localhost kernel: b43-phy0 ERROR: Firmware 
file "b43/ucode5.fw" not found or load failed.
Nov 29 07:29:53 localhost kernel: b43-phy0 ERROR: You must go to 
http://linuxwireless.org/en/users/Drivers/bcm43xx#devicefirmware and download 
the correct firmware (version 4).

Please make sure you are using the firmware available here:

   http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2

Please make sure you are using "b43-fwcutter" to extract it.

The file from comment 15 would seem to suggest that you have downloaded the 
correct firmware and extracted it with the correct tool.  Yet, the file from 
comment 16 clearly indicates that something went wrong.

You might also consider using a package I prepared privately which automates 
the download process:
 
http://fedora.tuxdriver.com/rfc/b43-firmware-download-351.126-1.fc8.noarch.rpm

Once you are sure that you have extracted the proper firmware, does the device 
function properly?
Comment 20 Tim Kitsos 2007-12-02 00:10:54 EST
I think I downloaded the correct firmware.  I tried your rpm also. The rpm is
loaded. Used:   su -c 'b43-fwcutter -w /lib/firmware
/home/tim/Download/broadcom-wl-4.80.53.0/kmod/wl_apsta.o'
Extracted O.K.  Reboot Still doesn't work.  Network Manager seems to see wifi
signals. Try to connect it asks for key etc but the "connect" button is always
gray so I can't click it.  Should auto connect anyway on boot, but if fails.
Comment 21 John W. Linville 2008-01-07 15:03:03 EST
Been a while...the kernels here have a lot of b43 changes since then:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=30119

Do they work any better for you?
Comment 22 Tim Kitsos 2008-01-09 00:12:19 EST
Will do more tests and get back to you shortly.
Comment 23 Tim Kitsos 2008-01-11 01:17:45 EST
Did all the updates. Still the same, no change, doesn't work. Can't make a 
connection.  (I was able to get Fedora 6 (before upgrade to 7&8), XP, Vista, 
and Mac all to work.)
Comment 24 John W. Linville 2008-01-11 16:17:31 EST
Please attach the output contents of /var/log/messages when using a current 
kernel.
Comment 25 Tim Kitsos 2008-01-11 22:51:12 EST
Created attachment 291451 [details]
var/log/messages F8 01/11/07
Comment 26 John W. Linville 2008-01-14 09:05:40 EST
Your messages file indicates you are using F8.  The -85.fc8 kernels are not 
equivalent to the kernels linked in comment 21.  Please try the kernels below:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=31090

If you don't get a working connect with those kernels please attach a fresh 
copy of /var/log/messages.  Also try disabling NetworkManager and configuring 
a connection with system-config-network or manually using iwconfig, dhclient, 
etc.
Comment 27 Tim Kitsos 2008-01-15 01:25:57 EST
I started to do what you told me, but the software updater had 14 updates.  So 
I let it do it's updates first. One of those updates had something to do with 
the "wpa_supplicant". I restart the pc and this time there were no failures 
(wireless).  The NetworkManager ask me for the "key". I try to give it the hex 
key but the "connect" button is gray. I type hex key in 0x...., but button is 
still gray. I start to backspace the 0x of the hex key and button becomes 
active. Click connect and it connects.  Under the System/Administration/Network 
it said to start hex key with a 0x.  I go back and check and its still says and 
has the 0x... under Sys/Adm/Ntw. Maybe my fault.  But I had tried it before 
with an 0x or # or blank(key only) and it didn't work with any of them.  I did 
not do your ID=31090 because it's working now. Maybe updates did the trick.

I do notice that the blue wireless indicator light go out sometimes for a short 
time then comes back on. Not sure if it loses the signal when light is out, I 
don't think it does.

THANK YOU! and everyone at Fedora.
Comment 28 John W. Linville 2008-01-15 08:49:09 EST
Good enough for me. :-)  Closing on the basis of comment 27...

Note You need to log in before you can comment on or make changes to this bug.