Bug 246792 - 'yum clean all' fails if no headers directory
Summary: 'yum clean all' fails if no headers directory
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 248729 249082 250398 250399 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-04 22:11 UTC by Ian Mortimer
Modified: 2014-01-21 22:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 22:21:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Mortimer 2007-07-04 22:11:12 UTC
Description of problem:
On a default f7 install `yum clean all' fails with gets errors like:

Error: Error accessing directory //var/cache/yum/fedora/headers, [Errno 2] No
such file or directory: '//var/cache/yum/fedora/headers'

A headers directory has to be created manually for every configured repo before
`yum clean all' will succeed.


Version-Release number of selected component (if applicable):
yum-3.2.1-1.fc7


How reproducible:
Every time so far.


Steps to Reproduce:
1. Install F7
2. yum update or yum check-update
3. yum clean all
  
Actual results:
Fails with above error


Expected results:
Should remove all packages and repo data files.


Additional info:
This is a regression from yum-3.0.6-1.fc6 where `yum clean all' works fine even
if the headers directory is removed - it gets recreated.

Comment 1 Seth Vidal 2007-07-04 22:21:06 UTC
already fixed in cvs - will be available in yum 3.2.2 - 'eventually'

thanks

Comment 2 Seth Vidal 2007-07-18 15:21:05 UTC
*** Bug 248729 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2007-07-24 20:35:06 UTC
*** Bug 249082 has been marked as a duplicate of this bug. ***

Comment 4 Seth Vidal 2007-08-01 12:26:20 UTC
*** Bug 250398 has been marked as a duplicate of this bug. ***

Comment 5 Seth Vidal 2007-08-01 12:26:33 UTC
*** Bug 250399 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.