This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 249304 - cupsd uses the Apple Bonjour compatiblity layer of Avahi
cupsd uses the Apple Bonjour compatiblity layer of Avahi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Triaged
: 249305 427835 432169 526944 (view as bug list)
Depends On:
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2007-07-23 12:32 EDT by Jonathan Kamens
Modified: 2011-05-04 11:11 EDT (History)
11 users (show)

See Also:
Fixed In Version: cups-1.4.5-9.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-24 08:38:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2007-07-23 12:37:56 EDT
*** Bug 249305 has been marked as a duplicate of this bug. ***
Comment 1 Tim Waugh 2007-07-23 12:50:17 EDT
Upstream plans to fix this:

http://cups.org/articles.php?L479 (see comments at end of page)

Patches welcome; I don't know the avahi API at all myself.
Comment 2 Tim Waugh 2008-01-08 04:38:50 EST
*** Bug 427835 has been marked as a duplicate of this bug. ***
Comment 3 udo 2008-01-08 04:57:34 EST
Who is working on this issue?
Because I got a `will not fix` http://www.cups.org/str.php?L2655 from the cups
folks.
So who can/will write a patch?
Comment 4 Tim Waugh 2008-01-08 05:03:02 EST
You are welcome to provide a patch. :-)
Comment 5 udo 2008-01-08 05:33:18 EST
I know (this is not my first bugzilla entry) but probably a more skileld person
is required although I might giev it a try. Is there any documentation on this
`conversion` available?
Comment 6 Tim Waugh 2008-01-08 05:48:55 EST
Not that I've found.
Comment 7 Tim Waugh 2008-02-11 06:14:47 EST
*** Bug 432169 has been marked as a duplicate of this bug. ***
Comment 8 Martin Jürgens 2008-04-17 17:42:03 EDT
Try asking Richard Hughes maybe.
Comment 9 Martin Jürgens 2008-04-21 12:29:09 EDT
I meant Lennart Poettering, sorry.. AFAIK he's a Red Hat employee and Avahi
developer..
Comment 10 Bug Zapper 2008-05-13 23:05:25 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Tim Waugh 2008-05-28 05:22:49 EDT
Deferring to rawhide.
Comment 12 Bug Zapper 2008-11-25 20:57:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 udo 2008-12-07 11:34:17 EST
Dec  7 11:14:43 localhost cupsd[2583]: *** WARNING *** The program 'cupsd' uses the Apple Bonjour compatibility layer of Avahi.
Dec  7 11:14:43 localhost cupsd[2583]: *** WARNING *** Please fix your application to use the native API of Avahi!
Dec  7 11:14:43 localhost cupsd[2583]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=cupsd>

Still present on Fedora 10 as released.
So were heading towards a 1.5 year anniversary of this issue.
Comment 14 Tim Waugh 2009-05-14 11:28:18 EDT
I have been trying to fix this since January but other things are always more important. :-(

This is no trivial task.

Moving to F11Target.
Comment 15 udo 2009-05-14 11:41:16 EDT
Do we need to bribe you?
Comment 16 Tim Waugh 2009-05-14 11:59:04 EDT
No, send a patch, or send patches for the other more pressing bugs so I have more time for this. :-)
Comment 17 udo 2009-06-16 12:27:12 EDT
GSOC 2010 perhaps?
Because moving a target along does not really fix the issue.
Or must I start advocating to make this bug a blocker for F12?
Comment 18 Tim Waugh 2009-10-04 14:14:35 EDT
*** Bug 526944 has been marked as a duplicate of this bug. ***
Comment 19 Guillaume Rousse 2009-10-16 09:52:56 EDT
Hello guys.

I guess you're refering to this patch:
http://cvs.fedoraproject.org/viewvc/rpms/cups/devel/cups-avahi.patch?view=log

Has it been submitted upstream already ?
Comment 20 Tim Waugh 2009-10-16 10:13:28 EDT
No, that's just the discovery patch.  That's the easy part.

The main work is in getting the scheduler to advertise its queues using avahi.

Until that work is done there is no use in submitting the smaller discovery patch, as they will likely share code and it will be a lot easier to submit a finished patch to do both parts.
Comment 21 Bug Zapper 2009-11-16 02:56:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 udo 2010-08-23 11:16:46 EDT
Maybe assign this bug to avahi so they can drop the compatibility layer.
Then, as a result, things may change?
Comment 23 Tim Waugh 2010-08-23 11:38:44 EDT
That won't speed anything up.  I'll just have to rip out the DNS-SD support altogether in that case.
Comment 24 udo 2010-08-23 11:44:35 EDT
But the process gets more political and that could help.
The bug would block, people pay attention and the job might get done.
Comment 25 Tim Waugh 2010-08-23 12:18:39 EDT
Well, as the person who would be doing the work: let me assure you it won't give me any more time to do it in. :-)
Comment 26 udo 2010-08-23 12:22:58 EDT
If you think that nobody can or will help... I can't help there. Just a suggestion, please think about it.
Comment 27 udo 2010-12-24 08:47:50 EST
EUh?
What does this mean?
It is fixed?
How can I test on Fedora 13?
Comment 28 Tim Waugh 2010-12-24 08:51:09 EST
It's a very substantial change with lots of new code and potential for bugs and so is currently being tested in Fedora rawhide.
Comment 29 JM 2011-05-04 10:41:41 EDT
Is this bug fixed in

cups-1.4.6-1.fc14

? Or is this bug only fixed in 1.4.5-9.fc15 (rawhide)?

Because in Fedora 14 I still have the problem that cups does not advertise the printers via Bonjour and Fedora 14 has the version 1.4.6-1.
Comment 30 Jiri Popelka 2011-05-04 11:11:26 EDT
(In reply to comment #29)
> ? Or is this bug only fixed in 1.4.5-9.fc15 (rawhide)?

Yes, it's Fedora 15 (and later) only.

Note You need to log in before you can comment on or make changes to this bug.