Bug 251890 - Exchanged and incomplete glyphs
Summary: Exchanged and incomplete glyphs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All All
low
medium
Target Milestone: ---
Assignee: Caius Chance
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: 304441 440992
TreeView+ depends on / blocked
 
Reported: 2007-08-13 08:49 UTC by Serg Bormant
Modified: 2008-06-11 01:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 06:54:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exchanged and incomplete glyphs (5.13 KB, image/gif)
2007-08-13 08:49 UTC, Serg Bormant
no flags Details
progress (5.28 KB, image/png)
2008-01-23 05:40 UTC, Caius Chance
no flags Details
Test Case (99.00 KB, application/msword)
2008-03-25 00:45 UTC, Caius Chance
no flags Details
Revised fonts. (1.10 MB, application/zip)
2008-03-25 02:05 UTC, Caius Chance
no flags Details
Test result pictures - serif. (27.67 KB, image/png)
2008-03-25 02:05 UTC, Caius Chance
no flags Details
Test result pictures - sans. (27.01 KB, image/png)
2008-03-25 02:06 UTC, Caius Chance
no flags Details
Test result pictures - mono. (24.89 KB, image/png)
2008-03-25 02:06 UTC, Caius Chance
no flags Details
Test Case (94.50 KB, application/msword)
2008-03-25 05:04 UTC, Caius Chance
no flags Details
Screenshot. (58.79 KB, image/png)
2008-03-25 05:04 UTC, Caius Chance
no flags Details
Screenshot: size 40, dpi 96, screen 1280x1024, no hinting, no smoothing, fedora 9 (rawhide). (5.78 KB, image/png)
2008-03-26 06:56 UTC, Caius Chance
no flags Details
Sources Tarball (1.10 MB, application/x-gzip)
2008-04-10 23:44 UTC, Caius Chance
no flags Details
Repacked (1.11 MB, application/x-gzip)
2008-06-11 01:53 UTC, Caius Chance
no flags Details
1.03 ZIP. (1.11 MB, application/zip)
2008-06-11 01:53 UTC, Caius Chance
no flags Details

Description Serg Bormant 2007-08-13 08:49:58 UTC
Description of problem:

There are some bugs encountered in LIBERATION fonts (downloaded at 
https://www.redhat.com/f/fonts/liberation-fonts-ttf-3.tar.gz).

1. Liberation Serif in Italic and Bold-Italic exchange glyphs "Cyrillic Capital 
Letter Sha" (U+0428) with "Cyrillic Capital Letter Shcha" (U+0429).

2. Liberation Sans in Bold-Italic has no double dots over "Cyrillic Capital 
Letter Io" (U+0401) glyph.

Comment 1 Serg Bormant 2007-08-13 08:49:58 UTC
Created attachment 161159 [details]
Exchanged and incomplete glyphs

Comment 4 Caius Chance 2007-11-01 00:12:54 UTC
Currently, Liberation Fonts modification is not authorized except by their
manufacturer.

This bug is tracked by bug# 304441 for prompting to the attention of Ascender.

Comment 5 Caius Chance 2008-01-23 05:40:40 UTC
Created attachment 292595 [details]
progress

After source update via bug#428596, #1 is fixed but #2 hasn't.

Comment 6 Caius Chance 2008-03-25 00:45:19 UTC
Communicating with manufacturer.

Comment 7 Caius Chance 2008-03-25 00:45:51 UTC
Created attachment 298960 [details]
Test Case

Comment 8 Caius Chance 2008-03-25 02:04:37 UTC
According to the testing, the issue had been fixed.

You may feel the dots are still no aligned on the following attached pictures.
However, they are 'illusions' of human eyes. This could be proved with dragging
a horizontal lines to measure by photo editing softwares like Photoshop (r) or GIMP.

The latest version of font will be updated on rawhide very soon.

Comment 9 Caius Chance 2008-03-25 02:05:08 UTC
Created attachment 298962 [details]
Revised fonts.

Comment 10 Caius Chance 2008-03-25 02:05:45 UTC
Created attachment 298963 [details]
Test result pictures - serif.

Comment 11 Caius Chance 2008-03-25 02:06:04 UTC
Created attachment 298964 [details]
Test result pictures - sans.

Comment 12 Caius Chance 2008-03-25 02:06:32 UTC
Created attachment 298965 [details]
Test result pictures - mono.

Comment 13 Caius Chance 2008-03-25 03:13:39 UTC
(Comment# 8-12 are for bug#240525.)

Comment 14 Caius Chance 2008-03-25 05:04:00 UTC
Created attachment 298973 [details]
Test Case

Comment 15 Caius Chance 2008-03-25 05:04:22 UTC
Created attachment 298974 [details]
Screenshot.

Comment 16 Caius Chance 2008-03-25 05:05:39 UTC
According to the test with latest font files in rawhide, the issues are not
reproducible anymore.

Closing this bug.

Comment 17 Cody Boisclair 2008-03-26 06:44:56 UTC
U+0401 in Sans Bold Italic is still lacking the double dot.

Comment 18 Caius Chance 2008-03-26 06:51:03 UTC
reopen
email to manufacturer

Comment 19 Caius Chance 2008-03-26 06:56:52 UTC
Created attachment 299104 [details]
Screenshot: size 40, dpi 96, screen 1280x1024, no hinting, no smoothing, fedora 9 (rawhide).

Comment 20 Răzvan Sandu 2008-04-07 14:47:57 UTC
There is also an issue for the Romanian language; please see bug #440992

Răzvan


Comment 22 Cody Boisclair 2008-04-10 14:10:44 UTC
Is there a .tar.gz version on the way for us non-RH-using folks? Or should I generate one using alien?

Comment 23 Cody Boisclair 2008-04-10 14:14:03 UTC
Never mind; I managed to get the .tar.gz out of the source file. But it (and a zip version) should still be 
made available for posting on http://www.redhat.com/promo/fonts/.

Comment 24 Caius Chance 2008-04-10 23:44:43 UTC
Created attachment 302088 [details]
Sources Tarball

Reply to comment #22. Sorry about that.

Attaching source tarball in bugzilla as official way for public to download is
not supposed to be the case, because it should be hosted in public servers but
not bugzilla.

There are requests from Fedora community to host this font package. We are
looking at working on that after Fedora 9 released.

For people who are keen on testing the latest version, please download this
attached file.

Comment 25 Caius Chance 2008-04-10 23:50:28 UTC
(In reply to comment #23)
> Never mind; I managed to get the .tar.gz out of the source file. But it (and a
zip version) should still be 
> made available for posting on http://www.redhat.com/promo/fonts/.

I don't have the permission on the website. It is managed by another team and we
have coherent communication to update the versions on
http://www.redhat.com/promo/fonts/. Please kindly be patient.

Finally, thank you very much for supporting on our commitment to
liberation-fonts by using it. :)



Comment 26 Caius Chance 2008-06-11 01:53:28 UTC
Created attachment 308882 [details]
Repacked

Comment 27 Caius Chance 2008-06-11 01:53:56 UTC
Created attachment 308883 [details]
1.03 ZIP.


Note You need to log in before you can comment on or make changes to this bug.