Bug 289801 - "GL Desktop" menu entry appearing twice
"GL Desktop" menu entry appearing twice
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-compiz-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
: 387571 416751 (view as bug list)
Depends On: 417381
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 15:01 EDT by Denis Leroy
Modified: 2007-12-21 08:05 EST (History)
9 users (show)

See Also:
Fixed In Version: 0.10.4-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 14:50:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Leroy 2007-09-13 15:01:24 EDT
After installing gnome-compiz-manager with yum, there are two identical entries
"GL Desktop" in the menu bar (system -> preferences -> Look and feel).
Comment 1 Mohd Izhar Firdaus Ismail 2007-10-20 21:48:40 EDT
duplicate

rpm -qf /usr/share/applications/fedora-gnome-compiz-preferences.desktop 
gnome-compiz-manager-0.10.4-2.fc8
rpm -qf /usr/share/applications/gnome-compiz-preferences.desktop 
gnome-compiz-manager-0.10.4-2.fc8

Comment 2 Laurent Rineau 2007-10-25 18:56:28 EDT
+1
Patch not tested:
*** gnome-compiz-manager.spec	17 Oct 2007 08:25:38 +0200	1.2
--- gnome-compiz-manager.spec	26 Oct 2007 00:50:25 +0200	
***************
*** 64,69 ****
--- 64,70 ----
  export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  make install DESTDIR=$RPM_BUILD_ROOT
  desktop-file-install --vendor="fedora"                          \
+         --delete-original \
          --dir=${RPM_BUILD_ROOT}%{_datadir}/applications         \
          
$RPM_BUILD_ROOT%{_datadir}/applications/gnome-compiz-preferences.desktop
  rm $RPM_BUILD_ROOT/%{_libdir}/*.la


Futhermore, those two entries are shown in the KDE menu. I do not know why.

Comment 3 Denis Leroy 2007-10-26 08:04:43 EDT
AWOL maintainer ? please fix, this is a simple bug.
Comment 4 Laurent Rineau 2007-11-12 07:34:34 EST
Yes, maybe AWOL.

John, are you still there? You are not listed in 
http://fedoraproject.org/wiki/Vacation
Comment 5 Jason Merrill 2007-12-03 11:58:29 EST
*** Bug 387571 has been marked as a duplicate of this bug. ***
Comment 6 Jonathan Underwood 2007-12-09 14:06:44 EST
*** Bug 416751 has been marked as a duplicate of this bug. ***
Comment 7 Denis Leroy 2007-12-09 16:16:20 EST
I'll just go ahead and commit a fix.
Comment 8 Fedora Update System 2007-12-10 15:44:15 EST
gnome-compiz-manager-0.10.4-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-compiz-manager'
Comment 9 Matěj Cepl 2007-12-19 11:20:03 EST
Denis, what about Rawhide? Could you then close the bug as CLOSED/RAWHIDE? Or do
I have to do it?
Comment 10 Fedora Update System 2007-12-20 14:50:39 EST
gnome-compiz-manager-0.10.4-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Denis Leroy 2007-12-21 08:05:17 EST
It was also built for rawhide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=27528

but i love using the bodhi bug closing feature :-) Is CLOSED/ERRATA ok ? If not,
feel free to change that to CLOSED/RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.