Bug 30156 - Install RHL 7.0 on Win ME Fat32 partition crashes in anaconda
Install RHL 7.0 on Win ME Fat32 partition crashes in anaconda
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 43270 54557 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 01:53 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-13 03:45:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-01 01:53:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; COM+ 
1.0.2204)


When installing RHL 7 on Dell Dimension PIII 667 Mhz with Win ME already 
installed and on the same Fat32 disk filesystem, installation hangs.  The 
machine must be cold-booted.

Reproducible: Always
Steps to Reproduce:
1.Boot from RHL 7.0 CD Disk1
2.Choose Graphical installation, workstation (also reproable for server 
installation consistently), GNOME, KDE, etc
3.Use Disk Druid to set Mount Point to / on hda1 which is the one and only 
FAT32 partition on this machine.
4.somewhere after clicking Next button on Installing Package, an error 
dialog box pops up indicating that there is an exception, and is most 
likely a bug.
5.no keyboard interaction, and the mouse click button cannot activate any 
of the button on the error dialog box.
5. Cold boot, and terminate RHL 7.0 installation
	

Actual Results:  Traceback (innermostlast):
File "/var/tmp/anaconda-7.0.1 //usr/lib/anaconda/iw/progress_gui.py", line 
20, in run rc=self.todo.doInstall()
File "/var/tmp/anaconda-7.0.1 //usr/lib/anaconda/todo.py", line 1469, in 
doInstall self.fstab.makeFilesystems()
File "/var/tmp/anaconda-7.0.1 //usr/lib/anaconda/fstab.py", line 643, in 
makeFileSystems (self.progressWindow, - ("Loopback"),
File "/usr/lib/anaconda/isys.py", line 78, in ddfile

... since I can't use the mouse to scroll down to the bottom of the error 
dialog box to read additional error info, hence the aforementioned error 
info is all I can provide.

Expected Results:  Installation should complete on FAT32 partition

Since my installation of RHL 7.0 fails, I do not want to erase my WinME 
partition and repartition and attempt the RHL installation again on a 
dedicated Linux partition.  Please let me know of a work around or 
possible patch.  Because I sincerely want to learn Linux, and yet I do not 
want to lose my WinME, because that's where all of my works are.  This 
does not appear to be a dup for bug 17791.

Based on my WinME hardware info, here is the profile for my machine:
Dell UltraScan 21" monitor
MS Natural keyboard
MS OptiSense Mouse
Dell Dimension PIII 667 mHz
modem - Conexant HCF V90 56K RTAP PCI modem
NIC - 3COM EtherLink XL PCI
IDE HD - 7.16GB
128 MB memory
IDE Controller - Intel 82801AA Bus Master IDE Controller
Comment 1 Michael Fulbright 2001-03-01 12:36:15 EST
How large did you make the loopback filesystem and swap file (you are prompted
for these after partitioning your drive)?
Comment 2 Need Real Name 2001-03-01 13:22:22 EST
I don't recall ever filling in loopback filesystem and swap file. I didn't get 
prompted for that, at least not after I identified the Mount Point in Disk 
Druid.   In Disk Druid, all I did was to edit the Mount Point from <not set> 
to /.
Comment 3 Michael Fulbright 2001-03-06 15:24:16 EST
After you select '/' to be on a FAT partition, you should be asked how large to
make the root and swap files on that partition.
Comment 4 Need Real Name 2001-03-13 03:45:21 EST
OK, my mistake, I thought you meant adding additional partition in Mnt Point in 
Disk Druid.  Yes, in the next screen, I was prompted to enter Swap size, the 
default was 32 MB.  So I left it at 32 MB, since I have about 128MB or RAM.  I 
have just attempted another re-installation of RHL 7.0, and this time I 
increased the Swap size to 127MB, I could not repro this bug any more.  
Installation completed successfully.
Comment 5 Michael Fulbright 2001-04-02 11:58:17 EDT
Sorry for the confusion - glad to hear its working now.
Comment 6 Brent Fox 2001-06-12 23:19:55 EDT
*** Bug 43270 has been marked as a duplicate of this bug. ***
Comment 7 Brent Fox 2001-10-15 15:04:39 EDT
*** Bug 54557 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.