Bug 318241 - Cryptic pirut/pup error reporting
Cryptic pirut/pup error reporting
Status: CLOSED DUPLICATE of bug 249369
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 320071 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 09:26 EDT by Remy Maucherat
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 10:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Error Dialog Box (21.55 KB, image/png)
2007-10-04 11:49 EDT, William Makowski
no flags Details

  None (edit)
Description Remy Maucherat 2007-10-04 09:26:49 EDT
Description of problem:
pirut and pup do not startup correctly on my Fedora 7 installation anymore. When
running them, both appear to do nothing for about two minutes, then display a
"Config error." dialog box, with "Unable to start due to a configuration error."
and Details set to "None", then exit normally. yum works normally.

http://forums.fedoraforum.org/showthread.php?t=168211

Version-Release number of selected component (if applicable):
pirut - 1.3.9-1.fc7.noarch

How reproducible:
Unknown.

Steps to Reproduce:
1. Could not determine what caused the problem.
2.
3.
Comment 1 Remy Maucherat 2007-10-04 10:50:42 EDT
This seems to have been caused by errors like this one (visible using yumex in
particular):
08:41:14 : Failure getting ftp://ftp.uci.edu/mirrors/fedora/li...a/comps-f7.xml:
08:41:14 : --> [Errno -1] Metadata file does not match checksum
08:41:14 : Trying other mirror.

The error reporting in pup/pirut is non existent in this situation.
Comment 2 William Makowski 2007-10-04 11:49:44 EDT
Created attachment 215961 [details]
Error Dialog Box

This problem has also been reported in linuxquestions.org.  The message isn't
much help, but I've attached a png of the dialog box.  Does anyone know if
there is a debug option that could be used when launching pup?
Comment 3 Jeremy Katz 2007-10-05 10:18:14 EDT
As mentioned in comment #1, the comps file in the updates repo was broken
yesterday leading to the problems being seen.  That is bug 318441.

The fact that the error dialog is empty is fixed and will go out in the pending
pirut update, marking as a dupe of that one

*** This bug has been marked as a duplicate of 249369 ***
Comment 4 Jeremy Katz 2007-10-05 10:19:15 EDT
*** Bug 320071 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.