Bug 338061 - big delay before running /sbin/loader on Dell Latitude D610
big delay before running /sbin/loader on Dell Latitude D610
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 344081 371081 372321 (view as bug list)
Depends On:
Blocks: F9AInstallBlocker
  Show dependency treegraph
 
Reported: 2007-10-18 10:45 EDT by cje
Modified: 2008-10-22 20:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 23:41:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cje 2007-10-18 10:45:17 EDT
Description of problem:
anaconda says "running /sbin/loader" and stops for about 3 minutes before
continuing.

Version-Release number of selected component (if applicable):
11.3.0.36

How reproducible:
every time


Additional info:
this is a pxeboot using the onboard nic.
F8T2 stopped for much longer - in fact i never saw it get past this step.
Comment 1 Chris Lumens 2007-10-22 13:50:23 EDT
*** Bug 344081 has been marked as a duplicate of this bug. ***
Comment 2 Igor Bukanov 2007-10-22 14:27:47 EDT
I have got bitten by the samebug on Dell Latitude X1. In my case the installer
just hangs at that step, see bug 344081.
Comment 3 Igor Bukanov 2007-10-30 11:25:57 EDT
Since there is message about detected floppy drives before the installation
hangs (see bug 344081 comment 0) on my floppy-less and cdrom-less Latitude X1
laptop, I would like to prevent floppy detection when booting. Is it possible?
Comment 4 Chuck Ebbert 2007-10-30 12:03:02 EDT
You can add the option "noprobe" to the boot options when starting the install
disk. It will then ask what drivers to load for installation.
Comment 5 Igor Bukanov 2007-10-30 15:20:52 EDT
(In reply to comment #4)
> You can add the option "noprobe" to the boot options when starting the install
> disk. It will then ask what drivers to load for installation.

noprobe has no effect. To be precise, I downloaded the development images from
development/i386/os/images/pxeboot released 2007-10-30 and then edit my GRUB
config file so it reads:

title FC8
        root (hd0,1)
        kernel /boot/fc8-vmlinuz noprobe 
        initrd /boot/fc8-initrd.img

That did not help. The same hang as described in bug 344081 comment 0 happend
with no questions asked with ot without noprobe.

Any other options to try?

Comment 6 Igor Bukanov 2007-10-30 15:23:48 EDT
Is it possible to change the title of the bug so it better reflects the reality
and reads:

Hang when running /sbin/loader on Dell Latitude D610 and Latitude X1
Comment 7 Igor Bukanov 2007-10-30 17:13:18 EDT
It turned out that that development images from
development/i386/os/images/pxeboot released 2007-10-30 caused 3 minutes delay,
not, hang, from showing "running /sbin/loader" message until showing anaconda
prompt. This matches  comment 0. So apparently the delay in the test 2 became
hang in the test 3 and now it is back to the delay state.
Comment 8 Dave Russell 2007-10-31 12:57:21 EDT
While I expect it to be the same code, I've tried booting from img dd'd to a
usb-drive, pxe'ing and using a boot cd...

All options hang at the "running /sbin/loader" step on the Dell Latitude D610

I'm testing using a mirror from rawhide that was made on 2007-10-30

I'll make a new mirror and re-try tomorrow.

Using nofb makes no difference.

Comment 9 Igor Bukanov 2007-11-04 19:00:20 EST
F8 RC3 shows the same 3 minutes delay after showing "running /sbin/loader" on
Dell Latitude X1.
Comment 10 Chuck Ebbert 2007-11-05 15:46:25 EST
Try adding to the kernel boot options:

 floppy.allowed_drive_mask=0
Comment 11 Chuck Ebbert 2007-11-06 19:44:35 EST
Did floppy.allowed_drive_mask=0 work?
Comment 12 Dave Russell 2007-11-07 04:28:33 EST
I've tried that option on F8 and it did indeed work. This is with a D610 with no
floppy or cd-rom, I have an extra battery in the multibay instead.
Comment 13 cje 2007-11-08 05:40:44 EST
i've just tried my pxeboot with floppy.allowed_drive_mask=0 added to the append
line in the tftp server's config.

the delay is reduced from three minutes to around 50 seconds.

on ctrl-altf3 the last line is 'trying to mount CD device scd0 on /mnt/source'
which still seems a bit odd.

this D610 has no floppy but does have an (empty) CD-RW/DVD drive.
Comment 14 cje 2007-11-08 05:56:20 EST
tried the same (F8T3 pxeboot with floppy.allowed_drive_mask=0) on a lenovo Z61m
(CD-RW/DVD and no floppy) and the delay there is about 6 seconds.

i think the "trying to mount CD..." message happens after the delay once the
text-mode part of the installer has loaded some modules etc.
Comment 15 Klaus Möllenhoff 2007-11-08 06:33:39 EST
with f8 from russion mirror it hangs on my dell inspiron 1300 notebook and at a
acer aspire 5650 notebook at "running /sbin/loader" 

even with "floppy.allowed_drive_mask=0" nothing happens. i waited about 15
minutes...

with my old medion 6400 notebook it boots in anaconda after a few seconds and
the media test is ok.
Comment 16 Klaus Möllenhoff 2007-11-08 10:06:52 EST
the sha1sum of my f8 version from yesterday is the same like the one on the
mirrors! so this bug is in final version :-(
Comment 17 Dave Russell 2007-11-08 10:26:03 EST
Indeed, I'd tested the released version on the 04/11/2007, and as you say, the
bug is still present in the final release.
Comment 18 Gianluca Varisco 2007-11-08 11:03:40 EST
*** Bug 371081 has been marked as a duplicate of this bug. ***
Comment 19 cje 2007-11-08 11:23:07 EST
Gianluca and Simon, can you confirm:
1) if this hang lasts longer than 3 minutes
2) if you have floppy and CD drives and
3) what happens if you use the floppy.allowed_drive_mask option
?
Comment 20 Chuck Ebbert 2007-11-08 13:39:26 EST
Also try:
  clocksource=acpi_pm
Comment 21 Mary Ellen Foster 2007-11-09 09:29:20 EST
*** Bug 372321 has been marked as a duplicate of this bug. ***
Comment 22 Mary Ellen Foster 2007-11-09 09:30:00 EST
I just duplicated my bug to this report. I haven't checked whether it's a freeze
or a three-minute delay, but my problem seems to have gone away when I added
"noapic" to the boot command line. The Smolt profile of my laptop is included in
bug 372321
Comment 23 Felix Knittel 2007-11-12 15:57:13 EST
I get the same problem on my MSI Megabook S425.
Tried option "noapic" which did not help. Haven't tried "clocksource=acpi_pm" or
"floppy.allowed_drive_mask=0" yet.

I got around this problem by disabling Intel Speedstep in BIOS Setup which made
the installation continue. But since I haven't done my backup yet, I did not
step any further then the "Install/Update" window (after chosing local keyboard
settings).
Comment 24 mh 2007-12-30 17:07:39 EST
Hello,

trying to install FC8 (boot.iso) on an Asus W5000 notebook. I experienced the 
same issue and appending clocksource=acpi_pm solved the problem. This 
bugtracker helped me out. Thanks!
Comment 25 Dave Russell 2008-02-19 12:17:41 EST
Same problem with rawhide as of 2008-02-19.
Comment 26 Dave Russell 2008-02-19 12:23:53 EST
I should note, that using clocksource=acpi_pm now fixes it.

Previously (F8 timeframe) I needed the floppy.allowed_drive_mask=0 option, this
no-longer works.

Using the noapic option makes no difference, it still hangs at "running
/sbin/loader"
Comment 27 Bug Zapper 2008-05-13 23:26:21 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 28 Dave Russell 2008-10-07 23:41:12 EDT
Well I have to say that I did a fresh F9 install some weeks ago on this same hardware, and didn't hit this problem.

So I guess it's been fixed somewhere along the line, closing the bug... :o)

Note You need to log in before you can comment on or make changes to this bug.