Bug 34472 - The quota command does not display disk usage and limits that is NFS-mounted.
The quota command does not display disk usage and limits that is NFS-mounted.
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
David Lawrence
:
: 22066 46146 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-03 07:35 EDT by Keiichi Mori
Modified: 2007-04-18 12:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 11:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
source patch (3.15 KB, patch)
2001-06-03 21:38 EDT, Keiichi Mori
no flags Details | Diff
spec file patch (364 bytes, patch)
2001-06-03 21:40 EDT, Keiichi Mori
no flags Details | Diff

  None (edit)
Description Keiichi Mori 2001-04-03 07:35:06 EDT
A NFS client mounts a file system that is setted disk quota on NFS Server.
I execute "quota -v" command on the client, but it does not
display that disk usage and limits.
Comment 1 Preston Brown 2001-04-03 12:10:58 EDT
RPC quota support was enabled in quota-3.00-4 and later.
Comment 2 Preston Brown 2001-04-03 12:11:20 EDT
please reopen the bug if you are already using that version.
Comment 3 Keiichi Mori 2001-04-03 21:43:49 EDT
I am using quota-3.00-4, but this problem occurs.
Comment 4 Luca Bonomi 2001-05-02 08:35:04 EDT
I had the same problem with a RH 7.0 nfs server and different client versions.
The server is running quota-2.00pre3-7.
On the server, I changed the line referring to the exported filesystem in
/etc/fstab using /dev/hdc1 insetead of the new form /LABEL=/home and the quota
was reported correctly on the clients.
Comment 5 Keiichi Mori 2001-06-03 21:38:26 EDT
Created attachment 20196 [details]
source patch
Comment 6 Keiichi Mori 2001-06-03 21:40:45 EDT
Created attachment 20197 [details]
spec file patch
Comment 7 Keiichi Mori 2001-06-03 21:44:38 EDT
I created two patches for this problems on quota-3.00-4(please see attachments).
I tested them on RedHat Linux7.1 client and server.

Would you try to test these patches?
Comment 8 Preston Brown 2001-07-02 14:48:04 EDT
*** Bug 46146 has been marked as a duplicate of this bug. ***
Comment 9 Preston Brown 2001-09-05 14:20:56 EDT
fixed in an upcoming 7.1 quota errata.
Comment 10 Need Real Name 2002-05-29 21:56:26 EDT
I believe I've encountered this exact problem even with the available 
patches.  Rather than opening a new bug, is it possible to reopen this one?

Let me first describe my setup:  I run a lab with several alpha machines 
running RedHat 7.1.  Each has several nfs mounts from a FreeBSD box.  The 
quota command reports "none" on each of these machines.  A Tru64 box mounting 
the same nfs volumes reports the correct quotas, so the nfs server is 
correctly functioning.  Perhaps there is an incompatability with nfs on Linux 
and FreeBSD.

I've tried mounting the nfs volumes with every imaginable option(hard, soft, 
udp, tcp, nfsvers=2 & 3, etc...).  To no avail, have tried several kernels, 
quota-tools, and updated the nfs programs on the linux machines.  
Specifically, 2.4.19-pre8 (both smp and non-smp) and the stock RH7.1 2.4.9 
(both smp and non-smp) do not work with the latest redhat patches(quota 
reports "none").  There are no errors, except on 2.4.18-pre8(from kernel.org) 
with quota-tools 3.05, which reports "Error while getting quota from /{IP 
Omitted}:/{nfs mount} for {user}: Connection refused".  In any case, quota-
3.01pre9-0.7.1 does not function on 2.4.9, as it *should*.  I can provide 
strace data if needed, but I do not want to post it on the 'net abroad.

Thanks, Jacob Joseph(jmjoseph@andrew.cmu.edu)
Comment 11 Andreas Metzler 2002-09-23 05:49:26 EDT
I cannot reproduce this with RedHat 7.3 anymore.
Comment 12 Pete Zaitcev 2002-10-08 20:03:58 EDT
*** Bug 22066 has been marked as a duplicate of this bug. ***
Comment 13 Need Real Name 2002-10-14 20:39:38 EDT
Okay, I think everyone needs to reread my post again.  I'm running Redhat 7.1 on
alpha machines, not intel boxes.  Redhat 7.3 is not even available for the alpha
platform, so it surely is not a solution.  Bug 22066 discusses only i686
machines. Would it be possible for anyone to test this on an alpha?  Redhat?

Thanks, Jacob Joseph(jmjoseph@andrew.cmu.edu)
Comment 14 Petri T. Koistinen 2003-05-17 18:16:39 EDT
See also new bug #90939.
Comment 15 Petri T. Koistinen 2004-03-21 08:24:00 EST
Time to close this bug?
Comment 16 Bill Nottingham 2006-08-07 14:28:50 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 17 Bill Nottingham 2006-10-18 11:56:26 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.