Bug 365861 - Firefox 2.0.0.8-2.fc8 crashes with flash-plugin 9.0.48.0 when viewing flash content
Firefox 2.0.0.8-2.fc8 crashes with flash-plugin 9.0.48.0 when viewing flash c...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libflashsupport (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
: youtube-ff-crash 416931 431612 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 11:05 EST by Mark
Modified: 2009-01-09 02:22 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gecko-Fehlerbericht (517.81 KB, text/plain)
2007-11-09 13:07 EST, Martin Jürgens
no flags Details
new backtrace (534.92 KB, text/plain)
2007-11-17 07:44 EST, Martin Jürgens
no flags Details
Gecko Bug Report (691.92 KB, text/plain)
2007-12-02 21:16 EST, John Ruemker
no flags Details
Backtrace (15.99 KB, text/plain)
2007-12-14 07:44 EST, Jan Arne Petersen
no flags Details
Debug Trace from Firefox (6.83 KB, text/plain)
2008-02-16 23:00 EST, Michael Best
no flags Details
Backtrace from firefox (8.65 KB, text/plain)
2008-02-23 22:08 EST, Thomas Quinn
no flags Details

  None (edit)
Description Mark 2007-11-04 11:05:33 EST
Description of problem: Firefox 2.0.0.8-2.fc8 crashed periodicly when viewing
flash content with flash-plugin 9.0.48.0


How reproducible: Open firefox and surf several sites.  Goto youtube.com and
select a video to watch.  Firefox will crash.
Comment 1 Martin Jürgens 2007-11-09 13:07:41 EST
Created attachment 253181 [details]
gecko-Fehlerbericht
Comment 2 Martin Jürgens 2007-11-09 13:08:21 EST
also happens to me. but only sometimes.

seems to be related to pulseaudio and the flash compatibility package
(libflashsupport) to me. debug information attached. I suggest to change
"version" to f8 as it also happens there.
Comment 3 Will Woods 2007-11-09 13:20:36 EST
Do you have the libflashsupport package installed? Are you using pulseaudio? Was
this an upgrade or a fresh install of F8?
Comment 4 Martin Jürgens 2007-11-09 13:26:03 EST
[root@medora-desktop ~]# rpm -qa  | grep libflashsupport
libflashsupport-000-0.1.svn20070904


It was an upgrade F7 -> F8. I installed the Pulse Gstreamer packages and
configured pulseaudio as output and input in gstreamer preferences. I upgraded
from the DVD and selected "Upgrade system".

It feels as it happens more likely when I listen to music parallely.
Comment 5 Martin Jürgens 2007-11-12 05:51:09 EST
My problem was caused by an old flash version. Works fine now with latest one.
Comment 6 Matěj Cepl 2007-11-12 06:38:30 EST
Cool, closing per comment 5.
Comment 7 sean.mcguffee 2007-11-12 19:47:54 EST
I have fedora 8 on an 86_64 whatever the &$#@ that means. Anyway, I guess what
it means is that flashplayer doesn't work even when I install it and it's
installed. It doesn't function, it's in the right directories, (yes I even used
the tar.gz type), and it doesn't get recognized as a plugin by firefox under
tool addons.
Comment 8 Matěj Cepl 2007-11-13 03:57:30 EST
Sean, please do not hijack other bugs. Moreover just brief reading Release Notes
would lead you to
http://docs.fedoraproject.org/release-notes/f8/en_US/sn-Desktop.html#sn-Enabling-Flash-Plugin
which describes exactly what you need to do to install Flash on x86_64 and you
can save displeasure of reading your comment.
Comment 9 Martin Jürgens 2007-11-17 07:44:15 EST
Created attachment 262201 [details]
new backtrace

re-happenes to me. But not that often than using the older Flash version.
Comment 10 John Ruemker 2007-12-02 21:16:38 EST
Created attachment 275201 [details]
Gecko Bug Report

I am seeing the same problem.  I'm using the Flash 9 Update 3 beta plugin from
Adobe Labs (flash-plugin-9.0.64.0-release) and firefox-2.0.0.10-1.fc8.	This
was a fresh install using the DVD.  

Attaching the gecko bug report.
Comment 11 John Ruemker 2007-12-02 22:26:28 EST
I removed pulse audio and haven't seen the problem since. It was easily
reproducible before but I have not been able to cause firefox to crash after an
hour of browsing.  
Comment 12 tengel 2007-12-10 23:36:28 EST
I concur, this bug was closed for the wrong reason (but thanks to the poster
above I'm fixed!) and should probably be reopened and assigned to the pulse
audio team.

I had a scenario on Youtube dialed in where I could boot the laptop, visit a
video, click on another video and cause Firefox to crash. I was able to repeat
this consistently without fail; this same flash-plugin on the same laptop
(Thinkpad T43, uses ALSA) with F7 worked like a champ. I also tried multiple
flash-plugin releases (including the new .115) and it crashed the same way 100%
regardless of plugin version.

For the next person along, simply remove these RPM files, reboot and I bet your
system (flash content) will now work and no longer crash Firefox; I think it's a
bug with pulseaudio.

alsa-plugins-pulseaudio-1.0.14-5.fc8
audacious-plugins-pulseaudio-1.3.5-3.fc8
pulseaudio-0.9.7-0.17.svn20071017.fc8
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-glib2-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-zeroconf-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8
pulseaudio-utils-0.9.7-0.17.svn20071017.fc8
pavucontrol-0.9.5-0.4.svn20070925.fc8.i386
paman-0.9.4-0.1.svn20070816.fc8.i386
libflashsupport-000-0.1.svn20070904.i386
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8.i386
padevchooser-0.9.4-0.3.svn20070925.fc8.i386
paprefs-0.9.6-0.2.svn20070925.fc8.i386
xine-lib-extras-1.1.8-4.fc8.i386

I'm not sure which specific package was causing the problem, but since I have
full ALSA support (I guess - my audio has always worked) I have no need of any
of this pulse audio stuff, I don't even know why it got installed originally or
why I would need it since it didn't exist on F7.

(repeated on Firefox 2.0.0.10 as well, btw)
Comment 13 Will Woods 2007-12-11 00:05:25 EST
There's a lot of reasons that Firefox could crash when viewing flash content - removing pulseaudio won't 
necessarily work for everyone. The most common problem is not having libflashsupport installed. Make 
sure it's installed (and that you've restarted Firefox) before blaming pulseaudio. 

There's a lot of other reasons, but we can't debug most of them because flash is proprietary closed-
source junk. So if you really want to disable pulseaudio, and hope that will fix things, removing alsa-
plugins-pulseaudio will suffice.
Comment 14 tengel 2007-12-11 01:18:33 EST
libflashsupport was installed as per the above list of removed RPMs; it's a
linked dependency from libpulse or whatnot, I don't rightly remember which. In
any case, they're all gone and everything is working the way it should be now.
Comment 15 Martin Jürgens 2007-12-11 05:43:37 EST
I am still running into that problem.. And actually, I want to use PA ;)

What I noticed is this: Sometimes, a flash video does not play sound. It only
makes crrrrccckkcrrr but the video plays. A little bit after, Firefox crashes.

This also happens on my laptop, which I updated to Fedora 8. On a fresh install,
it works fine. It is somewhat weird.
Comment 16 Matěj Cepl 2007-12-11 06:59:54 EST
OK, reopening
Comment 17 Matěj Cepl 2007-12-11 07:01:52 EST
Does the rest of sound works correctly (e.g., totem playing sound file)?
Comment 18 Martin Jürgens 2007-12-11 07:05:53 EST
Yes, and in most cases sound works correctly using Flash, also. But when I play
multiple videos in a row (for example watching some videos on YouTube), then it
crashs at some time. This is flash-plugin 9.0.115.0.
Comment 19 tengel 2007-12-11 12:13:16 EST
Matej - not sure if you're asking Martin or myself so I'll reply as well - all
my sound from other apps seems to work fine, no detected problems - in my case
it was only Flash+Firefox crashing. I do tend to use mplayer for almost
everything instead of totem, but they both work. (as well as several others like
audacious, xine, vlc and so forth). Also the first video played w/sound just
fine, it was only the 2nd video right after it causing the crash.

I had installed the debuginfo and run firefox -g and pulled out a backtrace of
the threads before removing the above RPMs and "fixing" the problem; please let
me know if you'd like it attached (or an lspci -v or lsmod or anything like that
to see my hardware). The backtrace didn't look too interesting fwiw.
Comment 20 Martin Jürgens 2007-12-11 12:20:06 EST
This is my last output:

0x0331aa80 in ?? () from /usr/lib/flash-plugin/libflashplayer.so
Comment 21 Martin Jürgens 2007-12-11 13:28:32 EST
Just had a thought.. I use Adblock Plus. Do you also use it?
Comment 22 Jan Arne Petersen 2007-12-14 07:44:43 EST
Created attachment 289091 [details]
Backtrace
Comment 23 hillct 2008-01-12 19:54:11 EST
After a fresh install of FC8 on a Dell C400, I had no audio output from flash,
added libflashsupport, got audio but started to experience frequent, almost
constant crashes when switching to a second flash video, or playing a flash
video using an already loaded player (where the video did not auto-start.

I then removed alsa-plugins-pulseaudio as per comment 13, leaving the others
(from comment 12) in place, including libflashsupport, and haven't had any
flash/firefox crashes in the intervening 4 hours of watching and switching
between flash video.

On this basis O'd have to say the issue is closely associated with the glue
between flash player and pulseaudio. This testing was done with all the most
current RPMs as of this writing:

Firefox 2.0.10
flash-plugin-9.0.115.0-release
libflashsupport-000-0.1.svn20070904
alsa-plugins-pulseaudio  1.0.14-5.fc8
Comment 24 Warren Togami 2008-01-12 23:17:44 EST
Or in pulseaudio itself, as pulseaudio is the cause of crashes in all sorts of
other applications from pidgin, mplayer, xine, etc.
Comment 25 Matěj Cepl 2008-02-05 04:45:49 EST
*** Bug 407051 has been marked as a duplicate of this bug. ***
Comment 26 Michael Best 2008-02-12 03:59:51 EST
Is there no fix for this bug in over three months.  It happens to all adobe
flash (official) playing users using pulseaudio.  

This bug really makes me mad, is there no workaround, like using a newer version
of libflashsupport or something?
Comment 27 Michael Best 2008-02-12 04:15:27 EST
My reading comprehension is a bit low. As per comment #23 I removed
alsa-plugins-pulseaudio but had to remove kde-settings-pulseaudio as well.

I noticed that Linus also reported this bug.
Comment 28 Matěj Cepl 2008-02-12 17:16:28 EST
(In reply to comment #26)
> Is there no fix for this bug in over three months.  It happens to all adobe
> flash (official) playing users using pulseaudio.  
> 
> This bug really makes me mad, is there no workaround, like using a newer version
> of libflashsupport or something?

The problem is that for many people (like me) this works. See my packages (all
from F8 or the official Adobe repository):

flash-plugin-9.0.115.0-release
libflashsupport-000-0.1.svn20070904
firefox-2.0.0.10-3.fc8
pulseaudio-0.9.8-5.fc8
Comment 29 Michael Best 2008-02-14 00:26:07 EST
If found it's a bit more stable after removing those two rpms, but it still
crashes on me.

$ echo "%_query_all_fmt %%{name}-%%{version}-%%{release}.%%{arch}" > ~/.rpmmacros$
$ rpm -qa | grep -iE  "flash|firefox|pulseaudio"
pulseaudio-module-x11-0.9.8-5.fc8.i386
pulseaudio-libs-0.9.8-5.fc8.i386
firefox-2.0.0.10-3.fc8.i386
pulseaudio-0.9.8-5.fc8.i386
akode-pulseaudio-2.0.1-9.fc8.i386
libflashsupport-000-0.1.svn20070904.i386
pulseaudio-libs-zeroconf-0.9.8-5.fc8.i386
flash-plugin-9.0.115.0-release.i386
pulseaudio-core-libs-0.9.8-5.fc8.i386
pulseaudio-libs-glib2-0.9.8-5.fc8.i386
pulseaudio-utils-0.9.8-5.fc8.i386
Comment 30 Matěj Cepl 2008-02-14 04:46:11 EST
Comment on attachment 289091 [details]
Backtrace

no -debuginfo
Comment 31 Matěj Cepl 2008-02-14 04:52:46 EST
OK, let's try it once more. Whoever is affected by this, let me know, what kind
of system you have (x86_64, ppc*, i386) and run 

rpm -qa --qf "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" \*flash\* firefox\*
\*pulseaudio\*

Then, please, install firefox-debuginfo; in order to do this you have to enable
-debuginfo repository.

	yum install --enablerepo=\*debuginfo firefox\*debuginfo pulseaudio\*debuginfo
\*flash\*debuginfo

Then run firefox with a parameter -g. That will start firefox running inside of
gdb debugger. Then use command run and do whatever you did to make firefox
crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text
editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 32 Sam L. 2008-02-16 05:39:01 EST
I was having the same troubles with SeaMonkey and Firefox crashing on a
consistent basis with any Flash content, but I found by upgrading
libflashsupport to the latest version seems to have resolved this issue.
See http://www.pulseaudio.org/wiki/FlashPlayer9Solution for more information.

The only item that I had to change from the documentation was:
PKG_CHECK_MODULES(PULSE, [ libpulse >= 0.9.7 ]) changed to 
PKG_CHECK_MODULES(PULSE, [ libpulse >= 0.9.5 ]) due to the PulseAudio version
installed on Fedora Core 8.
Comment 33 Matěj Cepl 2008-02-16 13:48:38 EST
*** Bug 416931 has been marked as a duplicate of this bug. ***
Comment 34 Michael Best 2008-02-16 23:00:24 EST
Created attachment 295084 [details]
Debug Trace from Firefox

As requested, I also tried compiling the latest libflashsupport without luck,
it was more stable but would eventually lock at 100% cpu requiring firefox to
be killed, so not much better in that regard.
Comment 35 Martin Stransky 2008-02-20 06:03:26 EST
*** Bug 431612 has been marked as a duplicate of this bug. ***
Comment 36 Thomas Quinn 2008-02-23 22:08:20 EST
Created attachment 295726 [details]
Backtrace from firefox

Here is a backtrace with debug info.  Package info is also attached.  This is
easy to reproduce by viewing Youtube videos.
Comment 37 Filip Miletic 2008-03-04 19:27:29 EST
(In reply to comment #32)
> consistent basis with any Flash content, but I found by upgrading
> libflashsupport to the latest version seems to have resolved this issue.
> See http://www.pulseaudio.org/wiki/FlashPlayer9Solution for more information.

Tried the instructions on the other end of the URL, but for me it did not work.
Comment 38 Ian 2008-03-11 08:07:35 EDT
I've been troubled by this bug for ages.  Come some fellow sufferers try this:

Edit /etc/X11/xorg.conf and add these lines at the end:

Section "Extensions"
        Option  "Composite" "Disable"
EndSection

Restart the X-server (CTRL-ALT-BACKSPACE)

After doing this I have been able to view youtube content for 30 mins without
a crash, whereas before it would crash on the first or second video.
Comment 39 Filip Miletic 2008-03-11 09:44:24 EDT
For what it's worth, I observed the following:  as long as you do not close any
pages that embed Flash, the Firefox+Flash Player combo will not crash.  

I.e. if you manage to do a 'open in new tab' or 'open in new window' for each
new video you want to watch, FF will not crash for an extended period of time. 
I tried this, and as long as I upheld the recipe, FF did not crash.

As soon as you close any of the Flash-enabled pages, you are eligible for a
crash.  This makes watching e.g. youtube rather tedious, as the interface there
tends to replace the old video with a new one upon almost any action.
Comment 40 Clodoaldo Pinto Neto 2008-03-11 19:13:52 EDT
(In reply to comment #38)
> Edit /etc/X11/xorg.conf and add these lines at the end:
> 
> Section "Extensions"
>         Option  "Composite" "Disable"
> EndSection

Didn't work for me
Comment 41 Ian 2008-03-13 07:20:03 EDT
Just loaded F8 on another identical machine and the problem was slightly
different - youtube made firefox hang.  The xorg.conf fudge did not fix it.
However, removing flash-plugin-9.0.48.0-release fixed it.

( I had previously removed kde-settings-pulseaudio, pulseaudio-module-x11
andalsa-plugins-pulseaudio )

Audio still functions correctly
Comment 42 Dan O'Brien 2008-06-30 09:14:31 EDT
install nspluginwrapper and ff will stop crashing.  flash may go grey from time
to time, just reload the page.
Comment 43 Michael Best 2008-06-30 10:10:23 EDT
Is there additional configuration required to use that?  I found no difference
with just 

yum install nspluginwrapper

I have been using Flashblock which has had a similar function to the one you
describe.
Comment 44 Michael Best 2008-10-16 01:20:45 EDT
Although I'm now in F9, flash-plugin-10.0.12.36-release.i386 just came out, and I am not having problems with it.
Comment 45 Bug Zapper 2008-11-26 03:11:31 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 46 Bug Zapper 2009-01-09 02:22:30 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.