Bug 407051 - (youtube-ff-crash) Gecko Crashes Firefox
Gecko Crashes Firefox
Status: CLOSED DUPLICATE of bug 365861
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: 379271 426860 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-11-30 19:12 EST by Brad Longo
Modified: 2008-02-05 04:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-05 04:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Bug Report (3.79 KB, text/plain)
2007-11-30 19:12 EST, Brad Longo
no flags Details
gecko-bugreport (523.10 KB, text/plain)
2008-01-01 19:39 EST, Jonas Nyman
no flags Details
gdb output as commented (25.24 KB, text/plain)
2008-01-16 14:48 EST, Patrick Monnerat
no flags Details
from bug buddy (556.92 KB, text/plain)
2008-01-16 23:06 EST, kincaid
no flags Details

  None (edit)
Description Brad Longo 2007-11-30 19:12:17 EST
Description of problem:
Firefox crashes randomly when I try to watch videos online, and gives me a
prompt to send a bug report dealing with something called gecko.  All the videos
are of the same type, and if I reload Firefox I can play the videos that caused
it to crash.     

Version-Release number of selected component (if applicable):
I couldn't find anything called gecko on my computer, but I did find gecko-sharp2...
Name   : gecko-sharp2
Arch   : i386
Version: 0.12
Release: 5.fc8

How reproducible:
Randomly whenever I click a video to watch.  I did not recognize any pattern.   

Steps to Reproduce:
1. Go to collegehumor.com.  Click a random video and see what happens.  
2. Keep clicking more until it decides to crash
Actual results:
Firefox crashes

Expected results:
It shouldn't.

Additional info:
I attached the bug report.
Comment 1 Brad Longo 2007-11-30 19:12:17 EST
Created attachment 274571 [details]
Bug Report
Comment 2 Christopher Aillon 2007-12-03 11:04:50 EST
Does installing libflashsupport help?
Comment 3 Brad Longo 2007-12-17 12:19:34 EST
Is libflashsupport provided by adobe?  I have adobe flash player, and last time
I downloaded something in the repos that did the same thing they conflicted with
each other.  I have recently been getting other error messages from ndiswrapper
so I just removed it because I don't really need it.  It seems firefox is just a
mess.  After I did that I got an error message from gecko again so its still there.
Comment 4 Matěj Cepl 2007-12-19 07:05:22 EST
(In reply to comment #3)
> Is libflashsupport provided by adobe?

[matej@hubmaier ~]$ sudo yum list libflashsupport
Sorry, try again.
Loading "changelog" plugin
Loading "versionlock" plugin
Loading "downloadonly" plugin
Loading "basearchonly" plugin
Loading "protectbase" plugin
Loading "allowdowngrade" plugin
Loading "security" plugin
Loading "skip-broken" plugin
Loading "priorities" plugin
Excluding Packages in global exclude list
Reading version lock configuration
0 packages excluded due to repository protections
0 packages excluded due to repository priority protections
Installed Packages
libflashsupport.i386                     000-0.2.svn20070904    installed       
libflashsupport.x86_64                   000-0.2.svn20070904    installed       
[matej@hubmaier ~]$ 

No, it is in Fedora.
Comment 5 Dmitry Burstein 2007-12-22 10:58:49 EST
I have the same problem and I have a feeling its pulseaudio-related too: the
crash only happens on audio-enables flash items (not every time, but ONLY on
audio, and NEVER on one without a sound track). It never happened in F7 - before
I have the same version of libflashsupport, and version of
flash-plugin, taken from adobe repository. I did try to run a git version of
libflashsupport from pulseaudio's site (locally compiled), but the crashes
Comment 6 Jonas Nyman 2008-01-01 19:10:49 EST
I am experiencing the same thing. Firefox often crashes when I try to view
videos on YouTube. I get the gecko-crash bug-reporting-tool-thing... However, I
believe I have found a pattern.  
Firefox/gecko crashes if I scroll down on the page simultaneously as the video
is loading. If I only click on the video to play it and letting it load, not
changing window size or scrolling, it does not crash.
I do not know if this is significant, but it is something I think I have observed. 

Further... If I restart Firefox and choose "Restore last session", and view the
same video, it will not crash! 


Comment 7 Jonas Nyman 2008-01-01 19:39:20 EST
Created attachment 290628 [details]

The bugreport created by gecko bug reporting tool.
Comment 8 Jonas Nyman 2008-01-01 19:54:33 EST
Duplicate of 426860 and more... 
Comment 9 Matěj Cepl 2008-01-02 08:09:23 EST
*** Bug 426860 has been marked as a duplicate of this bug. ***
Comment 10 Matěj Cepl 2008-01-02 08:09:56 EST
*** Bug 379271 has been marked as a duplicate of this bug. ***
Comment 11 Patrick Monnerat 2008-01-16 14:48:48 EST
Created attachment 291879 [details]
gdb output as commented

Same problem here. As additional info, I attach the gdb output after
installation of firefox-debuginfo.
My packages are:
flash-plugin- from Adobe
Comment 12 kincaid 2008-01-16 23:06:13 EST
Created attachment 291951 [details]
from bug buddy
Comment 13 Christopher Aillon 2008-01-22 16:15:27 EST
Possibly one of the nspluginwrapper bugs.  Also, I see google toolbar which
could be causing it.  Sending to nspluginwrapper for now.
Comment 14 Dmitry Burstein 2008-01-22 16:56:30 EST
Not in my case: I'm running 32-bit - no nspluginwrapper.
Comment 15 Jonas Nyman 2008-01-23 17:33:23 EST
Same here, i686, no nspluginwrapper installed.
And I don't have google toolbar. 
Comment 16 vaughn miller 2008-01-24 20:48:47 EST
I had same problem and submitted a similar bug report. I tried every suggestion
I could find. What worked was to remove firefox rpm and then yum install
firefox. It has not missed a frame since..I am on firefox on FC8 32bit.
Comment 17 Dmitry Burstein 2008-01-27 17:49:05 EST
Unfortunately, in my case even after
"rpm -e --nodeps firefox && yum -y install firefox"
it is still unstable in the same way :-(
Comment 18 Jonas Nyman 2008-01-31 17:30:08 EST
Duplicate of 429657 and 397641 too..?

I had gnash and gnash-plugin installed. With those installed, I did no longer
get the firefox-gecko-crash. However, I could never see any movie with gnash. 

I removed gnash and re-installed adobe's 

Now I can see movies but often get the gecko crash. 

Comment 19 Matěj Cepl 2008-01-31 17:49:52 EST
(In reply to comment #18)
> I had gnash and gnash-plugin installed. With those installed, I did no longer
> get the firefox-gecko-crash. However, I could never see any movie with gnash. 
> I removed gnash and re-installed adobe's 
> flash-plugin- 
> Now I can see movies but often get the gecko crash. 

Try swfdec\* from the development repository (yum --enablerepo=development
install swfdec\*). You will need all gstreamer packages, even those which are
not available in the official Fedora repository.
Comment 20 Jonas Nyman 2008-02-01 08:11:51 EST
duplicate of 365861?

It seems this and similar or somehow related bugs are reported in so many bug
reports. Would it be possible to close all but one and copy all info from the
different bugs into that single one? 

Why is nspluginwrapper the Component of this bug? 
Why is the priority of this bug low, when very similar bugs have high prio?
Shouldn't the priority be higher when we can assume _a lot_ of people are
experiencing the bug?
Comment 21 Matěj Cepl 2008-02-05 04:45:47 EST
(In reply to comment #20)
> duplicate of 365861?

Well, yes, I was trying to keep them separate until we know what's going on, but
I will fold them now into one.

*** This bug has been marked as a duplicate of 365861 ***

Note You need to log in before you can comment on or make changes to this bug.