Bug 36601 - [aix7xxx] installer crashes and wont let manually assign h/w drivers
[aix7xxx] installer crashes and wont let manually assign h/w drivers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
: 36078 44834 44925 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 21:32 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 20:27:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-18 21:32:41 EDT
I am trying to install RH7.1 from CD created from your ISO image.

On SMP PC (2 x Pentium III 700Mhz) with AHA2940UW, after reading aic7xxx driver, installation process displays:
  Running anaconda - please wait
  install exited abnormally - received signal 11
  
On Pentium 166Mhz with AHA1542CF, install detects IDE drives, but will not detect SCSI controller.
I haven't seen any error messages.

I have tried driver disk, expert and text mode. In both cases it doesn't change nothing.
I tried also to load driver on LILO prompt, using "linux aha1542=0x330" parameter. No go.
It looks like install doesn't enable expert mode at all. After asking for driver disk it does not show or ask for devices,
but goes on with installation without SCSI controller.

Both of those computers are happily running RH6.2.

Regards.
Zeb
Comment 1 Brent Fox 2001-04-19 12:45:18 EDT
We've gotten a couple of these...looks like some thing is wrong with the aic7xxx
driver.  However, I've seen stuff on the mailing list from quite few users who
say that theirs work fine.  Anyway, this is more of a kernel problem than an
installer problem.  Reassigning.
Comment 2 Brent Fox 2001-04-19 12:45:41 EDT
*** Bug 36078 has been marked as a duplicate of this bug. ***
Comment 3 Arjan van de Ven 2001-04-19 16:33:37 EDT
you should be able to pass "noprobe" to the bootscreen commandline to force
manual selection of the drivers
Comment 4 Need Real Name 2001-04-22 19:12:23 EDT
Thanks. "noprobe" fixed the problem with aha1542.
System still reports error, when loading aic7xxx.
Comment 5 Brent Fox 2001-06-19 12:21:18 EDT
*** Bug 44834 has been marked as a duplicate of this bug. ***
Comment 6 Brent Fox 2001-06-26 21:50:28 EDT
*** Bug 44925 has been marked as a duplicate of this bug. ***
Comment 7 boomerang_56 2003-01-23 13:08:05 EST
What motherboards/chipsets are having the issue? 

On my system everything from RedHat 7.2 onward had problems during install. 

I root-caused the issue to a BIOS setting on my ASUS CUV4X-D motherboard (VIA 
chipset). This board was set for PCI write combining which makes PCI access 
seem very fast - the problem is it also violates the PCI spec. 

When I disabled PCI write combining, that resolved the installation issue.
Comment 8 boomerang_56 2003-01-23 13:13:02 EST
Forgot to mention that I have had problem with the following Adaptec cards and 
the "new" AIC7XXX driver :2902, 2940Uw, 29160.

If I compiled new kernels and used the "new" driver I would get kernel panics 
on boot on Red Hat 7.2, and had problems installing RedHat 7.3 onward because 
the default driver on install is the "new" one.

Again, disabling PCI Write combining in BIOS fixed the problem. 

RH8 rocks, as does Phoebe. Looking forward to 8.1. :->

Note You need to log in before you can comment on or make changes to this bug.