Bug 405131 - awesfx compile problem (on alpha only!?)
awesfx compile problem (on alpha only!?)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
: 400681 434449 (view as bug list)
Depends On:
Blocks: gcc43rebuildfail
  Show dependency treegraph
 
Reported: 2007-11-29 16:31 EST by Oliver Falk
Modified: 2014-03-16 23:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 10:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-11-29 16:31:00 EST
Not quite sure how it looks like in F8 x86 or Rawhide x86, but in F8 alpha:
../include/awe_parm.h:25:29: error: linux/awe_voice.h: No such file or directory
In file included from awe_parm.c:25:
../include/awe_parm.h:30: error: expected ')' before '*' token
../include/awe_parm.h:31: error: expected ')' before '*' token
awe_parm.c:109: error: expected ')' before '*' token
awe_parm.c:142: error: expected ')' before '*' token
make[2]: *** [awe_parm.o] Error 1
make[2]: Leaving directory `/home/oliver/cvs/F-8/awesfx/awesfx-0.5.0d/awelib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/oliver/cvs/F-8/awesfx/awesfx-0.5.0d'
error: Bad exit status from /var/tmp/rpm-tmp.3350 (%build)


Any hint is appreciated!
Comment 1 Oliver Falk 2007-12-03 03:43:05 EST
*** Bug 400681 has been marked as a duplicate of this bug. ***
Comment 2 Oliver Falk 2007-12-03 03:43:38 EST
Grr. Opened two bz's for the same issue :-(
Comment 3 Martin Stransky 2007-12-03 03:45:58 EST
There are missing header linux/awe_voice.h. I wonder what happened...
Comment 4 Oliver Falk 2007-12-03 03:56:54 EST
That you need to ask kernel guys I guess :-)
Comment 5 Martin Stransky 2007-12-07 05:56:18 EST
It looks like a part of glibc-kernheaders. Reassigning.
Comment 6 David Woodhouse 2007-12-07 07:26:16 EST
∄ glibc-kernheaders.
∄ <linux/awe_voice.h>

The header was removed from the kernel on May 8th this year, because it was
apparently unused. If it was unused, that suggests that there was no kernel
support for whatever awesfx is trying to do anyway. Reassigning to awesfx, which
is presumed broken -- and won't compile on other architectures either.

Hm, awesfx also seems to exclude PowerPC, without being listed on the
FE-ExcludeArch-ppc tracker bug. Bad maintainer; no biscuit.
Comment 7 Oliver Falk 2007-12-08 18:22:22 EST
well. so awesfx -> dead.package? For me it's ok... :-)
Comment 8 Martin Stransky 2008-02-25 09:49:19 EST
*** Bug 434449 has been marked as a duplicate of this bug. ***
Comment 9 Martin Stransky 2008-04-09 14:54:36 EDT
I think we can remove the awesfx package from distro. It's quite obsolete now...
Comment 10 Jesse Keating 2008-04-10 10:48:04 EDT
(In reply to comment #9)
> I think we can remove the awesfx package from distro. It's quite obsolete now...

I blocked it.  Please follow the other parts of
http://fedoraproject.org/wiki/PackageMaintainers/PackageEndOfLife
Comment 11 Paul "KK4DUY" Bransford 2008-12-22 16:53:47 EST
This package is not obsolete, it is the only software available for Linux (that I am aware of, and I've been using these cards for years) capable of uploading soundfonts to the MIDI component of these cards.

All emu10k cards (Live!, Audigy, Audigy 2, etc) require this software to have midi support.
Comment 12 Tim Nelson 2009-01-19 23:20:43 EST
I agree it's still needed, and its easy to fix.  See https://bugzilla.redhat.com/show_bug.cgi?id=470642
Comment 13 Oliver Falk 2009-01-20 08:36:04 EST
Well. The new bugreport says everything. Let's Review it and it's included again.

If you mind: It compiles fine on Alpha architecture! :-)

Note You need to log in before you can comment on or make changes to this bug.