Bug 413271 - F8 install crash after media check with "loader received SIGSEGV!"
F8 install crash after media check with "loader received SIGSEGV!"
Status: CLOSED DUPLICATE of bug 374311
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-05 20:04 EST by Bryan Taylor
Modified: 2007-12-07 12:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-07 12:46:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bryan Taylor 2007-12-05 20:04:19 EST
Description of problem:
Installation of Fedora 8 crashes with "loader received SIGSEGV!" immediately
after the media check.

Version-Release number of selected component (if applicable):
Fedora 8. Works with Fedora 8 Test 3.

How reproducible:
Every time on affected hardware. My hardware is a new HP laptop.

Steps to Reproduce:
1. Launch installer with known good media
2. Select default/standard options
3. Skip media check
Actual results:
Crashes, allowing reboot with "loader received SIGSEGV!"  

Expected results:
Continues with install, launching X Windows.

Additional info:

Work around by installing from Fedora 8 Test 3 and then upgrading. This seems
significant because the problem was introduced between F8T3 and F8. However,
since the crash is a complete install show stopper, I propose "high" severity. A
coworkers with similar hardware (new HP laptop) had the same experience, but
didn't save the backtrace. 

This problem is similar to Bug 385281, Bug 375171, Bug 352861 with the same
loader SIGSEGV message at the same point of the install. These may or may not be
duplicates as the backtrace is quite different.

Here's the backtrace and last output from the virtual terminals:
loader received SIGSEGV!  Backtrace:

21:18:42 INFO    :  Loading SELInux policy
21:18:43 INFO    :  getting ready to spawn shell now
21:18:43 INFO    :  modules to insert ide-cd
21:18:43 INFO    :  load module set done
21:18:43 INFO    :  modules to insert
21:18:43 INFO    :  load module set done
21:18:43 INFO    :  modules to insert
21:18:43 INFO    :  load module set done

<7>SELinux:  initialized (dev sysfs, type sysfs), uses genfs_contexts
<5>audit(1196889523.415:2) policy loaded auid=4294967295
Comment 1 Jeremy Katz 2007-12-05 22:05:57 EST
Does booting with 'linux nopcmcia' help?
Comment 2 Bryan Taylor 2007-12-06 00:04:08 EST
It worked. At the Welcome to Fedora 8 screen, I hit tab and entered:
> vmlinux initrd=initrd.img nopcmcia
when it got to the media test, I skipped it and unlike before it came back with
Running anaconda... and then X started.

Care to illuminate me on how you knew/guessed this would work? Is there
somewhere to read up on how to use the backtrace?

Comment 3 Chris Lumens 2007-12-07 12:46:29 EST

*** This bug has been marked as a duplicate of 374311 ***

Note You need to log in before you can comment on or make changes to this bug.