Bug 426624 - installer fails to initialize eth0 for NFS install
installer fails to initialize eth0 for NFS install
Status: CLOSED DUPLICATE of bug 378641
Product: Fedora
Classification: Fedora
Component: libdhcp (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: 427106 427193 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-12-23 02:49 EST by G.Wolfe Woodbury
Modified: 2008-01-03 23:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-03 23:18:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2007-12-23 02:49:42 EST
Description of problem:
  installer (prior to loading anaconda proper) fails to initialize eth0

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:
  install goes through all the motions required then fails to initialize the
eth0 interface.  Main screen fails to provide any details or traceback. 
Examination of vt3 shows:

INFO   : result of pumpSetupInterface is pumpSetupInterface failed: set link -
1: operation not permitted

prior to this it notes that eth0 is only interface and that eth0 is not a
wireless interface.  There seem to be no other relevant notices by the installer
on other screens.

Expected results:
  normal install sequence

Additional info:
  machine hw-uuid: 4cf6a0ba-2941-4235-87a9-b2a55d827302
Comment 1 G.Wolfe Woodbury 2007-12-23 03:00:55 EST
the fault is reliably reproduceable on three attempts.  I tried (#2) after a
reboot, and #3 with "noipv6" on kernel line. Also (just trying) enforcing=0
makes no difference.
Comment 2 Jeremy Katz 2007-12-26 14:13:29 EST
Can you try and see if it works if you boot with 'linux ksdevice=eth0 ip=dhcp'
(or whichever net method you want to use)?  Although I'm going to try to see if
I can get it to happen as soon as I can get a tree synced
Comment 3 G.Wolfe Woodbury 2007-12-26 14:26:40 EST
That didn't work.  It still complains about "operation not permitted" on window
vt03 as reported above.
Comment 4 Jeremy Katz 2007-12-26 14:43:27 EST
Reproduced; looks like a problem in libdhcp
Comment 5 Jeremy Katz 2008-01-02 09:27:35 EST
*** Bug 427193 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2008-01-02 09:27:41 EST
*** Bug 427106 has been marked as a duplicate of this bug. ***
Comment 7 David Cantrell 2008-01-03 23:18:19 EST

*** This bug has been marked as a duplicate of 378641 ***

Note You need to log in before you can comment on or make changes to this bug.