Bug 42732 - named.conf manpage is missing.
named.conf manpage is missing.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
: 47042 51766 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-29 14:47 EDT by Gerald Britton
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-31 11:15:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Britton 2001-05-29 14:47:38 EDT
Description of Problem:
The manpage existed under 6.2, but is missing from the 7.1 package.

How Reproducible:
N/A.

Steps to Reproduce:
1. N/A.
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Bernhard Rosenkraenzer 2001-05-31 03:53:32 EDT
That's because bind 9.x doesn't come with a named.conf man page. The one from 
bind 8.x is outdated.
Comment 2 Bernhard Rosenkraenzer 2001-05-31 04:03:11 EDT
I've added the named.conf man page from bind 8.x to the bind-9.1.3-0.rc1.2 
package; it doesn't have all options, but the information it has is still 
correct, so it's better than nothing.
Comment 3 Daniel Roesen 2001-05-31 11:15:14 EDT
This is incorrect. The source tarball does contain the named.conf manpage.
Actually my private BIND RPM has only the following manpages in
bind-manpages.tar.bz2:

./man5/resolver.5.gz
./man5/resolv.conf.5.gz -> resolver.5.gz
./man8/nslookup.8.gz

Any I filed a bug on glibc as it is glibc which should contain the
resolver/resolv.conf manpages, because the resolved lib used in glibc is not
necessarily the one shipped with the installed BIND.
Comment 4 Bernhard Rosenkraenzer 2001-06-01 11:41:34 EDT
The source tarball does not contain the named.conf manpage.

[root@bero bind-9.1.3rc1]# find . -name "named.conf*"
./bin/tests/named.conf
./bin/tests/system/dialup/ns1/named.conf
./bin/tests/system/dialup/ns2/named.conf
./bin/tests/system/dialup/ns3/named.conf
./bin/tests/system/dnssec/ns1/named.conf
./bin/tests/system/dnssec/ns2/named.conf
./bin/tests/system/dnssec/ns3/named.conf
./bin/tests/system/dnssec/ns4/named.conf
./bin/tests/system/dnssec/ns5/named.conf
./bin/tests/system/forward/ns1/named.conf
./bin/tests/system/forward/ns2/named.conf
./bin/tests/system/forward/ns3/named.conf
./bin/tests/system/forward/ns4/named.conf
./bin/tests/system/glue/ns1/named.conf
./bin/tests/system/limits/ns1/named.conf
./bin/tests/system/lwresd/ns1/named.conf
./bin/tests/system/notify/ns1/named.conf
./bin/tests/system/notify/ns2/named.conf
./bin/tests/system/notify/ns3/named.conf
./bin/tests/system/nsupdate/ns1/named.conf
./bin/tests/system/nsupdate/ns2/named.conf
./bin/tests/system/resolver/ns1/named.conf
./bin/tests/system/sortlist/ns1/named.conf
./bin/tests/system/stress/ns1/named.conf
./bin/tests/system/stress/ns2/named.conf
./bin/tests/system/stress/ns3/named.conf
./bin/tests/system/stress/ns4/named.conf
./bin/tests/system/stub/ns1/named.conf
./bin/tests/system/stub/ns2/named.conf
./bin/tests/system/stub/ns3/named.conf
./bin/tests/system/unknown/ns1/named.conf
./bin/tests/system/upforwd/ns1/named.conf
./bin/tests/system/upforwd/ns2/named.conf
./bin/tests/system/upforwd/ns3/named.conf
./bin/tests/system/views/ns1/named.conf
./bin/tests/system/xfer/ns1/named.conf
./bin/tests/system/xfer/ns2/named.conf
./bin/tests/system/xfer/ns3/named.conf
./bin/tests/system/xferquota/ns1/named.conf
./bin/tests/system/xferquota/ns2/named.conf
[root@bero bind-9.1.3rc1]# ls doc/man/bin
dig.1   lwresd.8  named-checkconf.1  nsupdate.8  rndc.conf.5
host.1  named.8   named-checkzone.1  rndc.8


Maybe you found a patched tarball somewhere?!

Comment 5 jonathan 2001-06-03 22:57:34 EDT
The bind SRPM provided with RH 7.1 contains the source file 

  bind-manpages.tar.bz2

as the bug submitter mentioned.  That file contains the missing man page.

Worse yet, the spec file carefully installs the relevant extra man pages into
the buildroot correctly.  It just fails to list them in its %files section!

I am saddened that Red Hat would close this as "NOT A BUG", when it very 
obviously is a bug, one which a trivial spec file patch will fix.

I trust that dkl, the QA contact, will take whatever steps are needed to ensure
that this sort of too-rapid "NOT A BUG" classification does not happen in future.

The patch is:

--- SPECS.orig/bind.spec  Thu Mar 15 07:41:58 2001
+++ SPECS/bind.spec   Sun Jun  3 18:09:37 2001
@@ -154,10 +154,9 @@
 /usr/sbin/rndc
 /usr/sbin/dns-keygen
 
-%{_mandir}/man5/rndc.conf.5*
-%{_mandir}/man8/rndc.8*
-%{_mandir}/man8/named.8*
-%{_mandir}/man8/lwresd.8*
+%{_mandir}/man1/*.1*
+%{_mandir}/man5/*.5*
+%{_mandir}/man8/*.8*
 
 %attr(-,named,named) %dir /var/named
 %attr(-,named,named) %dir /var/run/named

Incidentally, this SRPM seems to me to require libtool and openssl-devel RPMs
in order to build, so those should probably be added to a BuildPreReq: tag in
the spec file, too.





Comment 6 jonathan 2001-06-03 23:11:05 EDT
Testing shows it is safer to just add a one line patch to include the single
man page concerned (avoids conflicts with the bind-utils RPM):

--- SPECS.orig/bind.spec      Thu Mar 15 07:41:58 2001
+++ SPECS/bind.spec   Sun Jun  3 19:12:50 2001
@@ -157,2 +157,3 @@
 %{_mandir}/man5/rndc.conf.5*
+%{_mandir}/man5/named.conf.5*
 %{_mandir}/man8/rndc.8*
Comment 7 Bernhard Rosenkraenzer 2001-07-03 12:05:10 EDT
*** Bug 47042 has been marked as a duplicate of this bug. ***
Comment 8 Bernhard Rosenkraenzer 2001-08-14 17:22:43 EDT
*** Bug 51766 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.