Bug 432267 - rt2500pci kernel panics when interface activated
rt2500pci kernel panics when interface activated
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Reopened
: 433201 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2008-02-10 13:55 EST by Vaclav "sHINOBI" Misek
Modified: 2008-04-03 18:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-03 18:00:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
2 listed bugs from /var/log/message (88.15 KB, text/plain)
2008-02-10 13:57 EST, Vaclav "sHINOBI" Misek
no flags Details
/var/log/messages calltrace (32.03 KB, text/plain)
2008-03-07 13:49 EST, Vaclav "sHINOBI" Misek
no flags Details
/var/log/messages (6.50 KB, text/plain)
2008-04-01 17:23 EDT, Vaclav "sHINOBI" Misek
no flags Details

  None (edit)
Description Vaclav "sHINOBI" Misek 2008-02-10 13:55:58 EST
Description of problem:
When wlan0 is started (doesn't matter if through NetworkManager or ifconfig
wlan0 up), the kernel panics.

Version-Release number of selected component (if applicable):
kernel-2.6.24-23.fc9.x86_64 and newer

How reproducible:

Steps to Reproduce:
1. boot system
2. kernel panic when wlan0 interface activated
Actual results:

Expected results:
no panic :-).

Additional info:
lspci -v and lsmod are included in bug #432266
Comment 1 Vaclav "sHINOBI" Misek 2008-02-10 13:57:53 EST
Created attachment 294504 [details]
2 listed bugs from /var/log/message
Comment 2 Ivo van Doorn 2008-02-11 10:42:53 EST
stack trace does not imply rt2x00 to be the cause, but I have a suspicious 
feeling that this trace was made with rt2x00 2.1.0.

What is the result of "modinfo rt2x00lib"

Version 2.1.0 is known to be broken and causes memory corruption. 2.1.1 fixes 
most of those issues but will not bring RX/TX activity back to any of the 
rt2x00 drivers yet.
Comment 3 Vaclav "sHINOBI" Misek 2008-02-11 14:14:28 EST
#modinfo rt2x00lib
license:        GPL
description:    rt2x00 library
version:        2.0.14
author:         http://rt2x00.serialmonkey.com
srcversion:     96EDA04F07CF1E49EA178D4
depends:        mac80211,input-polldev,crc-itu-t,rfkill,crc-ccitt
vermagic: SMP mod_unload
Comment 4 Ivo van Doorn 2008-02-11 17:15:20 EST
Hmm thats odd. Well for rt2x00 2.0.14 this kind of errors are unknown so far.
It doesn't look like a complete random crash, since it seems to be consistent 
about a list error. It is hard to see in which module this bug is occuring, 
but since rt2x00 doesn't use lists...

I'm sorry, but I am not really convinced this is a bug in rt2500pci...
Are you sure this bug doesn't appear when rt2500pci is not loaded, or the 
device is not present?
Comment 5 Vaclav "sHINOBI" Misek 2008-02-12 03:04:59 EST
Not completely sure, because the device is build in and I can't remove it. But
when the system is started without NetworkManager there is no error. But after
ifconfig wlan0 up - bang. There were many patches regarding rt2x00 merged in the
latest kernels.

- rt2x00: don't write past the end when writing short descriptors on rt61
- rt2x00: Update copyright notice
- rt2x00: Add new USB ID to rt2500usb
- rt2x00: Fix tx parameter initialization
- rt2x00: Enable master and adhoc mode again
- rt2x00: Driver requiring firmware should select crc algo
- rt2x00: Add per-interface structure
- rt2x00: Remove TX_MGMT queue usage
- rt2x00: Initialize QID from queue->qid
- rt2x00: Move beacon and atim queue defines into rt2x00
- rt2x00: Fix queue index handling
- rt2x00: Queue handling overhaul

All kernels after these patches doesn't work for me, but it can be certainly
related to the general wireless changes.
Any idea how to debug it?
Comment 6 Ivo van Doorn 2008-02-12 06:52:14 EST
Ah yes, that list correspond to the rt2x00 2.1.0 patch series, John probably
merged all patches for 2.1.0 except the version bump itself.

This means that:
yes this bug and the other one you reported are caused by rt2x00,
and those issues have been resolved in the 2.1.1 release. But unfortunately even
in rt2x00 2.1.1 the TX and RX remain broken so it isn't a useful version yet.
Comment 7 Vaclav "sHINOBI" Misek 2008-02-22 15:47:34 EST
Kernel panics are gone in the kernel 2.6.25-0.64.rc2.git5.fc9, but the other bug
9(432266) remains. Unfortunately the device is still not working, maybe in
another update ;-).
Comment 8 John W. Linville 2008-02-25 08:35:35 EST
Ivo, for reverence fedora kernel version 2.6.25-0.64.rc2.git5.fc9 corresponds 
to wireless-testing commit e040078e1d5700aaf2a554612db41c9384bc864a.
Comment 9 Ivo van Doorn 2008-02-25 17:38:32 EST
At the moment rt2x00 2.1.3 (released minutes ago) should address the issue of
the TX/RX not working (Current score: 3 people reported success, 1 reported
Comment 10 Vaclav "sHINOBI" Misek 2008-03-04 16:23:29 EST
The kernel-2.6.25-0.87.rc3.git4.fc9 which should include 2.1.3 is still not
working for my hw, but no kernel panic.
Comment 11 John W. Linville 2008-03-05 13:28:16 EST
*** Bug 433201 has been marked as a duplicate of this bug. ***
Comment 12 John W. Linville 2008-03-05 13:29:55 EST
Closing on the basis of "no kernel panic".  I believe bug 435591 covers 
the "still not working" bit...
Comment 13 Vedran Miletić 2008-03-06 05:41:19 EST
I doubt. All those bugs cover stuff that didn't work even before 2.6.24, while
in my case it stopped working with 2.6.24-something, and only in fedora (it
works just fine with debian's 2.6.24).
Let's hope it will magically get fixed somehow in final 2.6.25...
Comment 14 Vaclav "sHINOBI" Misek 2008-03-07 13:49:57 EST
Created attachment 297235 [details]
/var/log/messages calltrace

Hmm I just noticed with the latest rawhide, that the crash is unfortunately
back. kernel-2.6.25-0.95.rc4.fc9
Comment 15 Ivo van Doorn 2008-03-07 14:10:47 EST
Ok, that panic sounds pretty straightforward. :)
I'll look into this.
Comment 16 Ivo van Doorn 2008-03-09 17:53:35 EDT
I have a fix for this in the rt2x00 2.1.4 release which was released a few 
minutes ago.
Comment 17 Vaclav "sHINOBI" Misek 2008-03-12 17:30:55 EDT
Wonderful! The latest koji kernel (with included 2.1.4)
2.6.25-0.113.rc5.git2.fc9 did the trick. No crash and working wireless. Thanks a
Comment 18 Vaclav "sHINOBI" Misek 2008-04-01 17:23:22 EDT
Created attachment 299971 [details]

Unfortunately the bug is back. The latest working kernel is
kernel-2.6.25-0.155.rc6.git8.fc9.x86_64, the latest tested not working
Comment 19 Ivo van Doorn 2008-04-01 17:32:16 EDT
A bit of luck, I released a patch for this issue a few days ago. :)

John, this bug can be fixed with the patch:
[PATCH] rt2x00: Invert scheduled packet_filter check
which I send to linux-wireless recently.
Comment 20 John W. Linville 2008-04-03 15:08:05 EDT
That patch is available in the kernels here:


Do those kernels change the situation for you?
Comment 21 Vaclav "sHINOBI" Misek 2008-04-03 18:00:23 EDT
Great with the above mentioned kernel there is no crash and the wireless is
working. Thanks a lot.

Note You need to log in before you can comment on or make changes to this bug.