Bug 436589 - On boot up "pnpacpi: exceeded the max number of mem resources"
On boot up "pnpacpi: exceeded the max number of mem resources"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 425837 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 23:48 EST by David
Modified: 2008-04-02 23:52 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 23:52:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg showing error messages for 2.6.23.15-137.fc8 (23.90 KB, text/plain)
2008-03-16 14:19 EDT, Peter H. Jones
no flags Details
dmesg showing error messages for experimental version 2.6.24.3-22.fc8 (25.94 KB, text/plain)
2008-03-16 14:20 EDT, Peter H. Jones
no flags Details
/proc/iomem for working kernel 2.6.23.15-137.fc8 (1.77 KB, text/plain)
2008-03-16 14:21 EDT, Peter H. Jones
no flags Details
/proc/iomem for test kernel 2.6.24.3-22.fc8 (1.77 KB, text/plain)
2008-03-16 14:23 EDT, Peter H. Jones
no flags Details
dmesg showing error messages for experimental version 2.6.24.3-34.fc8 (25.89 KB, text/plain)
2008-03-17 00:19 EDT, Peter H. Jones
no flags Details
/proc/iomem for test kernel-2.6.24.3-34.fc8 (1.77 KB, text/plain)
2008-03-17 00:20 EDT, Peter H. Jones
no flags Details
output from yum/grubby when the kernel update fails (6.64 KB, text/plain)
2008-03-17 02:37 EDT, chris lea
no flags Details
diff showing /etc/sysconfig/hwconf change (5.33 KB, text/plain)
2008-03-18 22:03 EDT, Peter H. Jones
no flags Details

  None (edit)
Description David 2008-03-07 23:48:41 EST
Description of problem:
On boot up "pnpacpi: exceeded the max number of mem resources"

Version-Release number of selected component (if applicable):
Current kernel 2.6.24.3-12

How reproducible:
Absolutely - everytime you boot you see the alert

Steps to Reproduce:
1. Reboot
2. Observe the warning
3.
  
Actual results:
2.6.24.3-12

Expected results:
No error or warning

Additional info:
Comment 1 Stephen Warren 2008-03-08 02:13:16 EST
I see this too, on a Dell Inspiron 9300 laptop if it makes any difference.
Comment 2 Jón Fairbairn 2008-03-08 05:12:08 EST
I also get this, and what's more the machine (an IBM thinkpad X30, 26724XG)
subsequently hangs at "Starting udev:".  Booting kernel-2.6.23.15-137.fc8, the
machine runs fine.

Clearly this is a big issue for me.

Comment 3 Daniel Laczi 2008-03-09 14:06:44 EDT
I get this message too:

pnpacpi: exceeded the max nubmer of mem resources: 12
Uncompressing Linux... OK, booting the kernel.

But everything works fine.
My mainbord is: ASUS A8N SLI Premium. I get this message since the update to
kernel 2.6.24.3-12.fc8.
Comment 4 Zoltan Kota 2008-03-09 19:02:27 EDT
The same message for me, and I have no network with 2.6.24.3-12.fc8.
2.6.23.15-137.fc8 works fine.
Comment 5 Feng Yu 2008-03-09 20:14:49 EDT
The same message for me, too. 
Thinkpad T42. 
Everything seems fine.
Comment 6 Robert Scheck 2008-03-10 04:22:21 EDT
Same here on a "Dell Precision M6300 Workstation": pnpacpi: exceeded the max 
number of mem resources: 12 - see also: http://lkml.org/lkml/2007/12/5/301
Comment 7 Robert Scheck 2008-03-10 04:33:31 EDT
Oh and see http://lkml.org/lkml/2007/12/13/77 as well...
Comment 8 Airate 2008-03-10 09:24:12 EDT
i got the same message too,
Thinkpad T43, 
2.6.24.3-12
Everything seems fine.
Comment 9 Sergio Morais Lietti 2008-03-11 00:09:47 EDT
I got the same message on Dell optiplex gx280, Dell Latitude 520, and Dell
Inspiron 1420.
Comment 10 Daniel Laczi 2008-03-11 12:33:39 EDT
When I unplug a SATA-drive my SYSTEM FREEZES (it was unmounted before).

When SATA drives were mounted, the drive was attached and then unmounted (but
not unplugged, this would cause system freeze) autofs fails halting while
shutting down automount on system shutdown.

This behavior appears since kernel 2.6.24.3-12.fc8 and only on the machine which
shows that pnpacpi message. My other machines work fine.
Comment 11 Dave Jones 2008-03-11 15:04:50 EDT
I just added a patch to get some more debugging info.  It'll show up in builds
starting at version kernel-2.6.24.3-31.fc8
If all of you seeing the overflow messages could run this when it shows up and
paste the updated version of the message that might give us some idea of how
large a range we're expecting to see.

Thanks.
Comment 12 Dave Jones 2008-03-11 15:05:31 EDT
*** Bug 425837 has been marked as a duplicate of this bug. ***
Comment 13 David 2008-03-11 18:58:41 EDT
Dave,

Any idea when an updated kernel will make it into either testing or main repo? 
Only reason I ask is there are clear network adapter name bugs with this kernel
as well (https://bugzilla.redhat.com/show_bug.cgi?id=436456) so it would be good
to try one updated kernel fixing both these issues rather than potentially two
sets of kernels being made for different issues?
Comment 14 petrosyan 2008-03-12 02:24:57 EDT
here is the output from kernel-2.6.24.3-33.fc8

Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnpacpi: exceeded the max number of mem resources. Max:12 Found:12
pnp: PnP ACPI: found 10 devices
ACPI: ACPI bus type pnp unregistered
Comment 15 David 2008-03-13 18:48:33 EDT
ACPI: bus type pci registered
PCI: PCI BIOS revision 3.00 entry at 0xfaf90, last bus=3
PCI: Using configuration type 1
Setting up standard PCI resources
ACPI: EC: Look up EC in DSDT
ACPI: Interpreter enabled
ACPI: (supports S0 S1 S4 S5)
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
Force enabled HPET at base address 0xfed00000
PCI quirk: region 0400-047f claimed by ICH6 ACPI/GPIO/TCO
PCI quirk: region 0480-04bf claimed by ICH6 GPIO
PCI: Transparent bridge - 0000:00:1e.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PEX0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.HUB0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 *5 6 7 9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 *9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 9 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK0] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK1] (IRQs *3 4 5 6 7 9 10 11 12 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnpacpi: exceeded the max number of mem resources: 12
pnp: PnP ACPI: found 13 devices
ACPI: ACPI bus type pnp unregistered
Comment 16 Remy Maucherat 2008-03-14 08:22:03 EDT
With kernel-2.6.24.3-34:

Mar 14 12:35:09 localhost kernel: pnp: PnP ACPI init
Mar 14 12:35:09 localhost kernel: ACPI: bus type pnp registered
Mar 14 12:35:09 localhost kernel: pnpacpi: exceeded the max number of mem
resources. Max:12 Found:12
Mar 14 12:35:09 localhost kernel: pnp: PnP ACPI: found 14 devices
Mar 14 12:35:09 localhost kernel: ACPI: ACPI bus type pnp unregistered
Mar 14 12:35:09 localhost kernel: usbcore: registered new interface driver usbfs
Comment 17 Jón Fairbairn 2008-03-14 13:37:50 EDT
With 2.6.24.3-22.fc8 (ThinkPad X30)

Mar 14 17:21:27 localhost kernel: pnp: PnP ACPI init
Mar 14 17:21:27 localhost kernel: ACPI: bus type pnp registered
Mar 14 17:21:27 localhost kernel: pnpacpi: exceeded the max number of mem
resources: 12
Mar 14 17:21:27 localhost kernel: pnp: PnP ACPI: found 12 devices

And it turns out that it doesn't actually die when starting udev, just takes a
*very* long time. 
Comment 18 Peter H. Jones 2008-03-15 11:51:57 EDT
I made the following temporary patch to /etc/yum/yum.conf to stop the update
notifications from popping up:

=========== Start temp.patch ================================
*** yum-updatesd.conf       2007-12-17 23:41:33.000000000 -0500
--- yum-updatesd.conf.new   2008-03-15 10:46:20.000000000 -0400
***************
*** 16,18 ****
--- 16,21 ----
  do_download = no
  # automatically download deps of updates
  do_download_deps = no
+
+ # Temporarily ignore bad kernel update
+ kernel-2.6.24.3-12.fc8
=========== End temp.patch ================================

I tried to restart the yum-updatesd service, but got a subsys lock mesage. I
rebooted to get a clean restart. Now, no update popup appears. The kernel update
is still visible in Software Updater.

Hope this helps, until the bad update is pulled from the repositories and/or a
better kernel update is posted.
Comment 19 Peter H. Jones 2008-03-15 13:34:18 EDT
Sorry, please ignore the previous patch. It contains a syntax error: I had
forgotten to include the "exclude" command. I tried fixing that, and putting
wildcard *'s in, but I still get the popup. I'll go back to quitting the update
process after each boot.
Comment 20 Peter H. Jones 2008-03-16 06:22:26 EDT
This patch worked for me to remove this update from being offered by the popup
software updater:
========= Start of patch =====================================
*** /etc/yum.repos.d/fedora-updates.repo        2007-12-12 16:30:15.000000000 -0500
--- /etc/yum.repos.d/fedora-updates.repo.patch  2008-03-16 06:01:30.000000000 -0400
***************
*** 6,11 ****
--- 6,12 ----
  enabled=1
  gpgcheck=1
  gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
+ exclude = kernel-2.6.24.3-12.fc8.*
 
  [updates-debuginfo]
  name=Fedora $releasever - $basearch - Updates - Debug~
========= End of patch =====================================

Of course, subsequent updates should still appear.
Comment 21 Peter H. Jones 2008-03-16 14:19:15 EDT
Created attachment 298202 [details]
dmesg showing error messages for 2.6.23.15-137.fc8
Comment 22 Peter H. Jones 2008-03-16 14:20:51 EDT
Created attachment 298205 [details]
dmesg showing error messages for  experimental version 2.6.24.3-22.fc8
Comment 23 Peter H. Jones 2008-03-16 14:21:59 EDT
Created attachment 298206 [details]
/proc/iomem for working kernel 2.6.23.15-137.fc8
Comment 24 Peter H. Jones 2008-03-16 14:23:12 EDT
Created attachment 298207 [details]
/proc/iomem for test kernel 2.6.24.3-22.fc8
Comment 25 Peter H. Jones 2008-03-16 14:34:12 EDT
Downloaded kernel-2.6.24.3-12.fc8.i586, not offered by updater. Same behavior.
Deleted that kernel, and installed kernel-2.6.24.3-22.fc8.i686. Still behavior,
and also changed versions of the message reported in bug #285251. In connection
with the latter, I supplied a copy of /proc/iomem. While waiting for the
debugging patch promised in comment #11, I have posted dmesg and iomem output
for both the working kernel-2.6.23.15-137.fc8.i686 and the test version,
kernel-2.6.24.3-22.fc8.i686. I hope this information helps speed resolution of
this bug.
Comment 26 Peter H. Jones 2008-03-17 00:19:44 EDT
Created attachment 298229 [details]
dmesg showing error messages for  experimental version 2.6.24.3-34.fc8
Comment 27 Peter H. Jones 2008-03-17 00:20:47 EDT
Created attachment 298230 [details]
/proc/iomem for test kernel-2.6.24.3-34.fc8
Comment 28 Peter H. Jones 2008-03-17 00:27:34 EDT
Much improved. I have to start the network manually, using
System/Administration/Network Device Control/Activate. My network devices now
have .bak suffixes.
Comment 29 Peter H. Jones 2008-03-17 00:53:27 EDT
Significant diffs of the dmesg and iomem files are as follows:

 diff iomem.2.6.24.3-22.fc8 iomem.2.6.24.3-34.fc8
9,10c9,10
<   00400000-0062f688 : Kernel code
<   0062f689-0074a723 : Kernel data
---
>   00400000-0062f698 : Kernel code
>   0062f699-0074a723 : Kernel data

and

diff dmesg.2.6.24.3-22.fc8 dmesg.2.6.24.3-34.fc8
2c2
< Linux version 2.6.24.3-22.fc8 (mockbuild@xenbuilder2.fedora.redhat.com) (gcc
version 4.1.2 20070925 (Red Hat 4.1.2-33)) #1 SMP Fri Mar 7 10:08:30 EST 2008
---
> Linux version 2.6.24.3-34.fc8 (mockbuild@xenbuilder1.fedora.redhat.com) (gcc
version 4.1.2 20070925 (Red Hat 4.1.2-33)) #1 SMP Wed Mar 12 18:17:20 EDT 2008
75c75
< Kernel command line: ro root=LABEL=/ rhgb quiet nohz=off highres=off
---
> Kernel command line: ro root=LABEL=/ rhgb quiet
...
167,168c167,168
< pnpacpi: exceeded the max number of mem resources: 12
< pnpacpi: exceeded the max number of IO resources: 40 
---
> pnpacpi: exceeded the max number of mem resources. Max:12 Found:12
> pnpacpi: exceeded the max number of IO resources. Max:40 Found:40
...
417,418c418,421
< iTCO_vendor_support: vendor-support=0
< input: Power Button (FF) as /devices/virtual/input/input4
---
> sd 0:0:0:0: Attached scsi generic sg0 type 0
> sr 1:0:0:0: Attached scsi generic sg1 type 5
> input: PC Speaker as /devices/platform/pcspkr/input/input4
> input: Power Button (FF) as /devices/virtual/input/input5
420c423,428
< input: Lid Switch as /devices/virtual/input/input5
---
> input: Lid Switch as /devices/virtual/input/input6
> ACPI: Lid Switch [LID]
> input: Power Button (CM) as /devices/virtual/input/input7
> iTCO_vendor_support: vendor-support=0
> ACPI: Power Button (CM) [PWRB]
> ACPI: Battery Slot [BAT1] (battery present)
... more diffs regarding hardware assigned differently
> warning: process `system-control-' used the deprecated sysctl system call with
1.23.
> warning: process `/usr/sbin/syste' used the deprecated sysctl system call with
1.23.
> ADDRCONF(NETDEV_UP): eth1: link is not ready
> e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex
> ADDRCONF(NETDEV_UP): eth0: link is not ready
> ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
> eth0: no IPv6 routers present
Comment 30 chris lea 2008-03-17 02:37:44 EDT
Created attachment 298232 [details]
output from yum/grubby when the kernel update fails
Comment 31 chris lea 2008-03-17 02:38:51 EDT
Comment on attachment 298232 [details]
output from yum/grubby when the kernel update fails

Hi. I'm also seeing this, but interestingly the kernel fails to even install
properly (kernel-2.6.24.3-34). When I try to update via YUM, something is
failing and /boot/grub/menu.1st doesn't get updated properly. The entry for the
new kernel isn't getting put in. I'm attaching the file with the output I get
when it fails.

If I manually update /boot/grub/menu.1st I can get my box to boot, but I see
the "pnpacpi: exceeded the max number of mem resources" and the machine behaves
somewhat erratically. I can explain "somewhat erratically" in more detail if
it's helpful, but I'm guessing the attached file will be more useful. If I'm
wrong let me know and do my best to explain what I see.
Comment 32 Robin 2008-03-17 13:50:57 EDT
After fighting with a weird hardware/BIOS issue, I started looking into this
error message on reboot.

  kernel-2.6.24.3-12.fc8

dmesg output.

Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnpacpi: exceeded the max number of mem resources: 12
pnp: PnP ACPI: found 14 devices
ACPI: ACPI bus type pnp unregistered

As it shows, I have 14 devices but only 12 are accepted.  I don't know how this
affects my machine but I will have to wait and see.

I did search and found that this ia a kernel level decision and some of it is
waiting for dynamic code.  But in the mean time, something has to be done now.

This is what I found.

http://www.mail-archive.com/linux-kernel@vger.kernel.org/msg236413.html

http://kerneltrap.org/mailarchive/linux-kernel/2007/11/30/464546

Having an error message like this can take time away from finding and repairing
real problems.
Comment 33 Kevin Cozens 2008-03-17 14:13:54 EDT
IIRC, there was a message about the resources being exceeded with the last
2.6.23 kernel made available for F8. It just didn't give any stats. With the
2.6.24 kernels it would be appear to be using >= instead > when doing a check.
If 12 slots are needed and 12 are available there is no problem and it has not
exceeded the available resources.
Comment 34 Len Brown 2008-03-18 15:05:34 EDT
My comments on this issue are here
http://lkml.org/lkml/2008/3/12/255

As it seems we'll be living with these hard-coded,
but sometimes insufficient limits for some time,
I'm inclined to reduce KERN_ERR to something less severe.
If Red Hat deleted this message entirely from Fedora
to stop alarming users, I'd be okay with that too.
Comment 35 Peter H. Jones 2008-03-18 22:03:37 EDT
Created attachment 298469 [details]
diff showing /etc/sysconfig/hwconf change

After seeing that the pnpapci message is probably inoccuous, I have decided to
go ahead and try kernel 2.6.24.3-34.fc8. On reboot, I found my network was
dead. In the System/Administration/Network, menu, I changed the eth0.bak device
name to eth0. Also, I made sure to make this device become active after
booting.

Did a diff -r <previous /etc/hwconfig>	/etc/hwconfig. Several differences. The
result is it Attachment 7 [details].
Comment 36 Peter H. Jones 2008-03-18 22:07:00 EDT
Well, I meant the 7th in this posting, not Attachment 7 [details]. The diff is here:
https://bugzilla.redhat.com/attachment.cgi?id=298469 .
Comment 37 Chuck Ebbert 2008-03-20 11:42:36 EDT
(In reply to comment #34)
> As it seems we'll be living with these hard-coded,
> but sometimes insufficient limits for some time,
> I'm inclined to reduce KERN_ERR to something less severe.
> If Red Hat deleted this message entirely from Fedora
> to stop alarming users, I'd be okay with that too.

Changed to KERN_DEBUG in 2.6.24.3-50
Comment 38 Daniel Veillard 2008-03-21 09:00:53 EDT
Well w.r.t. hard coded limit I also get

"pnpacpi: exceeded the max number of I/O resources 40:40"

on a rather standard Dell Dimension 9150 when booting 2.6.24.3-34.fc8 x86_64

Daniel
Comment 39 Len Brown 2008-03-26 13:51:46 EDT
upstream I'll change this to KERN_WARNING.
Fedora boots with "quiet" by default, and so KERN_WARNING
will not be printed on the default boot.

for users that delete the "quiet", they'll get this
message along with a zillion others, which is appropriate.
going to KERN_DEBUG and thus requiring "debug" on the
cmdline to see this message seems to be burying it
a little too deep, as it is a valid warning after all.

also, note also that 2.6.25-rc7 made this message less likely:
03c086a747d0b242878eb881971ec61c1555869d

include/linux/pnp.h

-#define PNP_MAX_MEM            12
+#define PNP_MAX_MEM            24
Comment 40 Spnego Mrxsmb 2008-03-28 18:41:21 EDT
The consequence of this seems to be that devices don't work/activate.

Symptoms on my machine are that the sound system drops alsa, oss or arts. I
noticed that switching xine, mms or amarok to a different sound module causes
the external USB hard disk to unmount and disappear, remounting the USB hard
disk then causes sound to stop working.

From history it seems others are having similar issue but with different
devices, network cards etc.
Comment 41 Jón Fairbairn 2008-03-29 05:25:51 EDT
I think comment 40 is correct.  See my comments 20 and 21 (and
attachment(id=299389)) on bug#436583.
Udev times out during boot and I lose network and sound.
Comment 42 Chuck Ebbert 2008-04-02 23:52:49 EDT
The "exceeded the number of resources" message was just a warning. So many
people, all with different unrelated bugs, have piled onto this report that
there is no way to make any sense of it now. The severity of the warning has
been lowered so it will no longer show during normal (quiet) boot. Anyone who is
still having a problem please file a new separate bug (after trying 2.6.24.4-64).

Note You need to log in before you can comment on or make changes to this bug.