Bug 436714 - F-9 VMWare video driver is broken
F-9 VMWare video driver is broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vmware (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
: 437403 437439 (view as bug list)
Depends On:
Blocks: LTSPHARDWARE F9Beta
  Show dependency treegraph
 
Reported: 2008-03-09 16:44 EDT by Jon Stanley
Modified: 2008-04-03 10:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 16:04:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XConfig.test from installation (941 bytes, text/plain)
2008-03-09 16:44 EDT, Jon Stanley
no flags Details
X.log from installation (7.86 KB, text/plain)
2008-03-09 16:49 EDT, Jon Stanley
no flags Details
xorg log file from 1.4.99.901-5.20080310.fc9 (30.79 KB, text/plain)
2008-03-13 15:13 EDT, Jeff Bastian
no flags Details

  None (edit)
Description Jon Stanley 2008-03-09 16:44:11 EDT
Not sure whether to put this under anaconda or xorg, but the current rawhide
(for the last few days) has not been able to do a graphical install under VMWare
- the X server fails to start.  The configuration looks sane, but the driver
complains about no valid modes:

(EE) VMWARE(0): No valid modes found
(EE) Screen(s) found, but none have a usable configuration.

XConfig.test and X.log attached.
Comment 1 Jon Stanley 2008-03-09 16:44:11 EDT
Created attachment 297378 [details]
XConfig.test from installation
Comment 2 Jon Stanley 2008-03-09 16:49:36 EDT
Created attachment 297379 [details]
X.log from installation
Comment 3 Jon Stanley 2008-03-09 17:19:19 EDT
I was about ready to reassign when Jeremy did - the installed system has exactly
the same symptoms.
Comment 4 Warren Togami 2008-03-10 03:36:33 EDT
kvm-63's -vmware-vga which is now default in our kvm package has the same issue
with rawhide drivers.
Comment 5 Martin 2008-03-11 06:43:46 EDT
same problem on my VMWare Server with fc9 after yum update.
Comment 6 Jeff Bastian 2008-03-11 10:59:38 EDT
I'm also experiencing this with VMware Fusion 1.1.1 under OS X 10.5.2.
Comment 7 Jeff Bastian 2008-03-11 11:40:56 EDT
FWIW, the VESA driver works under VMware Fusion 1.1.1 (although it's not very
fast, of course).

I currently have:
xorg-x11-drv-vesa-1.3.0-13.20071113.fc9.i386
xorg-x11-drv-vmware-10.15.2-100.1.fc9.i386
Comment 8 Jeremy Katz 2008-03-11 12:41:00 EDT
Sticking on the beta blocker at least for now given the prevalence of using
virtualization for testing the betas.
Comment 9 John Poelstra 2008-03-11 23:39:13 EDT
not working with i386 20080311 rawhide on VMwareWorkstation-5.5.5-56455
Comment 10 Adam Jackson 2008-03-12 16:55:25 EDT
xserver 1.4.99.901-4 will at least start up.  There might still be a bug in the
cursor code though, in my testing the cursor just shows up black.
Comment 11 Jeremy Katz 2008-03-12 18:01:14 EDT
And this got tagged
Comment 12 Adam Jackson 2008-03-12 19:12:30 EDT
My naïve hope was that simply flipping to software cursor in the vmware driver
would fix things, but instead that actually makes it much worse.  The glyph
looks correct but mouse events don't happen.

Possibly worth flipping qemu back to cirrus for the beta?  Not my call.  I'll
keep looking at the vmware cursor problem but I suspect it's a qemu bug, since
"hardware cursor" in vmware hardware means the container draws the cursor.
Comment 13 Denis Leroy 2008-03-12 19:25:35 EDT
with workstation 6, the driver doesn't work at all, it's not just a cursor
problem...
Comment 14 Adam Jackson 2008-03-12 19:44:12 EDT
(In reply to comment #13)
> with workstation 6, the driver doesn't work at all, it's not just a cursor
> problem...

Can you attach the X log from the failure please?
Comment 15 Denis Leroy 2008-03-12 20:16:08 EDT
Ajax, apologies. xserver 1.4.99.901-5 works fine here, with no cursor problems.
Thanks!
Comment 16 Adam Jackson 2008-03-13 13:12:40 EDT
(In reply to comment #15)
> Ajax, apologies. xserver 1.4.99.901-5 works fine here, with no cursor problems.
> Thanks!

I'm assuming that means "works fine with vmware as the host".

So I think the remaining failure case is just that qemu's vmware emulation
doesn't do the cursor glyph right (since clearly it works with vmware vmware).
Comment 17 Jeff Bastian 2008-03-13 15:13:06 EDT
Created attachment 297968 [details]
xorg log file from 1.4.99.901-5.20080310.fc9

It's better with xorg-x11-server-Xorg-1.4.99.901-5.20080310.fc9 under
VMware Fusion 1.1.1 but it's not fully functional yet.

1. The mouse cursor moves, but the buttons don't work.	I can't click on 
   anything.  If I can get the focus onto a window, I can use keyboard
   shortcuts to do things.

2. I couldn't choose a resolution above 800x600 with s-c-display.  This 
   may be because of the mouse buttons not working, I couldn't pick a
   monitor with a supported resolution.  I copied my xorg.conf from my
   Fedora 8 VMware system and that got me to 1680x1050, but the mouse
   buttons were still non-functional.

/var/log/Xorg.0.log is attached
Comment 18 Denis Leroy 2008-03-13 17:22:17 EDT
In reply to comment #16)
> I'm assuming that means "works fine with vmware as the host".

That was F-8 as host, F-9 as guest. I was able to xrandr to a higher resolution
in the guest OS too.
Comment 19 Jeremy Katz 2008-03-13 18:08:53 EDT
*** Bug 437403 has been marked as a duplicate of this bug. ***
Comment 20 Gilboa Davara 2008-03-13 20:44:22 EDT
xorg-x11-drv-vmware-10.15.2-100.1.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-1.20080307.fc9.x86_64

VMWare Server 1.0.4 under F8 as a host.
X dies with a "Mode pool is empty" message and leaves a corrupted text console.

P.S. I'm using vesafb on my text consoles. (vga=0x317).

- Gilboa
Comment 21 Jeremy Katz 2008-03-14 09:39:45 EDT
*** Bug 437439 has been marked as a duplicate of this bug. ***
Comment 22 Adam Jackson 2008-03-17 13:12:04 EDT
(In reply to comment #20)
> xorg-x11-drv-vmware-10.15.2-100.1.fc9.x86_64
> xorg-x11-server-Xorg-1.4.99.901-1.20080307.fc9.x86_64

Yes, 1.4.99.901-1 is busted.  Which is why it's not in the beta:

atropine:~% koji latest-pkg --quiet f9-beta xorg-x11-server 
xorg-x11-server-1.4.99.901-8.20080310.fc9  f9-beta               ajax
Comment 23 Jesse Keating 2008-03-17 19:54:10 EDT
I can confirm that the vmware driver in rawhide / beta now works.
Comment 24 John Poelstra 2008-04-02 15:01:25 EDT
appears to be broken again in 2008-04-02 rawhide
Comment 25 Warren Togami 2008-04-02 16:04:14 EDT
John, no, that was a different new issue in Bug #440175
Comment 26 Austin 2008-04-02 19:48:52 EDT
(In reply to comment #17)
> Created an attachment (id=297968) [edit]
> xorg log file from 1.4.99.901-5.20080310.fc9
> 
> It's better with xorg-x11-server-Xorg-1.4.99.901-5.20080310.fc9 under
> VMware Fusion 1.1.1 but it's not fully functional yet.
> 
> 1. The mouse cursor moves, but the buttons don't work.	I can't click on 
>    anything.  If I can get the focus onto a window, I can use keyboard
>    shortcuts to do things.
> 
> 2. I couldn't choose a resolution above 800x600 with s-c-display.  This 
>    may be because of the mouse buttons not working, I couldn't pick a
>    monitor with a supported resolution.  I copied my xorg.conf from my
>    Fedora 8 VMware system and that got me to 1680x1050, but the mouse
>    buttons were still non-functional.
> 
> /var/log/Xorg.0.log is attached

I have a feeling the issues described here are related to bug# 439336. Feel free
to add yourself to the CC list if it is...
Comment 27 Jeff Bastian 2008-04-03 10:09:15 EDT
(In reply to comment #26)
> I have a feeling the issues described here are related to bug# 439336. Feel free
> to add yourself to the CC list if it is...

Actually, I believe bug 434807 describes the problem.  I tried the workaround
mentioned in 
https://bugzilla.redhat.com/show_bug.cgi?sourceid=Mozilla-search&id=434807#c6
and my mouse started acting normally again.
Comment 28 Denis Leroy 2008-04-03 10:26:11 EDT
I have no problems (mouse, driver,...) with the latest Koji build
(xorg-x11-server-1.4.99.901-16.20080401.fc9).

Note You need to log in before you can comment on or make changes to this bug.