Bug 436885 - Anaconda UI buglet - root password box not focused
Anaconda UI buglet - root password box not focused
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
: 437536 437954 438098 (view as bug list)
Depends On:
Blocks: F9Beta
  Show dependency treegraph
 
Reported: 2008-03-10 18:15 EDT by Will Woods
Modified: 2008-03-18 22:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 18:09:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-03-10 18:15:39 EDT
A couple of minor things have changed in recent anaconda builds:

1) Network setup screen - defaults to being set to "localhost.localdomain"
manually, even if hostname was picked up by DHCP

2) On the Root Password screen, the text input box is not focused when the
screen loads.

Also Right-Alt is equivalent to Enter or Spacebar - it activates the hilighted
widget. Probably this is evdev-related but I haven't found a bug filed for it yet.
Comment 1 David Cantrell 2008-03-10 18:39:42 EDT
You violated a bug reporting rule.  Don't report more than one bug per bugzilla.

#1 was on purpose, but, yes, it should be dropping the hostname it found in to the entry box.  Will look at 
that.

Will look at #2 too since I worked on that last.
Comment 2 Will Woods 2008-03-11 11:47:38 EDT
Right, right. Sorry about that. If you'd like, I can split this into two bugs...
heh. (Actually the first bug mentioned is already fixed (thanks!) so I won't
waste time by doing so.)

I'll be sure to file the keymap thing separately.
Comment 3 David Cantrell 2008-03-11 21:51:02 EDT
Fixed up the root password entry box focus.  Also fixed the glade file so we don't get libglade warnings 
on the console because of root-password.png.

I cannot reproduce the hostname problem you're describing.
Comment 4 Will Woods 2008-03-14 13:03:31 EDT
With anaconda-11.4.0.52-1, the root password box appears to have focus, but
keyboard input goes nowhere.

Clicking on the second input box makes them *both* focused (!?).

I can hit Alt-P to focus the first box properly, and then it accepts keyboard input.
Comment 5 Jesse Keating 2008-03-14 13:33:36 EDT
I'm seeing the same thing, a single tab works though.
Comment 6 David Cantrell 2008-03-14 18:27:34 EDT
*** Bug 437536 has been marked as a duplicate of this bug. ***
Comment 7 Warren Togami 2008-03-18 17:16:14 EDT
*** Bug 437954 has been marked as a duplicate of this bug. ***
Comment 8 David Cantrell 2008-03-18 18:09:21 EDT
Fixed in rawhide now.  Sorry it took so long.  The "revenue" product had my attention for several days.

commit a177c85ddf988e813b3d56ce05ca631ef328c234
Author: David Cantrell <dcantrell@redhat.com>
Date:   Tue Mar 18 12:06:46 2008 -1000

    Focus root password entry box (#436885).
    
    Make sure the root password entry box has focus when we
    get to the password screen.  Pressing Enter will take
    you down to the confirm box.  Pressing Enter in confirm
    is the same as clicking Next on the screen.

Comment 9 David Cantrell 2008-03-18 22:13:05 EDT
*** Bug 438098 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.