Bug 439639 - Must select "shutdown"/"restart" several times to get out of KDE
Summary: Must select "shutdown"/"restart" several times to get out of KDE
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 441260 446789 448729 (view as bug list)
Depends On:
Blocks: F10Target
TreeView+ depends on / blocked
 
Reported: 2008-03-29 22:37 UTC by Mary Ellen Foster
Modified: 2008-05-28 13:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-29 22:57:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 152110 None None None Never

Description Mary Ellen Foster 2008-03-29 22:37:17 UTC
Description of problem:
I seem to have to tell the computer several times that, yes, I really do want to
shutdown/restart. It would be nice if it worked with one attempt.

Version-Release number of selected component (if applicable):
(KDE F9 beta live image)

How reproducible:
Every time (although I only got dumped to KDM once)

Steps to Reproduce:
1. Click KDE menu
2. Hover over "Leave"
3. Select "Restart"
(... screen gets shaded and a dialogue box comes up with three options, "Log
out", "Restart", and "Shut down")
4. Select "Restart" again from this box
5. (Optional (only once): get dropped to KDM instead of starting the shutdown
process, and choose "Restart" *again* from there)

Expected results:
I should only have to tell the computer once what I want to do :)

Additional info:
The discussion in bug 431817 is probably related, but I'm not sure if this is
exactly the same problem.

Comment 1 Rex Dieter 2008-03-29 22:44:39 UTC
This is definitely an upstream issue (and apparently it was done this way on
purpose, but it boggles my mind still).

Comment 2 Mary Ellen Foster 2008-03-29 22:57:21 UTC
Aha, finally found the upstream bug. They seem to be saying it's good because it
provides a confirmation. Then why don't they, like, use a confirmation DIALOGUE
BOX instead of presenting you with the same options again?!?! Arrgh ...

I also wonder why it dumped me to KDM that one time. Possibly a fluke because I
think kdesktop crashed on the way out that time too. Must investigate further.

Comment 3 Kevin Kofler 2008-03-29 23:27:59 UTC
This is not the same as bug 431817, which is about communication with GDM 2.22, 
this issue happens before KDM or GDM gets involved in the first place.

Comment 4 Kevin Kofler 2008-04-07 13:53:01 UTC
*** Bug 441260 has been marked as a duplicate of this bug. ***

Comment 5 Kevin Kofler 2008-04-07 13:54:37 UTC
FYI, the upstream bug has recently been reopened because people there disagree 
that this is intended/sensible behavior.

Comment 6 Gilboa Davara 2008-04-07 14:25:40 UTC
Eeek. Someone @KDE must have lost his marbles. (Which would explain the
un-removable zoom applet on the top left...)

Anyways, can you disable the "offer shut down options" (Settings -> session
manager) by default?

- Gilboa


Comment 7 Gilboa Davara 2008-04-07 14:28:53 UTC
Just for future reference.
http://bugs.kde.org/show_bug.cgi?id=152110
http://bugs.kde.org/show_bug.cgi?id=152486


Comment 8 Rex Dieter 2008-04-07 14:54:02 UTC
> Anyways, can you disable the "offer shut down options" (Settings -> session
> manager) by default?

No, because then that would break the simple/classic menu (I think).

Comment 9 Gilboa Davara 2008-04-07 15:18:39 UTC
Oy. /bangs head against the table.
Oh well, never liked the kick off menu any-how.

- Gilboa

Comment 10 Rex Dieter 2008-05-16 12:08:55 UTC
*** Bug 446789 has been marked as a duplicate of this bug. ***

Comment 11 Kevin Kofler 2008-05-28 13:42:41 UTC
*** Bug 448729 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.