Bug 439680 - gnome-packagekit shows installed packages as both installed & uninstalled
gnome-packagekit shows installed packages as both installed & uninstalled
Status: CLOSED DUPLICATE of bug 440122
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 439696 439782 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 07:32 EDT by Basil Mohamed Gohar
Modified: 2008-04-06 00:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 03:13:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Basil Mohamed Gohar 2008-03-30 07:32:21 EDT
Description of problem:
In the Add/Remove Software application (pk-application?), gnome-packagekit shows
all installed packages twice in the listing - once as installed, and once again
as uninstalled.  If installed packages are filtered out, then the uninstalled
"versions" of these installed packages are still shown, and, of course,
installing them will result in pk reporting "no packages were installed".


Version-Release number of selected component (if applicable):
gnome-packagekit 0.1.10

How reproducible:
Every time

Steps to Reproduce:
1. Start Add/Remove Software application
2. View listing and optionally refresh
3. Profit?
  
Actual results:
Lists all packages, installed & uninstalled, with the installed packages
appearing as both installed & uninstalled

Expected results:
All packages should be listed, with the installed packages (assuming they are
not filtered), only appear once, and appearing as installed (i.e., not dull)


Additional info:
Comment 1 Richard Hughes 2008-03-30 11:46:04 EDT
packagekitd is actually doing the right thing here, as we asking for all
installed and available packages. If the yum backend supported NEWEST then only
the installed package would be shown. Robin, are you able to look at the NEWEST
filter when you return?
Comment 2 Richard Hughes 2008-03-30 12:48:16 EDT
*** Bug 439696 has been marked as a duplicate of this bug. ***
Comment 3 Basil Mohamed Gohar 2008-03-30 12:50:05 EDT
Richard,

I don't know if this how PackageKit is supposed to work, but yum does allow
filtering by what is installed, so, it is perhaps possible to filter these out
from the entire available list.  I know, for example, yumex does this, but I
don't know how helpful that is...

Thanks for all your hard work and expediency in responding to bugs.
Comment 4 Richard Hughes 2008-03-30 15:25:06 EDT
Basil, if you just want to filter the installed packages you can just click
Filters->Installed->Only Installed in pk-application.
Comment 5 Richard Hughes 2008-03-31 08:22:00 EDT
*** Bug 439782 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy West 2008-04-04 01:40:48 EDT
Richard,

I think you're missing the point ... lol.  I'm glad that packagekit is showing
both installed and available packages, however I think the bug being referenced
here is in pk-application.  Try to think about this from the customer's
prospective.  What we have is confusion.  The customer installs a package and
then suddenly sees two packages with the same list.  They think to themselves,
did I install it correctly?  So they click the "greyed" out package (duplicate)
and try to install that and get a "no packages installed" message. 

Regarding comment #4, if I filter out the installed packages, then I should
*ONLY* have packages that are available to install.  Which ... is not the case
with this bug.  One of the duplicate entries stays in the list.  

Once again, there's nothing wrong with the backend, but we really need to
rethink what's going on on the frontend, otherwise all the hard work that was
put into packagekit is going to mean nothing, because customers are going to
install this and say, "this is crap"

--jwest
Comment 7 Jeremy West 2008-04-04 01:47:01 EDT
Isn't this a dup of BZ 440122?

--jwest
Comment 8 Richard Hughes 2008-04-04 03:13:16 EDT
Yup, and I learned python!

*** This bug has been marked as a duplicate of 440122 ***
Comment 9 Jeremy West 2008-04-06 00:42:26 EDT
Richard, can we expect to see this in rawhide and fedora 9 beta updates anytime
soon?

Note You need to log in before you can comment on or make changes to this bug.