Bug 440136 - PATCH: imagemagick fails to read 24bit .ico files causing various package build failures
PATCH: imagemagick fails to read 24bit .ico files causing various package bui...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Norm Murray
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 440765 440828 440907 440911
  Show dependency treegraph
 
Reported: 2008-04-01 16:35 EDT by Hans de Goede
Modified: 2008-04-28 11:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 11:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH: imagemagick fails to read 24bit .ico files (1.04 KB, patch)
2008-04-01 16:35 EDT, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2008-04-01 16:35:31 EDT
Description of problem:
Several packages uses convert to convert .ico files to .png files during their
build, currently a few of these fail to build as the reading of 24 bpp .ico
files is broken. The attached patch fixes this.

Here are a few buildlog examples of packages which currently fail to build in 
rawhide because of this, please fix this ASAP:
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-core/i386/scorched3d-41.3-2.fc9.src.rpm/result/build.log
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-core/i386/njam-1.25-9.fc9.src.rpm/result/build.log
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-core/i386/crystal-1.0.5-2.fc9.src.rpm/result/build.log
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-core/i386/zasx-1.30-6.fc9.src.rpm/result/build.log

I've also send this patch upstream.

Here is some explaintion of the patch:

Some recent versions of ImageMagick have seen some changes to the .ico handling
code to support reading 32 bit .ico files which contain a real alpha channel
instead of an alpha 0/1 bitmask.

These changes have broken support for reading 24 bpp + alpha bitmask .ico files,
by trying to read an alpha channel there, leading to an early eof.

This patch restores the reading of 24 bit .ico files, by not trying to read an
alpha channel there, but instead use the alpha bitmask as ImageMagicke did a
couple of releases ago.
Comment 1 Hans de Goede 2008-04-01 16:35:31 EDT
Created attachment 299966 [details]
PATCH: imagemagick fails to read 24bit .ico files
Comment 2 Hans de Goede 2008-04-18 08:17:46 EDT
Norm,

Can you please fix this, this blocks 4 other bugs. I'm sorry todo this, but
consider this your first ping in the light of the NonResponsiveMaintainers policy:
http://fedoraproject.org/wiki/PackageMaintainers/Policy/NonResponsiveMaintainers
Comment 3 Norm Murray 2008-04-22 23:57:57 EDT
Should be fixed in latest build just done. Please let me know if there are any
problems. 
Comment 4 Hans de Goede 2008-04-23 04:05:13 EDT
(In reply to comment #3)
> Should be fixed in latest build just done. Please let me know if there are any
> problems. 

There are, by updating to upstream's latest release instead of just applying my
patch, you've introduced a soname change into F-9 very very late in the F-9
release cycle. Luckily this build was never pushed to rawhide because rawhide is
frozen at the moment, please do a build of ImageMagick-6.3.8.1 with my patch
included for F-9 (no need to bump the epoch, the 6.4.x build was never pushed ot
any repos) and do the 6.4.x build for F-10 (F-9 currently has its own cvs
branch, F-10 is the devel branch).

Also looking at:
https://admin.fedoraproject.org/pkgdb/packages/bugs/ImageMagick

There are a lot of bugs open against ImageMagick, so it looks like you could use
a hand with maintaining it. I'm a _very_ experienced package maintainer /
programmer, see:
https://admin.fedoraproject.org/pkgdb/users/packages/jwrdegoede

And I would be very happy to lend a hand, would it be ok with you to have me as
co-maintainer. If so I'll request the necessary rights and start working on that
list of bugs.
Comment 5 Norm Murray 2008-04-23 21:21:34 EDT
done and done
Comment 6 Hans de Goede 2008-04-25 09:47:35 EDT
Thanks!

The new ImageMagick works fine, fixing all the bugs depending upon this one,
shall I mail rel-eng to ask to include this fixed version in F-9?

One important note: you've only done this update for the F-9 branch in CVS not
for devel, so if someone know makes changes to devel, then the 2 versions might
get out of sync. Its good policy to always make changes in devel and then copy
them to other branches, unless for reasons like sonames being different the 2
branches are based on different upstream versions (which will be the case once
devel gets updated to 6.4.x).
Comment 7 Hans de Goede 2008-04-28 11:22:10 EDT
I've discussed things with rel-eng and they've decided to include
ImageMagick-6.3.8.1-4.fc9 in F-9 final, so I'm closing this now.

Note You need to log in before you can comment on or make changes to this bug.