This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 458807 - xorg-x11-drv-i810-2.4.0-1.fc10.i386: 'failed to load module "intel"', whitescreens compiz
xorg-x11-drv-i810-2.4.0-1.fc10.i386: 'failed to load module "intel"', whitesc...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 459298 459326 459363 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 09:52 EDT by Tom London
Modified: 2009-09-17 07:16 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 07:16:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log showing "intel" errors (14.43 KB, text/plain)
2008-08-12 09:58 EDT, Tom London
no flags Details
Xorg.0.log from xorg-x11-drv-i810-2.4.0-2.fc10.i386 (36.23 KB, application/octet-stream)
2008-08-12 17:44 EDT, Tom London
no flags Details
/var/log/Xorg.0.log showing "black" external monitor, "active" shut laptop LCD (126.92 KB, text/plain)
2008-08-13 04:13 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2008-08-12 09:52:55 EDT
Description of problem:


15c15
< (==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 12 06:43:58 2008
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 12 06:14:15 2008
153,156c153,164
< (EE) LoadModule: Module intel does not have a intelModuleData data object.
< (II) UnloadModule: "intel"
< (II) Unloading /usr/lib/xorg/modules/drivers//intel_drv.so
< (EE) Failed to load module "intel" (invalid module, 0)
---
> (II) Module intel: vendor="X.Org Foundation"
> 	compiled for 1.4.99.902, module version = 2.2.1
> 	Module class: X.Org Video Driver
> 	ABI class: X.Org Video Driver, version 4.0
> (II) Loading sub module "intel_master"
> (II) LoadModule: "intel_master"
> 
> (II) Loading /usr/lib/xorg/modules/drivers//intel_master_drv.so
> (II) Module intel: vendor="X.Org Foundation"
> 	compiled for 1.4.99.902, module version = 2.3.2
> 	Module class: X.Org Video Driver
> 	ABI class: X.Org Video Driver, version 4.0
169a178,181
> (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
> 	i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-08-12 09:57:36 EDT
Sorry hit enter key too soon.

This update appears to boot into gnome fine (gdm-greeter comes up at higher resolution than previously!), but I get the above messages in Xorg.0.log, and compiz does not start properly: I get the "white screen of death": screen completely white, with active cursor.  Workaround is to hit 'ctrl-alt-backspace'.

Reveting to previous version fixes.

I attach complete /var/log/Xorg.0.log below.

System is ThinkPad X60, with Intel 945 graphics.

[BTW, compiz whitescreens with or without "LIBGL_ALWAYS_INDIRECT=1"]
Comment 2 Tom London 2008-08-12 09:58:52 EDT
Created attachment 314095 [details]
Xorg.0.log showing "intel" errors

Doesn't seem to want to insert "intel" module.....
Comment 3 Tom London 2008-08-12 10:13:29 EDT
More: This happens every time, and I run without xorg.conf.
Comment 4 darrell pfeifer 2008-08-12 11:39:35 EDT
Same problem here. In my case both gdm and using startx fail

(--) PCI:*(0@0:2:0) Intel Corporation Mobile GM965/GL960 Integrated Graphics Controlle
r rev 12, Mem @ 0xfea00000/0, 0xe0000000/0, I/O @ 0x0000eff8/0
(--) PCI: (0@0:2:1) Intel Corporation Mobile GM965/GL960 Integrated Graphics Controlle
r rev 12, Mem @ 0xfeb00000/0


(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
(EE) LoadModule: Module intel does not have a intelModuleData data object.
(II) UnloadModule: "intel"
(II) Unloading /usr/lib/xorg/modules/drivers//intel_drv.so
(EE) Failed to load module "intel" (invalid module, 0)
Comment 5 Antonio A. Olivares 2008-08-12 13:55:21 EDT
I was bitten by this bug as well.  Thanks to Tom for letting me know that it was BZ'd.

[olivares@localhost ~]$ startx
xauth:  creating new authority file /home/olivares/.serverauth.4200


X.Org X Server 1.4.99.906 (1.5.0 RC 6)
Release Date:                         
X Protocol Version 11, Revision 0     
Build Operating System: Linux 2.6.18-92.1.6.el5 i686 
Current Operating System: Linux localhost.localdomain 2.6.27-0.244.rc2.git1.fc10.i686 #1 SMP Fri Aug 8 13:26:20 EDT 2008 i686                                   
Build Date: 05 August 2008  01:17:52AM                                          
Build ID: xorg-x11-server 1.4.99.906-5.fc10                                     
        Before reporting problems, check http://wiki.x.org                      
        to make sure that you have the latest version.                          
Module Loader present                                                           
Markers: (--) probed, (**) from config file, (==) default setting,              
        (++) from command line, (!!) notice, (II) informational,                
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.           
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 12 11:55:00 2008            
(EE) Unable to locate/open config file                                          
New driver is "intel"                                                           
(==) Using default built-in configuration (30 lines)                            
(EE) LoadModule: Module intel does not have a intelModuleData data object.      
(EE) Failed to load module "intel" (invalid module, 0)                          
(EE) open /dev/fb0: No such file or directory                                   
(EE) Screen(s) found, but none have a usable configuration.                     

Fatal server error:
no screens found   

^Cgiving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  unexpected signal 2.              
[olivares@localhost ~]$ su -
Password:                   
[root@localhost ~]# Xorg -configure

X.Org X Server 1.4.99.906 (1.5.0 RC 6)
Release Date:                         
X Protocol Version 11, Revision 0     
Build Operating System: Linux 2.6.18-92.1.6.el5 i686 
Current Operating System: Linux localhost.localdomain 2.6.27-0.244.rc2.git1.fc10.i686 #1 SMP Fri Aug 8 13:26:20 EDT 2008 i686                                   
Build Date: 05 August 2008  01:17:52AM                                          
Build ID: xorg-x11-server 1.4.99.906-5.fc10                                     
        Before reporting problems, check http://wiki.x.org                      
        to make sure that you have the latest version.                          
Module Loader present                                                           
Markers: (--) probed, (**) from config file, (==) default setting,              
        (++) from command line, (!!) notice, (II) informational,                
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.           
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 12 11:55:31 2008            
List of video drivers:                                                          
        trident                                                                 
        mach64                                                                  
        avivo                                                                   
        neomagic                                                                
        i810                                                                    
        tseng                                                                   
        i740                                                                    
        apm                                                                     
        ati                                                                     
        ast                                                                     
        ztv                                                                     
        voodoo                                                                  
        r128                                                                    
        rendition                                                               
        intel                                                                   
        sis                                                                     
        cyrix                                                                   
        sisusb                                                                  
        s3virge                                                                 
        geode                                                                   
        siliconmotion                                                           
        chips                                                                   
        s3                                                                      
[olivares@localhost ~]$ startx
xauth:  creating new authority file /home/olivares/.serverauth.4111


X.Org X Server 1.4.99.906 (1.5.0 RC 6)
Release Date:                         
X Protocol Version 11, Revision 0     
Build Operating System: Linux 2.6.18-92.1.6.el5 i686 
Current Operating System: Linux localhost.localdomain 2.6.27-0.244.rc2.git1.fc10.i686 #1 SMP Fri Aug 8 13:26:20 EDT 2008 i686                                   
Build Date: 05 August 2008  01:17:52AM                                          
Build ID: xorg-x11-server 1.4.99.906-5.fc10                                     
        Before reporting problems, check http://wiki.x.org                      
        to make sure that you have the latest version.                          
[olivares@localhost ~]$ startx
xauth:  creating new authority file /home/olivares/.serverauth.4200


X.Org X Server 1.4.99.906 (1.5.0 RC 6)
Release Date:                         
X Protocol Version 11, Revision 0     
Build Operating System: Linux 2.6.18-92.1.6.el5 i686 
Current Operating System: Linux localhost.localdomain 2.6.27-0.244.rc2.git1.fc10.i686 #1 SMP Fri Aug 8 13:26:20 EDT 2008 i686                                   
Build Date: 05 August 2008  01:17:52AM                                          
Build ID: xorg-x11-server 1.4.99.906-5.fc10                                     
        Before reporting problems, check http://wiki.x.org                      
        to make sure that you have the latest version.                          
Module Loader present                                                           
Markers: (--) probed, (**) from config file, (==) default setting,              
        (++) from command line, (!!) notice, (II) informational,                
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.           
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 12 11:55:00 2008            
(EE) Unable to locate/open config file                                          
New driver is "intel"                                                           
(==) Using default built-in configuration (30 lines)                            
(EE) LoadModule: Module intel does not have a intelModuleData data object.      
(EE) Failed to load module "intel" (invalid module, 0)                          
(EE) open /dev/fb0: No such file or directory                                   
(EE) Screen(s) found, but none have a usable configuration.                     

Fatal server error:
no screens found   

^Cgiving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  unexpected signal 2.              
[olivares@localhost ~]$ su -
Password:                   
[root@localhost ~]# Xorg -configure

X.Org X Server 1.4.99.906 (1.5.0 RC 6)
Release Date:                         
X Protocol Version 11, Revision 0     
Build Operating System: Linux 2.6.18-92.1.6.el5 i686 
Current Operating System: Linux localhost.localdomain 2.6.27-0.244.rc2.git1.fc10.i686 #1 SMP Fri Aug 8 13:26:20 EDT 2008 i686                                   
Build Date: 05 August 2008  01:17:52AM                                          
Build ID: xorg-x11-server 1.4.99.906-5.fc10                                     
        Before reporting problems, check http://wiki.x.org                      
        to make sure that you have the latest version.                          
Module Loader present                                                           
Markers: (--) probed, (**) from config file, (==) default setting,              
        (++) from command line, (!!) notice, (II) informational,                
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.           
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 12 11:55:31 2008            
List of video drivers:                                                          
        trident                                                                 
        mach64                                                                  
        avivo                                                                   
        neomagic                                                                
        i810                                                                    
        tseng                                                                   
        i740                                                                    
        apm                                                                     
        ati                                                                     
        ast                                                                     
        ztv                                                                     
        voodoo                                                                  
        r128                                                                    
        rendition                                                               
        intel                                                                   
        sis                                                                     
        cyrix                                                                   
        sisusb                                                                  
        s3virge                                                                 
        geode                                                                   
        siliconmotion
        chips
        s3
        vmware
        radeon
        ark
        mga
        openchrome
        tdfx
        v4l
        glint
        nouveau
        nsc
        cirrus
        savage
        dummy
        nv
        amd
        i128
        fbdev
        vesa
(EE) LoadModule: Modu[olivares@localhost Documents]$

This process hanged so I had to CTRL + ALT + DELETE to reboot.
Comment 6 Tom London 2008-08-12 17:44:11 EDT
Created attachment 314143 [details]
Xorg.0.log from xorg-x11-drv-i810-2.4.0-2.fc10.i386

xorg-x11-drv-i810-2.4.0-2.fc10.i386 from koji produces black screen with colored stipping in the top one inch or so.

Believe this is the Xorg.0.log from that......

"intel' now loads, but .....
Comment 7 darrell pfeifer 2008-08-12 17:51:49 EDT
The new koji version works for me.

Note: I haven't rebooted, just logged out to gdm, and I have backed out xorg-x11-drivers to the previous  7.3-8.fc10
Comment 8 Tom London 2008-08-13 04:11:37 EDT
It appears that for me, when I update to xorg-x11-drv-i810-2.4.0-2.fc10.i386 and restart gdm, I get a funny black screen with colored stippling on the top of the screen.

But, I get reasonably looking cursor.

Checking over the Xorg.0.log, I noticed that I was getting modes only for the Lenovo builtin screen, not for my external monitor (even though the laptop screen was shut).

[I did this via ctrl-alt-F1, logging in to console login, etc....]

Ctrl-Alt-f7 and opening the lid of the laptop reveals a perfect gdm-greeter screen (at 1024x768) on the laptop screen, but the funny "black with colored stippling with a good cursor" screen on the external monitor.

If I gdm-login using the laptop screen, the laptop screen turns off and the external monitor turns on (at 1280x1024).  I can even start compiz!

I attach below the Xorg.0.log showing the above.
Comment 9 Tom London 2008-08-13 04:13:58 EDT
Created attachment 314176 [details]
/var/log/Xorg.0.log showing "black" external monitor, "active" shut laptop LCD
Comment 10 Tom London 2008-08-13 04:19:54 EDT
Not sure if it is relevant, but:

[tbl@localhost Xorg.0.logs]$ grep PIPE *
Xorg.0.log:(WW) intel(0): Register 0x71024 (PIPEBSTAT) changed from 0x00000242 to 0x00000000
Xorg.0.log:(WW) intel(0): PIPEBSTAT before: status: VSYNC_INT_STATUS LBLC_EVENT_STATUS VBLANK_INT_STATUS
Xorg.0.log:(WW) intel(0): PIPEBSTAT after: status:
[tbl@localhost Xorg.0.logs]$
Comment 11 Tom London 2008-08-14 09:52:20 EDT
I continue to get "both Pipes" active, even though the laptop LCD monitor is closed, causing borkage to be displayed on external monitor.  Opening laptop LCD shows good stuff displayed on it.  Completing gdm login "fixes" this (i.e., laptop LCD powers off, external monitor lights ups at appropriate resolution).

Continue to see in /var/log/Xorg.0.log:

[root@localhost log]# grep PIPE Xorg.0.log
(WW) intel(0): Register 0x71024 (PIPEBSTAT) changed from 0x00000242 to 0x00000000
(WW) intel(0): PIPEBSTAT before: status: VSYNC_INT_STATUS LBLC_EVENT_STATUS VBLANK_INT_STATUS
(WW) intel(0): PIPEBSTAT after: status:
[root@localhost log]# 

[ThinkPad X60, Intel 945 graphics.]

Shall I continue to file here?  Open seperate BZ?
Comment 12 marco crosio 2008-08-19 08:54:20 EDT
*** Bug 459363 has been marked as a duplicate of this bug. ***
Comment 13 Andrew McNabb 2008-08-21 10:37:48 EDT
I've been getting the same error ("Module intel does not have a intelModuleData data object") and the koji RPM seemed to fix it for me.
Comment 14 Tom London 2008-08-26 14:04:36 EDT
(In reply to comment #11)
> I continue to get "both Pipes" active, even though the laptop LCD monitor is
> closed, causing borkage to be displayed on external monitor.  Opening laptop
> LCD shows good stuff displayed on it.  Completing gdm login "fixes" this (i.e.,
> laptop LCD powers off, external monitor lights ups at appropriate resolution).
> 
> Continue to see in /var/log/Xorg.0.log:
> 
> [root@localhost log]# grep PIPE Xorg.0.log
> (WW) intel(0): Register 0x71024 (PIPEBSTAT) changed from 0x00000242 to
> 0x00000000
> (WW) intel(0): PIPEBSTAT before: status: VSYNC_INT_STATUS LBLC_EVENT_STATUS
> VBLANK_INT_STATUS
> (WW) intel(0): PIPEBSTAT after: status:
> [root@localhost log]# 
> 
> [ThinkPad X60, Intel 945 graphics.]
> 
> Shall I continue to file here?  Open seperate BZ?

xorg-x11-drv-i810-2.4.2-1.fc10.i386 seems to fix this.

Thanks!
Comment 15 Aurélien FOUCRET 2008-08-27 11:13:05 EDT
(In reply to comment #13)
> I've been getting the same error ("Module intel does not have a intelModuleData
> data object") and the koji RPM seemed to fix it for me.

Idem for me. I was able to use Xorg only with the downgraded xorg-x11-drv-i810 package from f9. The 2.4.2-1.fc10 version don't fix the bug. I will not try to update to the f10 version until the beta release. I think this will be a critical error and beta won't be released until this bug won't be fixed (thanks to fix me if this is a mistake).

For now I will follow this thread. Don't hesitate to ask me for some details, error reports, any other logs or some tests I can do able to help to resolve the bug. 

PS: excuse my English I am a poor French guy.
Comment 16 Aurélien FOUCRET 2008-08-28 04:53:11 EDT
edit of my previous post :

In fact it was version 2.4.0-1 which fails to start correctly with a intelModuleData error. The koji version (2.4.2-1) start correctly. However there is strange artefacts and compositing (compiz) is very unstable since I use this driver. So I decide to reuse metacity until the situation won't involve. I will test again on the next release of a package.

Thank you everyone for the wonderful work you do on Fedora. I hope it will help you.
Comment 17 Matěj Cepl 2008-09-05 11:39:24 EDT
*** Bug 459298 has been marked as a duplicate of this bug. ***
Comment 18 Matěj Cepl 2008-09-09 19:03:00 EDT
*** Bug 459326 has been marked as a duplicate of this bug. ***
Comment 19 David Jones 2008-09-24 08:57:54 EDT
Further to the above comments.

Recently installed F10 Alpha from DVD version. 

Laptop Compaq Presario C700 with GM945/GL955 mobile graphics.

During installation everything Ok upto where you are prompted to submit your Hardware profile (I selected - Do not provide details) pressing Next to continue the screen goes black, I left the laptop at this point for approx 20mins. Then pressed the power switch, to reboot.
On reboot Xserver started allowing to login, all worked as would be expected, apart from some icons on the toolbar being corrupted as new icons appeared.

kernel-2.6.27-0.166.rc0.git8.fc10.i686
xorg-x11-drv-i810.i386 2.3.2-2.fc9

I used Yum to manually install kernel-2.6.27-0.344.rc7.fc10.i686
On reboot where I would expect login to appear I was left with a black screen.

I can provide the following logs.
anaconda.log
anaconda.xlog
boot
dmesg - kernel-2.6.27-0.344.rc7.fc10.i686
kdm
Xorg.0
Xorg.0.log.old
messages - if of any value showing 
               boot with kernel-2.6.27-0.166.rc0.git8.fc10.i686 
               boot with kernel-2.6.27-0.344.rc7.fc10.i686
Comment 20 David Jones 2008-09-24 09:23:35 EDT
Update to correct Graphics chip

Laptop Compaq Presario C792EZ with GM965/GL960 mobile graphics
Comment 21 Bug Zapper 2008-11-25 21:45:01 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 Vedran Miletić 2009-09-06 04:41:39 EDT
Reporter, this chipset should work now. Are you still seeing this issue?
Comment 23 Vedran Miletić 2009-09-17 07:16:38 EDT
Reporter doesn't reply, and this works for me. It's likely this has been fixed in Fedora 11, and maybe even in Fedora 10 with updates. Closing. If anyone can still reproduce it, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.