Bug 46450 - Installer fails to reload partition tables
Installer fails to reload partition tables
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 46746 48344 48424 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-28 15:12 EDT by Brock Organ
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-10 13:43:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brock Organ 2001-06-28 15:12:51 EDT
Description of Problem:

Using disk druid to delete old partitions and create new ones causes a 
traceback ...

Steps to Reproduce:
1. start tui, nfs minimal install on system with previous partitions
2. use ddruid to remove old partitions, create new partitions
	hda1 - 4000 Mb - /
	hda2 - 512 Mb - <swap>
3. continue in install until traceback (see traceback below)

Additional Information:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 559, in ?
    intf.run(id, dispatch)
  File "/usr/lib/anaconda/text.py", line 386, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 117, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 182, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 301, in turnOnFilesystems
    thefsset.formatSwap(instPath)
  File "/usr/lib/anaconda/fsset.py", line 494, in formatSwap
    entry.fsystem.formatDevice(entry, self.progressWindow, chroot)
  File "/usr/lib/anaconda/fsset.py", line 319, in formatDevice
    raise SystemError
SystemError: 

Local variables in innermost frame:
rc: 256
file: /tmp/hda2
self: <fsset.swapFileSystem instance at 8268df8>
chroot: /mnt/sysimage
entry: <fsset.FileSystemSetEntry instance at 8243ec8>
progress: <method InstallInterface.progressWindow of InstallInterface 
instance a
t 81bec88>

ToDo object:
(iinstdata
InstallData
p1
(dp2
S'diskset'
p3
(ipartitioning
DiskSet
p4
(dp5
S'disks'
p6
(dp7
S'hda'

<failed>
Comment 1 Matt Wilson 2001-07-01 12:58:38 EDT
*** Bug 46746 has been marked as a duplicate of this bug. ***
Comment 2 Matt Wilson 2001-07-02 17:31:42 EDT
*** Bug 46219 has been marked as a duplicate of this bug. ***
Comment 3 Matt Wilson 2001-07-10 05:01:57 EDT
should be fixed in beta2, please try to reproduce.
Comment 4 Matt Wilson 2001-07-10 13:34:41 EDT
*** Bug 48424 has been marked as a duplicate of this bug. ***
Comment 5 Matt Wilson 2001-07-10 13:43:10 EDT
*** Bug 48344 has been marked as a duplicate of this bug. ***
Comment 6 Brock Organ 2001-07-12 16:04:50 EDT
verified fix in qa0711.4 ...

Note You need to log in before you can comment on or make changes to this bug.