Bug 465321 - gnome-session-properties "remember currently running application" button does nothing.
Summary: gnome-session-properties "remember currently running application" button does...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 471153 474214 480068 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-02 19:15 UTC by Jeremy Fitzhardinge
Modified: 2009-06-14 00:55 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-03 17:50:24 UTC
poelstra: fedora_requires_release_note+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 552387 None None None Never

Description Jeremy Fitzhardinge 2008-10-02 19:15:44 UTC
Description of problem:
The "Remember currently running application" button doesn't seem to work.  I would expect that it adds the currently running application*s* to the session to start up.

Version-Release number of selected component (if applicable):
gnome-session-2.24.0-5.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start gnome-session-properties
2. Go to "Options" tab
3. Press "Remember currently running application"
  
Actual results:
Nothing

Expected results:
Adds running applications to list of startup programs.

Additional info:

Comment 1 Matthias Clasen 2008-10-03 04:21:31 UTC
Upstream bug tracking this issue: http://bugzilla.gnome.org/show_bug.cgi?id=552387

Comment 2 Ray Strode [halfline] 2008-11-12 15:32:07 UTC
Not going to get this fixed before F10 and it should be fixed upstream before F11, so I'm going to close this bug UPSTREAM.b

Comment 3 Peter Staubach 2008-11-12 15:56:57 UTC
I thought that closed as UPSTREAM meant that it was already fixed upstream?

How do we track this issue with this bz closed?

Comment 4 Ray Strode [halfline] 2008-11-12 16:09:45 UTC
Hi Peter,

Not necessarily.  Since development primarily happens upstream, we like to move the issues that we aren't tracking for a particular release upstream to make sure everyone is on the same page (it doesn't always go down that way because bug triage is time consuming, but that's the general rule).

If you want to follow along, CC yourself on the upstream report.

Comment 5 Ray Strode [halfline] 2008-11-13 15:26:07 UTC
*** Bug 471153 has been marked as a duplicate of this bug. ***

Comment 6 Daniel Roesen 2008-12-01 12:26:23 UTC
So Fedora won't try to resolve this problem for F10 at all?

Comment 7 Bernd Bartmann 2008-12-01 13:29:13 UTC
Could the original reporter of this bug please re-open it?

Honestly, how can a bug that prevents a major functionality in the default desktop environment just be ignored with CLOSED UPSTREAM, especially as session management was working just fine in older Fedora releases.

So, this is a major regression and should be fixed ASAP.

Comment 8 Matthias Clasen 2008-12-01 14:30:22 UTC
If you want this to be fixed earlier, feel free to chime in with a patch.

Comment 9 Ray Strode [halfline] 2008-12-01 15:36:49 UTC
It's not that this won't get fixed for F10.  It's that there's already traction upstream for this, and there's not reason to duplicate effort.  We can always backport the patch and do an update when it's ready.

Comment 10 Ray Strode [halfline] 2008-12-02 22:29:01 UTC
*** Bug 474214 has been marked as a duplicate of this bug. ***

Comment 11 Derek Atkins 2009-01-14 21:15:27 UTC
So when will this be ready?   Honestly, guys, this is a MAJOR regression!

Comment 12 Ray Strode [halfline] 2009-01-14 21:30:57 UTC
it lost steam upstream and then picked the steam back up again 5 days ago.  So soonish.

Comment 13 Ray Strode [halfline] 2009-01-14 21:31:35 UTC
*** Bug 480068 has been marked as a duplicate of this bug. ***

Comment 14 Derek Atkins 2009-01-15 15:57:25 UTC
Ray, any chance you could keep this bug open so we can track when it gets fixed in F10?  It would be very useful to know (for historical reasons if none other) when this future fix actually makes it into the release?

Comment 15 Ray Strode [halfline] 2009-01-15 16:22:23 UTC
Sure.

Comment 16 Matthias Clasen 2009-03-03 17:50:24 UTC
This is supposed to be fixed in 2.25.92.

Comment 17 Derek Atkins 2009-03-03 18:05:55 UTC
Any chance this will get pushed back into Fedora 10?

Comment 18 Matthias Clasen 2009-03-03 18:27:32 UTC
There are not plans to do so. 
If someone stepped forward and backported the patch to 2.24, we would certainly consider it.

Comment 19 Mike McLeish 2009-04-06 15:39:35 UTC
I would like to help get this fixed in F10. Can someone help me get started?

Comment 20 Zing 2009-06-14 00:10:35 UTC
Is this supposed to be fixed in f11?  I just tried a gnome-session-save and then logged out and logged back in but it didn't save any of of my gnome-terminals like it did in F9.

gnome-session-2.26.1-1.fc11.x86_64

Comment 21 Daniel Roesen 2009-06-14 00:54:24 UTC
Well, at least the "remember currently running application" option in the "Startup applications" preferences works again in F11. Only checked with gnome-terminals though, not with other apps - just need it to open nearly a dozend terminals over several desktops :)

So, try to enable the option, log out, log in again (windows should restore to pre-logout positions), disable option.

Comment 22 Daniel Roesen 2009-06-14 00:55:46 UTC
BTW, if gnome-session-save doesn't work, this should be a separate bug report, as this here is about the specific "remember currently running application" option. I suggest opening a new bug, referencing this one here.


Note You need to log in before you can comment on or make changes to this bug.