Bug 468598 - How to add fonts?
How to add fonts?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
: 471891 475048 510589 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-26 12:55 EDT by Daryll
Modified: 2015-03-03 17:33 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 19:02:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daryll 2008-10-26 12:55:11 EDT
Description of problem:
In previous versions of Fedora you could open fonts:/// in Nautilus and see all the fonts and install new ones. Fonts:/// is no longer recognized by Nautilus. 

Although you can manually put fonts in ~/.fonts and add them that way, that's far from obvious and isn't what is shown in on-line documentation.


Version-Release number of selected component (if applicable):
nautilus-2.24.1-2.fc10.i386


How reproducible:
Every time

Steps to Reproduce:
1. Hit ctrl-l in a nautilus window
2. type fonts:///
3.
  
Actual results:
Could not display fonts:///
Nautilus cannot handle "fonts" locations.

Expected results:
Open the fonts directory

Additional info:
Comment 1 Matthias Clasen 2008-10-26 15:02:25 EDT
Its true. But arguing for fonts:// on the grounds that opening ~/.fonts is non-obivous is a bit incongruent... fonts:// is at least as non-obvious.
Comment 2 Daryll 2008-10-26 15:11:42 EDT
Agreed! It would be better if it was in the places menu.
But at least fonts:/// is documented everywhere. 
It took me, an extremely experienced user, several searches to figure out that I should use .fonts and run the mkfontdir program.
Comment 3 Nicolas Mailhot 2008-11-20 14:46:22 EST
*** Bug 471891 has been marked as a duplicate of this bug. ***
Comment 4 Bug Zapper 2008-11-25 23:15:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Tomáš Bžatek 2008-12-08 05:47:30 EST
*** Bug 475048 has been marked as a duplicate of this bug. ***
Comment 6 An. N 2008-12-08 05:56:49 EST
In earlier versions of Fedora (prior to 10), nautilus was able to manage fonts,
and - more importantly - display icons with the font face and open previews.

This is no longer the case, there are no previews shown for directories containing fonts and there is no way to view a font sheet from natuilus without an external application designed for that purpose. A very good piece of functionality was removed.
Comment 7 Nicolas Mailhot 2008-12-08 06:37:08 EST
The preview bit is fixed in rawhide
Comment 8 Tomáš Bžatek 2009-07-22 09:28:26 EDT
*** Bug 510589 has been marked as a duplicate of this bug. ***
Comment 9 Máirín Duffy 2009-07-23 17:27:24 EDT
That you can preview fonts is nice, but can you install them cleanly too?

I think it is too much to expect artists to drop to a command line or work with non-obvious 'hidden folders' in order to install fonts.
Comment 10 Tomáš Bžatek 2009-07-30 11:27:51 EDT
FYI: http://www.bomahy.nl/hylke/blog/adding-fonts-in-gnome/
Comment 11 Matthias Clasen 2009-08-21 19:02:59 EDT
This has landed in control-center-2.27.90.

Note You need to log in before you can comment on or make changes to this bug.