Bug 469218 - Corrupt text of certain size after scrolling in firefox on XO
Corrupt text of certain size after scrolling in firefox on XO
Status: CLOSED DUPLICATE of bug 467762
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-amd (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 470186 (view as bug list)
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2008-10-30 12:56 EDT by Terry Stewart
Modified: 2008-12-13 19:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-13 19:30:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of problem caused by scrolling (320.37 KB, image/png)
2008-10-30 12:56 EDT, Terry Stewart
no flags Details
Example of problem caused by dragging window overtop (296.64 KB, image/png)
2008-10-30 12:58 EDT, Terry Stewart
no flags Details
X server config file (991 bytes, text/plain)
2008-10-30 20:57 EDT, Terry Stewart
no flags Details
X server log file (36.25 KB, text/plain)
2008-10-30 21:05 EDT, Terry Stewart
no flags Details
X server log file (simplified) (17.62 KB, text/plain)
2008-10-30 21:37 EDT, Terry Stewart
no flags Details

  None (edit)
Description Terry Stewart 2008-10-30 12:56:35 EDT
Created attachment 321961 [details]
Example of problem caused by scrolling

Description of problem:

Under Fedora on an XO, there are particular sizes of text that cause firefox rendering glitches after scrolling or when another window is moved overtop of the firefox window.  

How reproducible:

This is 100% consistent once you find the DPI and font size combination that triggers it.  

Steps to Reproduce:

1. Change DPI to 140 (Appearance->Fonts->Details)
2. Open firefox
3. Go to http://dailykos.com
4. Scroll down or drag another window overtop of any of the main text
  
Actual results:

Lots of random visual noise appears in the text.  The problem goes away if you use the firefox zoom in and zoom out commands.

Additional info:

The same problem appears on other websites; you just have to find the right combination of DPI setting and the font size of the webpage.  It always seems to occur with text of the same size in terms of pixel height.  

The same problem occurs in firefox under Ubuntu on the XO.
Comment 1 Terry Stewart 2008-10-30 12:58:22 EDT
Created attachment 321962 [details]
Example of problem caused by dragging window overtop
Comment 2 Matěj Cepl 2008-10-30 18:27:26 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Terry Stewart 2008-10-30 20:57:36 EDT
Created attachment 322006 [details]
X server config file

This is the standard xorg.conf used on the XO, and gets set by fedora-live-base.ks
Comment 4 Terry Stewart 2008-10-30 21:05:52 EDT
Created attachment 322007 [details]
X server log file
Comment 5 Terry Stewart 2008-10-30 21:37:22 EDT
Created attachment 322009 [details]
X server log file (simplified)

Here's another log file where I've done nothing other than log in, open firefox, and scroll down to see the effects of the bug.

(The previous log file included lots of other actions as well).
Comment 6 Martin Stransky 2008-10-31 04:35:07 EDT
Unable to reproduce on firefox/fedora...the redraw is slow but it works.
Comment 7 Jeremy Katz 2008-10-31 15:11:43 EDT
Terry -- can you try editing the /etc/X11/xorg.conf and adding a line to the geode driver section that is
   Option "MigrationHeuristic" "greedy"
(below the EXA line) and see if that helps?
Comment 8 Terry Stewart 2008-11-01 01:03:26 EDT
Wonderful!  Adding "MigrationHeuristic" "greedy" fixes this problem, and it looks like it fixes the black boxes (bug 462531) and also fixes a rendering bug that I hadn't noticed before: a white box around the wedge in the circle that counts down the 60 seconds in the initial login screen.

Thank you!
Comment 9 Jiri Pechanec 2008-11-06 03:53:00 EST
*** Bug 470186 has been marked as a duplicate of this bug. ***
Comment 10 Bug Zapper 2008-11-25 23:30:35 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Warren Togami 2008-12-13 19:30:48 EST

*** This bug has been marked as a duplicate of bug 467762 ***

Note You need to log in before you can comment on or make changes to this bug.