Bug 471537 - Serious problem with rendering
Serious problem with rendering
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 473140 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 01:37 EST by Pavel Lisý
Modified: 2009-11-20 05:21 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-20 05:21:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rendering problem of intel 810i driver (17.62 KB, image/png)
2008-11-14 01:39 EST, Pavel Lisý
no flags Details
/etc/X11/xorg.conf (835 bytes, text/plain)
2008-11-14 17:15 EST, Pavel Lisý
no flags Details
/var/log/Xorg.0.log (81.57 KB, text/plain)
2008-11-14 17:19 EST, Pavel Lisý
no flags Details
/var/log/Xorg.0.log, Without config (59.99 KB, text/plain)
2008-11-14 17:41 EST, Pavel Lisý
no flags Details
screen shot to demonstrate "boldness" of characters (8.50 KB, image/png)
2008-11-20 18:15 EST, Konrad Karl
no flags Details
Image after mouse moved down (34.77 KB, image/png)
2008-11-21 07:35 EST, Pavel Lisy
no flags Details
Image after mouse moved up (34.88 KB, image/png)
2008-11-21 07:35 EST, Pavel Lisy
no flags Details
Menubar corruption (17.89 KB, image/png)
2008-11-27 07:00 EST, Benjamin Thery
no flags Details
another corrupted screenshot (302.26 KB, image/jpeg)
2009-02-03 11:12 EST, David
no flags Details
another screenshot with some bold characters (133.98 KB, image/jpeg)
2009-02-03 11:17 EST, David
no flags Details
yet another form of screen corruption (190.30 KB, image/jpeg)
2009-02-03 11:20 EST, David
no flags Details

  None (edit)
Description Pavel Lisý 2008-11-14 01:37:08 EST
Description of problem:
Driver has serious problem with rendering, i.e. I can see only half screen "man xorg.conf" in gnome-terminal. I can see only half of letters (with underscore) in gnome menu

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.5.0-3.fc10.i386

How reproducible:
always

Steps to Reproduce:
1.start gnome terminal
2.man xorg.conf
3.
  
Actual results:
see attachement

Expected results:
whole man page

Additional info:
Comment 1 Pavel Lisý 2008-11-14 01:39:47 EST
Created attachment 323538 [details]
rendering problem of intel 810i driver
Comment 2 Pavel Lisý 2008-11-14 13:21:50 EST
I found workaround but it is not solution.

When you set from menu:
System -> Preferences -> Look and Feel -> Appearance 
Tab: Fonts, Rendering: Subpixel smoothing (LCDs)

and then I can see whole font letters again. I don't know how can I change this for login screen (GDM)

But some rendering problems are still there. 
I.e. when I switched to different tab in Appearance dialogue I didn't see icons of themes. But this happens only sometimes.
Comment 3 Pavel Lisý 2008-11-14 13:35:05 EST
You need switch with keyboard (Ctrl-Tab) instead of mouse click to see it
Comment 4 Matěj Cepl 2008-11-14 16:28:50 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Pavel Lisý 2008-11-14 17:15:11 EST
Created attachment 323660 [details]
/etc/X11/xorg.conf
Comment 6 Pavel Lisý 2008-11-14 17:19:12 EST
Created attachment 323661 [details]
/var/log/Xorg.0.log
Comment 7 Konrad Karl 2008-11-14 17:20:34 EST
same problem here. see screenshot at bug 461829 comment #40-42
Thanks,
Konrad
Comment 8 Pavel Lisý 2008-11-14 17:41:34 EST
Created attachment 323668 [details]
/var/log/Xorg.0.log,  Without config
Comment 9 Konrad Karl 2008-11-16 11:34:02 EST
with Option "AccelMethod" "XAA"  I dont have font corruption so far. 

X w/o xorg.conf seems to select EXA.

(Intel Corporation 82865G Integrated Graphics Controller (rev 02))
Greetings,
Konrad
Comment 10 Pavel Lisý 2008-11-16 16:22:47 EST
I can confirm it. With this option rendering and redrawing is OK. 

But system-config-display didn't set it. 
This can be serious problem for many users.
Comment 11 David 2008-11-18 11:15:16 EST
I have the same problem.  The "intel" driver with AccelMethod XAA
works without corruption AFAICT.  The i810 driver doesn't work at
all... says "No screens found" when I select that driver from
system-config-display.  The vesa driver works without corruption.

Here is the smolt profile for this system:
http://www.smolts.org/client/show/pub_f24c96f9-7884-4d14-a298-63a2847d0c0e

This system works fine with i810 and vesa in fedora 8 and X crashed
frequently in fedora 9 (https://bugzilla.redhat.com/show_bug.cgi?id=449460).

Do other people see the "no screens found" problem with i810?
Comment 12 Joakim Ryden 2008-11-18 19:10:23 EST
After today's updates the "intel" driver appears to work without having to set Option "AccelMethod" "XAA" manually. I have the 82852/855GM card in a Dell Latitude 505 laptop. Desktop effects do not work though and just produce a white screen before reverting.

I can confirm David's observation that the i810 driver doesn't work at all and just give a "no screens found"
Comment 13 Matěj Cepl 2008-11-19 06:25:51 EST
Pavel? Could you confirm comment 12? Could we close this bug?
Comment 14 Pavel Lisy 2008-11-19 08:12:19 EST
I can confirm it. It is working now without Option "AccelMethod" "XAA".
Comment 15 Konrad Karl 2008-11-19 12:33:42 EST
Has X been changed so that it selects XAA by default or has EXA made working?
(did not try w/o xorg.conf)

Yesterday I tried EXA (selected in xorg.conf) for a few seconds only and observed
something: When typing in one long line of text in KDE konsole some amount of the already typed characters got displayed somewhat more or less bold.

Difficult to explain, they were not in real bold font but they changed
their perceived grey level somewhat while typing. Using XAA there was no 
such effect. 

The font corruption (only parts of characters visible) did not happen
yesterday.
Comment 16 Konrad Karl 2008-11-20 18:15:19 EST
Created attachment 324252 [details]
screen shot to demonstrate "boldness" of characters

see the bottom line. it got more black after entering some 'd' s.
Comment 17 Michal Nowak 2008-11-21 03:25:48 EST
I am experiencing the same problem as Konrad, having 82852/855GM graphics. EXA being auto-on. One can see it in rxvt (whole lines) and thunderbird (beginnings of lines). Not sure about XXA. 

But the former rendering problem is fixed.
Comment 18 Pavel Lisy 2008-11-21 07:35:10 EST
Created attachment 324294 [details]
Image after mouse moved down
Comment 19 Pavel Lisy 2008-11-21 07:35:49 EST
Created attachment 324295 [details]
Image after mouse moved up
Comment 20 Pavel Lisy 2008-11-21 07:41:21 EST
I am confirming problem with "boldness" of characters. 
It is changing even if I move with move over window.

I've sent two images. You can see difference in one line, but it was the same on all lines before I've made these screenshots.
Comment 21 Michal Nowak 2008-11-24 11:28:28 EST
(removing the needinfo flag, we received Pavel's feedback)
Comment 22 Bug Zapper 2008-11-26 00:21:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 23 Benjamin Thery 2008-11-27 06:58:59 EST
I also see the problem with "boldness" of characters.
And also, I've:
- some random graphic corruptions on gtk controls (button) when I move my mouse over them. (They can't be captured, They don't appear on screen capture)
- graphic corruptions in windows menu bars in the form of series of white characters (often 'F') appearing above the menu bar when the window opens. See attachment below.

Intel chipset 82865G.
Driver: i915?

How do you determine the "AccelMethod" used by the driver?
Comment 24 Benjamin Thery 2008-11-27 07:00:33 EST
Created attachment 324871 [details]
Menubar corruption

Here is the kind of graphic artifact I get on menubar very often when a new window is opened.
Comment 25 Benjamin Thery 2008-11-27 07:24:56 EST
Following the advices from the comments above, I have:
* Installed system-config-display to generate a xorg.conf file
* Added Option "AccelMethod" "XAA"
* Restarted X

Tada! No more display artifacts and font rendering looks a lot better.
Thanks for the tips.

I still can't use Compiz or any apps the require 3D-accelerated OpenGL but I think it belongs to another bug report.
Comment 26 bughead 2008-12-02 12:24:58 EST
(In reply to comment #16)
> Created an attachment (id=324252) [details]
> screen shot to demonstrate "boldness" of characters
> 
> see the bottom line. it got more black after entering some 'd' s.

My bug (473140 https://bugzilla.redhat.com/show_bug.cgi?id=473140) seems to be the same like this one.
Comment 27 Matěj Cepl 2008-12-02 15:37:18 EST
*** Bug 473140 has been marked as a duplicate of this bug. ***
Comment 28 Masao Takahashi 2009-01-09 01:49:24 EST
I have tried a unstable git version of xf86-video-intel-2.6.99 from git server of freedesktop.

The newest version of xf86-video-intel seems to resolve this problem.
No bold face and no artifacts.
Comment 29 David 2009-02-03 11:12:07 EST
Created attachment 330743 [details]
another corrupted screenshot

About 80% of the way down the screen there is corruption.

xorg-x11-drv-i810.i386                  2.5.0-4.fc10
Comment 30 David 2009-02-03 11:17:05 EST
Created attachment 330745 [details]
another screenshot with some bold characters

About 55% down the screen, there is a line with noticeably bolder characters
than those on adjacent lines.
Comment 31 David 2009-02-03 11:20:06 EST
Created attachment 330746 [details]
yet another form of screen corruption

While I was using eog to look at an earlier corrupt screen shot, I noticed a bunch
of vertical tick marks below the menu bar.  They went away after I forced a refresh.
Comment 32 David 2009-02-05 15:09:49 EST
For what it's worth, installation of f11 alpha had horrible screen corruption problems.  I didn't get through more than a few screens before my computer hung completely, but it was obvious that f11 still has major problems with intel graphics support.


On a somewhat related question, how active is the development of this driver?  Ever since fedora 6 (when the driver worked flawlessly), I've had nothing but trouble with this graphics card (which came with my IBM ThinkCentre).  I've reported and watched several bugs, but several have been ignored and others have not been fixed.  I've easily wasted $400 of time reporting bugs, trying workarounds, etc.  Should I just get my company to buy a $100 Nvidia or ATI graphics card and punt on Intel?  I'm willing to try a few more things to provide feedback on f10 or f11 alpha, but I'd like to know that it's actively being worked on.
Comment 33 David 2009-02-05 19:02:24 EST
FYI - I filed a new bug report for the f11 alpha intel X corruption
and hang:

https://bugzilla.redhat.com/show_bug.cgi?id=484276

vesa works without corruption in f10 and works without the 
corruption and the X hang in f11.
Comment 34 Ian Collier 2009-04-21 05:40:50 EDT
Yup, I have the random changes-in-boldness of fonts when typing into an input field too, and Accelmode XAA fixed it (as well as making glxgears seem to go a bit faster).  Unfortunately there's now occasional stray lines on the screen when I move windows around - it's a case of which is the worst of two evils...

xorg-x11-server-Xorg-1.5.3-15.fc10.i386
xorg-x11-drv-i810-2.5.0-4.fc10.i386
Comment 35 Vedran Miletić 2009-11-05 18:11:38 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, including Intel driver, which may have resolved this issue.
To be more precise, Intel has undergone a major rewrite during Fedora 10, 11 and 12 cycles, and whole driver is working a lot better now. Users who have experienced this problem are encouraged to retry with at least Fedora 12 Beta and see if the issue is still relevant.

Please, if you experience this problem on Fedora 12 Beta or up-to-date system running Rawhide, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

We hope to see how many older bugs in Intel driver are still relevant today, in hope that most of them were fixed in rewrite process.

[This is a bulk message for all open Fedora 10 i810-related bugs (39 of them are still open). I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 36 Bug Zapper 2009-11-18 02:47:22 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 37 Ian Collier 2009-11-19 18:44:14 EST
I think it's safe to say that this isn't an issue on F12, thank goodness for small mercies. (Neither the font corruption nor the random stray lines have appeared so far in testing.)
Comment 38 Matěj Cepl 2009-11-20 05:21:46 EST
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.