Bug 480541 - nv driver fails to start X on GeForce 7025/7050/7150 [NEEDINFO]
nv driver fails to start X on GeForce 7025/7050/7150
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
: 465634 468278 471365 473301 478527 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-18 12:35 EST by Jonathan Roberts
Modified: 2010-06-28 07:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:07:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mcepl: needinfo? (jonrob.one)
mcepl: needinfo? (jonrob.one)


Attachments (Terms of Use)
xorg.conf with nouveau driver (615 bytes, text/plain)
2009-01-20 04:23 EST, Jonathan Roberts
no flags Details
xorg.log with nouveau driver (160.56 KB, text/plain)
2009-01-20 04:24 EST, Jonathan Roberts
no flags Details
xorg.log with nv driver (10.21 KB, text/plain)
2009-01-20 04:24 EST, Jonathan Roberts
no flags Details
Patched RPM xorg.log (33.95 KB, text/plain)
2009-01-23 04:57 EST, Jonathan Roberts
no flags Details
Second new RPM xorg.log (33.95 KB, text/plain)
2009-01-26 07:49 EST, Jonathan Roberts
no flags Details

  None (edit)
Description Jonathan Roberts 2009-01-18 12:35:15 EST
Description of problem:

x fails to start on a system with Geforce 7025 integrated chipset. Nouveau works fine. 

Version-Release number of selected component (if applicable):

xorg-x11-drv-nv-2.1.12-6.fc10.i386

How reproducible:

Everytime you try to use the nv driver. 

Steps to Reproduce:
1. Boot live CD or change driver setting on installed system.
  
Actual results:

x fails.

Expected results:

x to start as normal.

Additional info:

Nouveau works fine. Looking at the log, it says that the device is unsupported by the driver, so maybe Fedora should default to Nouveau for this chipset?
Comment 1 Matěj Cepl 2009-01-19 19:38:47 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

And could we get the same set when using nouveau driver as well, please?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jonathan Roberts 2009-01-20 04:23:51 EST
Created attachment 329441 [details]
xorg.conf with nouveau driver
Comment 3 Jonathan Roberts 2009-01-20 04:24:23 EST
Created attachment 329442 [details]
xorg.log with nouveau driver
Comment 4 Jonathan Roberts 2009-01-20 04:24:52 EST
Created attachment 329443 [details]
xorg.log with nv driver
Comment 5 Jonathan Roberts 2009-01-20 04:26:12 EST
Attached requested files. I presume no xorg.conf for nv driver as it occurred after first installation, which no longer uses that file? I could generate one using the system-config-display utility if that would be useful.
Comment 6 Ben Skeggs 2009-01-20 21:52:45 EST
I'd be interested to know if nv simply works on this chipset by adding a case for 0x0530 to the list in nv_driver.c function NVIsSupported().

As far as I'm aware we didn't need to change anything in nouveau (aside from some chipset-specific code that is irrelevant to nv) to support this series of chips, so it could simple be a case of missing pciids for this series.
Comment 9 Ben Skeggs 2009-01-21 20:14:05 EST
Are you able to test a new RPM for me?  This contains a patch to nv which tells it about all the cards of your series, hopefully this'll be all that's required to get nv running on these chips.

The RPM is here:
http://koji.fedoraproject.org/scratch/bskeggs/task_1072860/xorg-x11-drv-nv-2.1.12-6.fc10.i386.rpm

Thanks :)
Comment 10 Jonathan Roberts 2009-01-22 04:32:50 EST
Could you give me some advice on how to install the RPM? When I try, it conflicts with the currently installed package, and if I try to remove it fails because xorg-x11-drivers depends on it. 

Simple question, I'm sure, but will be more than happy to help when I know how :)

Thanks for your work so far,
Comment 11 Ben Skeggs 2009-01-22 19:44:23 EST
It should install with "rpm -ivh --force <rpm filename>".
Comment 12 Jonathan Roberts 2009-01-23 04:56:45 EST
Tried the new RPM, it didn't work :( 

When I changed the driver setting and reset X, it failed to come back at all - couldn't even switch virtual terminals and there was no blinking cursor. Had to do a hard reboot to get anything back, and then boot to run level 3 (apparently xdriver= on  the grub boot doesn't work any more?)

I've attached the xorg.log from the failed attempt.
Comment 13 Jonathan Roberts 2009-01-23 04:57:30 EST
Created attachment 329787 [details]
Patched RPM xorg.log
Comment 14 Ben Skeggs 2009-01-24 03:51:18 EST
Ok, i know where that problem is and have came up with a fix. Unfortunately i won't have a real net connection until i get back to brisbane on monday, so won't be able to build you a new rpm until then. Thanks for testing :)
Comment 16 Jonathan Roberts 2009-01-26 07:47:42 EST
Just tested the latest RPM and although it didn't leave me with just a blank screen, my monitor displayed a sign saying "out of range" and the virtual terminals were extremely garbled with white marks all over - couldn't actually make out the text but they were functional. Had to reboot into run level 3 again and this time edit xorg.conf by hand because system-config-display wouldn't work (it tried to start with nv I think). 

Attaching the log again. 

Hope it helps,
Comment 17 Jonathan Roberts 2009-01-26 07:49:07 EST
Created attachment 329980 [details]
Second new RPM xorg.log
Comment 18 Ben Skeggs 2009-01-31 02:36:39 EST
You definitely installed the new RPM?  The crash is identical to the previous one.  It's possible the crash was in a different place to where I suspected however.  If you're sure you used the new RPM I'll come up with a patch to provide more info as to where the crash is happening.  Thanks again!
Comment 19 Jonathan Roberts 2009-01-31 07:28:57 EST
Well, I just re-installed, and provided the link is correct I'm certain I installed the new RPM. Got the same results as before. The crash actually performs a little differently to the old one from a user perspective. I suppose it's possible I attached the wrong xorg.log... I just grabbed Xorg.1.log the next time I booted up with a running X - looked to me like Xorg.0.log was the log for the most recent successful attempt.
Comment 20 Matěj Cepl 2009-01-31 15:30:43 EST
(In reply to comment #19)
> next time I booted up with a running X - looked to me like Xorg.0.log was the
> log for the most recent successful attempt.

Check their timestamps with ls -l /var/log/Xorg.*.log, but you don't do anything bad when you attach all of them.
Comment 21 Vedran Miletić 2009-09-06 04:24:32 EDT
*** Bug 478527 has been marked as a duplicate of this bug. ***
Comment 22 Vedran Miletić 2009-09-06 04:26:00 EDT
*** Bug 465634 has been marked as a duplicate of this bug. ***
Comment 23 Vedran Miletić 2009-09-06 04:26:18 EDT
*** Bug 471365 has been marked as a duplicate of this bug. ***
Comment 24 Vedran Miletić 2009-09-06 04:26:39 EDT
*** Bug 468278 has been marked as a duplicate of this bug. ***
Comment 25 Vedran Miletić 2009-09-06 04:27:05 EDT
*** Bug 473301 has been marked as a duplicate of this bug. ***
Comment 26 Matěj Cepl 2009-11-05 13:21:26 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 27 Matěj Cepl 2010-02-26 07:24:45 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 28 Bug Zapper 2010-04-27 08:45:30 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 29 Bug Zapper 2010-06-28 07:07:22 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.