Bug 492085 - X application cannot start since libX11-1.1.5-1.fc10; stuck in XOpenIM
X application cannot start since libX11-1.1.5-1.fc10; stuck in XOpenIM
Status: CLOSED DUPLICATE of bug 491813
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
: 492115 492140 (view as bug list)
Depends On:
Blocks: 491979
  Show dependency treegraph
Reported: 2009-03-25 07:02 EDT by Hubert Verstraete
Modified: 2014-06-18 05:11 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 491915
: 491915 (view as bug list)
Last Closed: 2009-03-25 20:25:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
strace of xterm which hangs forever. (1.58 MB, text/plain)
2009-03-25 08:37 EDT, Kelvin J. Hill
no flags Details

  None (edit)
Description Hubert Verstraete 2009-03-25 07:02:26 EDT
Description of problem:
Since I received the libX11 update libX11-1.1.5-1.fc10 some X applications cannot start any more. They are stuck in the library function XOpenIM which never returns. It does not happen with applications made in GTK, but applications like xterm, xarkeia, mgdiff (use Motif) are now broken.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. start xterm or xarkeia or mgdiff
Actual results:
No xterm window appear and xterm does not return.

Expected results:
Have the xterm window appear.

Additional info:
The work around is to downgrade to the previous release of libX11: libX11-1.1.4-6.fc10

The bug is probably the same encountered by windowmaker in bug #491915
Comment 1 Kelvin J. Hill 2009-03-25 08:37:27 EDT
Created attachment 336632 [details]
strace of xterm which hangs forever.

This is an strace output from xterm, showing the problem.
Comment 2 Rex Dieter 2009-03-25 11:27:43 EDT
*** Bug 492115 has been marked as a duplicate of this bug. ***
Comment 3 Misha Karpenko 2009-03-25 11:40:39 EDT
I have the same bug - xterm window doesn't appear when launching under user or even root.
BUT it does appear executing "sudo xterm".
Comment 4 Rex Dieter 2009-03-25 11:53:09 EDT
*** Bug 492140 has been marked as a duplicate of this bug. ***
Comment 5 Luis Garrido 2009-03-25 13:41:23 EDT
For the sake of consolidation there seems to be yet another duplicate here:


This one has hit hard.
Comment 6 Peter Hutterer 2009-03-25 20:25:11 EDT
Consolidating all into Bug #491813.

*** This bug has been marked as a duplicate of bug 491813 ***

Note You need to log in before you can comment on or make changes to this bug.