Bug 494711 - Kernel prevents drive spinning down
Kernel prevents drive spinning down
Status: CLOSED DUPLICATE of bug 507963
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 16:56 EDT by Mace Moneta
Modified: 2009-07-17 16:45 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 16:45:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2009-04-07 16:56:13 EDT
Description of problem:

I booted F11/rawhide to runlevel 1, and confirmed that nothing was polling my second drive (via "sysctl -w vm.block_dump=1"), /dev/sdb, which is normally only mounted for backups. 

However, I could not spin it down.  Every time it went to spin down, I
heard it spin up again immediately (confirmed with 'hdparm -C').  Even manually (via 'hdparm -y'), the drive immediately spun back up.

I booted a F10 liveCD, and the drive spins down no problem.

Version-Release number of selected component (if applicable):

kernel-2.6.29.1-52.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:
1.Verify SMART is off in BIOS
2.Boot to single user mode to insure nothing is polling the drive
3.hdparm -S1 /dev/sdb and/or hdparm -y /dev/sdb
  
Actual results:

Drive does not spin down

Expected results:

Drive spins down

Additional info: Works in F10
Comment 1 Mace Moneta 2009-04-07 17:00:32 EDT
bug 454582 comment 5 may be related.
Comment 2 Bug Zapper 2009-06-09 09:26:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 max 2009-06-16 16:32:38 EDT
I had a script that did sleep my 2nd hard disk with "hdparm -y /dev/sdb" 

In Fedora 10 is was working and after the upgrade to Fedora 11 it did spin down but spins up right away. 

There is a bug listed in the debian bug tracker that's about the same problem. 

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=526516

If I am right, it's about hdparm en pulling the drive to often via udev. 

I couldn't find a rpm of hdparm version >= 9.15. 
1 So I downloaded the source of hdparm
2 make
3 make install

and my problem is gone. The drive is quite noisy...

I hope this comment helps someone.
Comment 4 Mace Moneta 2009-06-16 16:53:25 EDT
I tried hdparm 9.15, and the drive is going idle now.  However, it is being brought active again after a few seconds.  Perhaps udev should skip polling drives that are unmounted and spun-down?  Or perhaps limit the polling on these drives to once a day and at boot?
Comment 5 Peter Backes 2009-07-17 16:33:03 EDT
(In reply to comment #0)
> However, I could not spin it down.  Every time it went to spin down, I
> heard it spin up again immediately (confirmed with 'hdparm -C').

actually, because of the nature of the hdparm bug, hdparm -C is another cause of the drive spinning up.

> Version-Release number of selected component (if applicable):
> 
> kernel-2.6.29.1-52.fc11.x86_64

this bug is incorrectly filed as a kernel bug

see also bug #507963 and bug #511936
Comment 6 Eric Sandeen 2009-07-17 16:45:00 EDT
Even though this bug was filed first :) I think duping it to 507963 is the right answer since that's a bit more descriptive, and on the right component.

*** This bug has been marked as a duplicate of bug 507963 ***

Note You need to log in before you can comment on or make changes to this bug.