This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 507963 - hdparm can't spin down my pata drives
hdparm can't spin down my pata drives
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hdparm (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
: 494711 511936 (view as bug list)
Depends On:
Blocks: 454582
  Show dependency treegraph
 
Reported: 2009-06-24 17:00 EDT by regis.fouret
Modified: 2009-08-15 04:15 EDT (History)
6 users (show)

See Also:
Fixed In Version: 9.16-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-15 04:15:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description regis.fouret 2009-06-24 17:00:38 EDT
Description of problem:
after issuing hdparm -Y /dev/sdb, my drive is entering sleep mode then going immediately active
for another drive it just ignore the sleep mode command and stay active


Version-Release number of selected component (if applicable):
v9.12

How reproducible:
always

Steps to Reproduce:
1.hdparm -Y /dev/sdb
2.
3.
  
Actual results:
drive doesn't sleep

Expected results:
drive should enter sleep mode

Additional info:
bugfix is to update hdparm to version v9.15 which works ok
Comment 1 Peter Backes 2009-07-17 16:33:13 EDT
This is a bug in 7.3 <= hdparm < 9.14. It is caused by hdparm opening the device with O_RDRW instead of O_RDONLY and triggered if udevd is running.

Relevant entries from hdparm ChangeLog:
hdparm-9.14
        ...
        - switch back to O_RDONLY for everything, to keep Debian/udevd happy
                http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=522091
          Note that the kernel returns EFAULT rather than EPERM from SG_IO for
          non-root users, and *no* SG_IO functions work for non-root users now.
...
hdparm-7.3
        ...
        - use O_RDWR instead of O_RDONLY for better SG_IO compatibility

see also bug #494711, which is incorrectly filed as a kernel bug and essentially describes the same issue
bug #511936 is another duplicate of this bug
Comment 2 Eric Sandeen 2009-07-17 16:45:00 EDT
*** Bug 494711 has been marked as a duplicate of this bug. ***
Comment 3 Eric Sandeen 2009-07-17 16:46:09 EDT
*** Bug 511936 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2009-07-17 17:05:26 EDT
hdparm-9.16-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/hdparm-9.16-1.fc11
Comment 5 Peter Backes 2009-07-17 17:34:58 EDT
As expected, the update fixes the problem.
Comment 6 Karsten Hopp 2009-07-18 19:01:20 EDT
re comment #5: Please add this comment at our updates website so that the new package will be pushed to the stable repository automatically when enough positive comments were entered. The link is available in comment #4
Comment 7 Fedora Update System 2009-07-22 17:46:27 EDT
hdparm-9.16-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hdparm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7829
Comment 8 Fedora Update System 2009-08-15 04:15:34 EDT
hdparm-9.16-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.